TABLE OF CONTENTS

Introduction ........................................................................................................................................ iv

Lesson 1: Getting Started
Set up a Local Root Folder to house your Web site, and get acquainted with Dreamweaver’s interface, palettes, and inspectors. Create a new document and do basic text formatting, change headline and paragraph formats and align your text on a page. Preview pages in a browser. ............................................. 3

Lesson 2: Building the Site
Create and format more pages and start building a site. Learn how to import text and reformat it, how to work with images, how to create horizontal rules and lists, and how to create hyperlinks between your pages. ................................. 9

Lesson 3: Adding Image Maps, Animation and Forms
Create an image map and add links, learn to embed multimedia files, and learn to create and incorporate forms of various kinds................................................................. 17

Lesson 4: Creating Tables and Frames
Learn to insert and configure a table and modify it to meet your needs, and create a frameset to make navigating and viewing a site easier. ................................................................. 25

Lesson 5: Using Cascading Style Sheets
Learn how to use style sheets for more control over document formatting. Use Dreamweaver to set up document styles and create and modify an external style sheet. ................................................................. 31

Lesson 6: Working with Dynamic HTML. Uploading Your Site
Learn how to use rollover effects to make pages more dynamic. Work with layers, behaviors, and timelines to create rollover effects and animation. Use Dreamweaver’s built-in FTP capabilities to access your Web server and transfer files. ................................................................. 35
INTRODUCTION

Dreamweaver is a professional Web site authoring program with innovative features and comprehensive design capabilities that are useful for beginners and seasoned Web designers alike.

You can use it to create Web sites visually, with an easy-to-use graphical interface that shows you the changes you make as soon as you make them. And you can do so with confidence that the HTML being generated behind the scenes is consistently clean, concise, and editable.

Unlike most visual Web authoring programs, Dreamweaver doesn’t even alter the HTML code when documents are imported into Dreamweaver from another HTML program.

Dreamweaver offers many features to make designing pages easier. You can test your pages virtually in a number of Web browsers, drop in a variety of multimedia file types at the click of a button, select colors from a Web-safe palette featuring hexadecimal naming conventions, even FTP files to a remote file server from within the program. More advanced features include support for the latest innovations on the Web including Cascading Style Sheets and Dynamic HTML.

In this course you’ll learn by doing, using Dreamweaver to develop sample Web projects step-by-step. You’ll learn to create HTML pages, format text, insert images and multimedia objects, set links, and work with tables and frames, style sheets, and dynamic HTML features.

Dreamweaver comes with an extensive online Help system, featuring tutorials as well as searchable Help files. Most of the palettes also feature ScreenTips that describe icon functions when you hold the cursor over them.

The CD-ROM that comes with the lessons includes sample files to make it easy for you to follow the step-by-step exercises as you go through the lessons.
LESSON 1: GETTING STARTED

OBJECTIVES

By the end of this lesson you will be able to:

- set up a Local Root folder to house your Web site
- understand the Dreamweaver interface, palettes, and inspectors
- create a new document and do basic text formatting
- change headline and paragraph formats and align your text on a page
- preview pages in a browser

SUMMARY

The best way to learn Dreamweaver is by using it. In this lesson you’ll learn how set up a site, use Dreamweaver’s windows and palettes to create a page, add text, and insert an image. You’ll also learn how to access the HTML inspector, and how to preview your page in a browser.

Before opening the program, open the CD-ROM that came with these lessons and copy the folder called “DWwebs” to your hard drive. Put it on the desktop, or where you can easily find it again.

EXERCISES

SETTING UP A SITE

Dreamweaver makes it easy to build a Web site on your local computer and then transfer it to a Web server. Before you start creating pages you should establish a home for your site so the program will keep track of your files as you add more pages, graphics, and other elements.

Designate a Local Root Folder

First we’ll open the program and designate a Local Root folder, which will correspond to the root directory on the Web server. Your local site will become a “mirror” for the site that is actually online.

1. With the program open, select File > Open Site > Edit Sites and click on the New Site button.
2. When the Site Information dialog box opens (Figure 1-1), type in “bookstore” for a site name.
3. Click on the Browse button (PC) or Choose (Mac) to designate a folder on your hard drive to be the Local Root folder for this site. This is the folder where you will store files for this site. Let’s open and designate “bookstore” in the folder called “DWwebs” that we copied from the CD-ROM.
4. The remaining options in the dialog box are to establish the connection between your local site and a remote server. If you have not yet established a remote server you can leave these options empty and go back and fill them in later.
5. Click OK. What you see now is a directory of the site. We will return to this view when we explain how to upload your files to a remote server, but for now close the window to return to the Dreamweaver workspace and let’s build our first page.
USING THE KEY COMPONENTS OF THE DREAMWEAVER WORKSPACE

What you should be looking at now is the **Document window** (Figure 1-2), which displays the current document approximately as it will appear in a Web browser. A blank page opens automatically when you open the program. You can always open another new blank page by selecting **File > New**.

![Figure 1-2: The Document Window](image)

**Figure 1-2**
The Document Window

---

**Setting the Page Properties for Your First Page**

1. With the page open, right-click your mouse (PC) or Control-click (Mac) to open the **Page Properties** dialog box (Figure 1-3), or open it by choosing **Modify > Page Properties** from the menu bar.
2. Type a title in the text box. This is the title that will appear in the browser’s Bookmarks or Favorites list, so it should be descriptive. Let’s call this page “Mythical Bookstore.”
3. Click on the square next to **Background Color**. When the color palette appears you can select a color swatch. The best color for this exercise is white, which is also the default. If you wanted to add a background image you would use the Browse button next to **Background Image**.
4. Now select the square next to **Text Color** and choose a dark color for the text. Note that you can choose different colors for **Link Color** (text that is linked), **Visited Links** (previously selected by a viewer), and **Active Links** (the color of the link while it is being selected). You’ll learn more about links in the next lesson.
5. Click **OK**, then save your page by selecting **File > Save As**. Save it as index.htm. This will become our “entry page” for the site we are building.
The Property inspector

1. After closing the Page Properties window, click on the page and type the words “Mythical Bookstore.” If the Property inspector (Figure 1-4) is not already open, select Window > Properties. The Property inspector displays properties for whatever object is selected.

2. Highlight the words you typed, and let’s use the menus in the Property inspector to change the format and font. Change the format to Heading1 and see how the size and style changes. Change the font face from default to “Arial.” Change the font size to “7” and then back to the default. Click on the Align Center icon (in the group on the right side of the top row) to center the text on the page.

3. Place the cursor after the headline, and hit Enter (PC) or Return (Mac) and then type your address. Highlight the new line, and change the font size to “5.” Change the font color by clicking on the gray box below the text size window. Note that color changes made in the Property inspector apply only to the item selected, not the entire page. Leave the window open. We’ll look at more options later.

Dreamweaver’s color palette is “Web safe,” and uses six-digit Hexadecimal color names. Colors selected will stay true even if the end user’s computer only displays 256 colors. If you’re not satisfied with the available choices, you can create custom colors by clicking on the Painter’s Palette icon in the bottom right of the color palette and then creating your own colors in the Color Picker dialog box. When seen on a 256-color display these will default to the nearest Web-safe color. You can also enter a desired color’s “hex” number or color name (e.g., Navy, Maroon, White) directly into the window.

The Property inspector

1. After closing the Page Properties window, click on the page and type the words “Mythical Bookstore.” If the Property inspector (Figure 1-4) is not already open, select Window > Properties. The Property inspector displays properties for whatever object is selected.

2. Highlight the words you typed, and let’s use the menus in the Property inspector to change the format and font. Change the format to Heading1 and see how the size and style changes. Change the font face from default to “Arial.” Change the font size to “7” and then back to the default. Click on the Align Center icon (in the group on the right side of the top row) to center the text on the page.

3. Place the cursor after the headline, and hit Enter (PC) or Return (Mac) and then type your address. Highlight the new line, and change the font size to “5.” Change the font color by clicking on the gray box below the text size window. Note that color changes made in the Property inspector apply only to the item selected, not the entire page. Leave the window open. We’ll look at more options later.
The Object palette

1. Select Window > Objects to open the Object palette. This tool contains buttons for inserting various types of objects, such as images, tables, layers, applets, and other multimedia elements. (Figures 1-5 to 1-6). Holding the cursor over each icon on the palette will open a caption box explaining the function of each button.

2. Now let’s insert a picture between your headline and address. Place your cursor just after the headline and hit Enter (PC) or Return (Mac) to open up a space.

3. Click on the top button on the Object Palette to choose an image, and browse to the folder “images” inside your new Local Root folder (“bookstore”). Click on the jpeg file called books.jpg, and click select then click OK. The picture should appear just below your headline.

4. Place your cursor next to the image without selecting it, and then click on the Align Right icon in the Property inspector and it will move to the right side of the page. Now click on the Align Left icon, then use the Align Center icon to move it back to the middle of the page.

5. Click on the picture, and note that the Property inspector automatically changes to show you the image properties including its dimensions and location. (Note that the Align option here is for aligning a picture next to a block of text, not aligning it on the page. Ignore it for now. We’ll cover this in the next lesson.)

6. If you don’t like your color combination, change your choices in the Page Properties window or the text Property inspector.

7. Remember to save your changes.

Figure 1-5
The Objects palette with the common icons displayed. Other choices are Forms icons and Invisible icons.

Figure 1-6
The small arrow at the top of the Object palette scrolls to open up other tool sets, including a comprehensive set of Forms tools.

Figure 1-7
The Invisibles Panel on the Objects palette is for inserting objects not visible in the document window.
The Launcher

Another important tool is the Launcher, which you can access from Window > Launcher. Launcher has buttons for opening and closing various inspectors and palettes, including the HTML inspector. We’ll save the others for later.

The HTML Inspector

Open the HTML inspector by clicking on the HTML button of the Launcher and you see the HTML source code the program has generated for the page you are working on. Source code containing HTML tags lies behind every HTML page, with code elements set off in brackets as in this example, where <H1> is similar to Heading1 in a word processor.

```
<h1 align="center"><font face="Arial" color="#9933FF">Mythical Bookstore</font></h1>
```

Elements are instructions that tell the browser how to display the page. Note that each set of instructions requires a beginning and ending tag. The align="CENTER" statement is an example of an attribute; it modifies the element to which it was added. All the user actually sees are the words “Mythical Bookstore.”

If you are new to HTML, you should spend some time studying the code for the tags you create so you understand them and can edit the code directly when necessary. There are now many good books available to help you learn HTML.

Dreamweaver lets you have both the document window and the HTML inspector open at the same time so you can see changes in both views. When you highlight text in the document window, it is also highlighted in the HTML inspector, seen in Figure 1-9.

Note that you can access the HTML inspector in four different ways: from the Launcher, from the F10 hotkey, from a button on the bottom of the document window, or from the menu bar (Window > HTML).

Figure 1-9
The HTML inspector in Dreamweaver is fully integrated with the WYSIWYG editor. Changes made in one window are automatically reflected in the other.
PREVIEWING YOUR WORK IN A WEB BROWSER

It’s wise to test your work in a variety of browsers to make sure your pages will look good to everyone who sees it.

Setting up a Preview Browser

Dreamweaver makes it easy for you to set up preview links to different browsers. It’s a preference setting you can access from either the Edit > Preferences menu, or from File > Preview in Browser > Edit Browser List.

1. Choose Edit > Preferences and look over the various Preference topics seen in Figure 1-10. You may want to change some of the settings later. Pick Preview in Browser, and click Add.

2. Type the name of a browser (such as Netscape or Internet Explorer) in the Name text box, then click the Browse button to open the Select Browser dialog box and locate the browser you want to configure.

3. Double-click on the program file for the browser, and click Open, then OK. The browser has now been added to the list in the Preview in Browser options. You can add other browsers in the same way, and designate one of them as your primary browser.

4. Now let’s preview our page using Dreamweaver’s F12 hotkey to instantly open the page in the primary browser. Compare it to the page as it appears in your Document window and the HTML inspector.

Later we’ll learn how Dreamweaver can also test your documents in various browsers “virtually” without a visual preview, and give you a report on any problems or deficiencies. You can access this useful feature from File > Check Target Browsers.

MORE EXERCISES TO SHARPEN YOUR SKILLS

• Look through the various menu options and start getting comfortable with the program. Explore the various palettes and inspectors, and the different ways you can access and use them.

• Follow the exercise in this lesson to create another new page substituting different text and images (or make a copy of the page you just created), and experiment with the color and alignment settings in the Page Properties and Property inspector Windows.

• With the new page open, open and close the HTML inspector using the F10 key and track how the changes made in the document window are reflected in the HTML code. Make changes in the HTML code and see what happens to the document window display.

• Explore the tutorials and Help section that come with the program.