LESSON 6: WORKING WITH DYNAMIC HTML. UPLOADING YOUR SITE

Because the animation part of the DHTML section is quite involved it is broken into modules. In the interest of time you may want to save some of them until after you have worked through the section covering Dreamweaver’s built-in FTP capabilities. To see the finished animation open flydone.htm inside the “animate” folder.

DYNAMIC DHTML

OBJECTIVES

In this lesson you will learn:

• how Dreamweaver simplifies the process of creating Dynamic HTML for 4.0 Web browsers with layers, behaviors, and timeline palettes
• how to create rollover effects
• how to create and use layers
• how to apply behaviors
• how to use the timeline
• how to combine the power of these features to create an animation

CONTEXT

One of Dreamweaver’s most attractive features is its support for Dynamic HTML. DHTML is a powerful component of the HTML 4.0 specification, bringing fast-loading animations, complex interactivity, and pixel-perfect placement of elements to Web sites.

Dynamic HTML combines the power of HTML with JavaScript, making it possible to dynamically change the attributes of HTML tags. You can make a page come alive with rollovers and animation. Dreamweaver also offers you access to a long list of new HTML 4.0 tags, offering other new features never before possible on a Web page.

The biggest limitation of DHTML is that it only works in 4.0 and later browsers and that each browser has its own approach to DHTML. Internet Explorer 4.0 supports more DHTML features than Netscape 4.0.

In this lesson, you’ll learn how to use Dreamweaver to assign behavior and create a rollover, how to make layers to place elements exactly where you want them on a page, and how to animate a series of images on the timeline.
EXERCISES

Look at Dreamweaver’s Help files, where DHTML makes a list of topics expand and collapse when a topic is selected.

1. In Dreamweaver, choose Help > Dreamweaver Help Topics.
   Dreamweaver launches a Web browser and displays the Help files. To see DHTML effects, you’ll need a 4.0 or later browser.

2. In the frame on the left, click once on the word “Workspace.”
   The outline expands to show a list of subtopics, as seen in Figure 6-1.

3. Click Workspace again to collapse the outline.

Figure 6-1

Dreamweaver’s Help files use DHTML to make the topic list on the left expand and collapse when a topic is selected.

Dynamic HTML in action causes the outline to expand and collapse on the page. If the outline doesn’t collapse or expand and the Help files don’t look like Figure 6-1, you might be using an older browser. If you are using a 4.0 or later browser and it still doesn’t work, make sure you have enabled JavaScript in your browser preferences.

To make your Web site accessible to viewers with older browsers, use the Check Browser feature, available in the Behaviors Library. The Check Browser feature enables you to determine what browser your viewer is using and then direct the viewer to an appropriate Web page. Many designers create two pages, one with DHTML features and another that works in older browsers, and then direct viewers accordingly with the Check Browser feature. You can learn more about targeting browsers in Dreamweaver’s Help files.
CREATING BUTTON ROLLOVERS

Rollovers can be used to create a variety of effects when a viewer passes a cursor over an image. In the following exercise, you’ll create a script that will allow you to replace one image with another when a cursor moves over it. It’s a popular feature for navigation bars.

Remember that to see the results of this exercise, you will need to open the page in a browser that supports JavaScript. This example will work in Netscape 3.0 or later or in Internet Explorer 4.0 or later.

To create a new page with a rollover button

1. Open the document called coming.htm, which is located inside the “bookstore” folder at the root level.
2. Insert your cursor in the center of the page in the space between “Here’s a preview.” and “Where are they hiding?”
3. Use the Object palette or choose Insert > Image and browse to find redlite.gif in the “images” folder. Double-click on it.
4. With the image selected, enter the name “redlight” in the text field in the far left of the Property inspector, as seen in Figure 6-2.
   Naming the image is very important, because JavaScript uses this name when it swaps two images (which is what creates the rollover effect).

![Figure 6-2](image)

Figure 6-2

Before you can apply a behavior to an image, you must enter a name for it in the text field on the left in the Property inspector.

5. In the Property inspector, set the Border to “0.”
6. Select the image and choose Window > Behaviors to open the Behaviors inspector (or access it from the Launcher palette).
7. Choose 4.0 Browsers from the pop-up menu in the Events pane.
   Use this pop-up menu to choose the browsers you want to target with your designs. Only the features that work in the selected browsers will be available. When you choose an option, such as Netscape 3.0, many of the features in the list are grayed out because they only work in 4.0 browsers. Choosing 4.0 Browsers will create DHTML that is supported in both Netscape and Microsoft.
8. Hold down the + button and select “onMouseOver” from the Events list on the left.
9. Hold down the + button on the right pane, and select “Swap Image” from the Actions pop-up list, as seen in Figure 6-3. You may get a message at this point, stating there must be an <a> tag for the button to work (based on the assumption that the image is a button and linked to something, which it often will be). If you don’t want to link to anything just yet, just click OK and Dreamweaver will automatically create a link tag around the image. (The program inserts a # sign in place of a URL in the Property inspector so the rollover will work even though it is not linked to anything.)
10. In the Swap Image dialog box, select image “redlight” from the list of Named Images.
11. Click the Browse button and navigate to the “images” folder where you will pick the image to swap for redlight.gif. Double-click on grnlite.gif and click OK.
12. Hold down the + button and select onMouseOut from the Events list.
13. Select Swap Image Restore from the Actions pop-up list. Click OK in the resulting dialog box.
14. Use the F12 hotkey or choose Edit > Preview In Browser from the menu bar and preview your work in a browser. Use Netscape 4.0 or later or Internet Explorer 4.0 or later.
15. Now let’s link this file to the rest of your site. Open the file coftable.htm, highlight the words, “coming attractions,” and use the Property inspector to make a link to coming.htm.

CREATING ANIMATIONS WITH LAYERS AND TIMELINES (ADVANCED)

If you’ve ever seen a cartoonist at work you know that an animation is really a series of still images. Rapidly displaying them in sequence creates the illusion of motion. The toughest part of animation is creating the still images. For that you will need a drawing or paint program.

Dreamweaver makes an easy job of putting your images together and creating an animation, using layers for absolute positioning, and a timeline to animate these layers.

In the following exercises, you’ll create a rather silly animation of a fly that flits around your screen until it is squashed with a fly swatter. To create this illusion, you’ll use two different images of the fly, one that looks alert and another that looks squashed. You’ll also use an image of a fly swatter. This is a great example of how just a few images can be used to create an animation sequence.

If you want a preview of what this will look like when finished, use an Internet Explorer or Netscape 4.0 browser to open the file flydone.htm in the “animate” folder.
Create and position layers

1. Open a new page in Dreamweaver and save it as fly.htm.
2. If the Object palette is not open, choose Window > Objects.
3. Select the Marquee Layer icon in the Object palette. A crosshair-style cursor appears on the page.
4. Click and drag this cursor to create a box in the upper left hand corner of the page. This “box” is a layer. After you create it, you can move it anywhere on the page by clicking on the handle in its upper left corner and dragging it.
5. Click to place your cursor in the layer. Choose Insert > Image.
6. Use the Browse button in the Insert Image dialog box to locate fly.gif in the “images” folder in the “animate” folder (not the “images” folder in bookstore).
7. Double-click on fly.gif and click OK. An image of a fly appears in the layer.
8. Click on the Marquee Layer icon in the Object palette again.
9. Click and drag to create another layer in the bottom right corner of your screen.
10. Click to place your cursor in the new layer and use the Object palette to insert an image. Browse to the same “images” folder and double-click on the image up.gif. The Fly Swatter image appears in the layer, in an up position.
11. Repeat steps 9-11, but this time insert down.gif (an image of a fly swatter in a down position). Overlap the two images.

When you finish, the page should look like Figure 6-4. The fly should appear in the upper left corner, and both Fly Swatter images should be in the bottom right about where they appear in Figure 6-4. If you need to move any of the images, click to select the layer and then click on the handle in the layer’s top left corner and drag the layer to the desired location.

12. Choose Window > Layers to open the Layers palette seen in Figure 6-4.
13. Click Layer1 to select the fly layer, and use the Property inspector to change the name to “fly” (see Figure 6-4).
14. Click Layer2 and Layer3 in the Layer palette and use the Property inspector to name them “up” and “down,” respectively. Save the page as fly.htm.

Note: Make sure that “fly” is first in the Z index in the Layer palette. If you followed these steps in order, it should be correct. If not, double-click on the numbers listed in the z-index column in the Layer palette and change them so “fly” is 1, “up” is 2, and “down” is 3.

ANIMATING LAYERS WITH THE TIMELINE

After you create the layers described in the previous steps, you can use the timeline to animate them. If you’ve never used a timeline before, this might seem a bit complex at first. Take it slowly and follow each step carefully, even if it doesn’t fully make sense to you.

If you want to start fresh from this point, or just want to make sure you are beginning this section with the right layers, open the file layers.htm in the “animate” folder to be ready for the following exercise.
Use the Timeline to Animate Layers

1. With the file fly.htm open, choose Window > Timelines.
2. Click to place a check mark in the Autoplay box in the top of the Timeline palette.
   Autoplay will cause the animation to begin as soon as the page is loaded. If you want to control an animation with a mouse click or some other viewer action, leave the Autoplay box blank.
3. Click to select the layer with the fly image.
4. Click and hold the layer-positioning handle at the top left corner of the layer, and drag the entire layer over the Timeline palette. Release the layer when a new sprite appears in the first row, as seen in Figure 6-5.

Note: You are not actually moving the layer itself—you are dragging the layer onto the timeline to create a sprite representing the layer. Sprite, as it is used here, refers to the purple bar that appears when you drag an element, such as a layer, into the timeline.

5. Click to select the layer with the fly swatter image in the up position. Then use the layer-positioning handle in the top left corner to drag the layer over the timeline and create a second sprite just below the first one you created for the fly layer.

6. Click to select the layer with the fly swatter image in the down position. Then use the layer-positioning handle in the top left corner to drag the layer over the timeline and create a third sprite just below the first two.

7. Click to select the circle at the end of the sprite that represents layer 1 (the fly layer). A circle represents a keyframe. Drag this one until the circle extends to frame 25 in the timeline.

8. Click to select the keyframes at the end of the sprites representing the two fly swatter layers and extend the sprites to frame 30 in the timeline.
   After you complete this step, the timeline should look like Figure 6-6. Be sure the sprites that represent each layer are placed in the 1, 2, and 3 positions in the timeline and that they all start as far to the left as possible. You can move the sprites around by clicking and dragging them in the timeline.

9. Click to select the fly layer. In the timeline, move the keyframe marker to the last frame of the Fly sprite.
   The keyframe marker is the red slider that can be moved across the sprites.

Figure 6-5
Click and drag a layer over the timeline to create a sprite representing that layer.

Figure 6-6
After you complete step 8 in the exercise for animating layers with the timeline, the timeline should look like this.
10. Now you are going to create the animation path the fly will take. Select the fly image, then click on the layer-positioning handle and drag the fly layer down and across the page until it’s on top of the fly swatter layers, as seen in Figure 6-7.

11. To create a more elaborate flight path for the fly, make sure the fly layer is still selected and move the frame marker (the red slider) to frame 10. Then click on the layer-positioning handle on the layer and drag the fly layer to another place on the screen. A keyframe circle appears in the sprite in the timeline, representing the new location. You can now use the frame marker to create additional keyframes anywhere along the timeline. Notice that as you move the frame marker back and forth in the timeline, the position of the fly layer changes on the page. Figure 6-8 shows a rather elaborate path with three keyframes in the fly layer sprite.

SWAPPING IMAGES IN ANIMATION SEQUENCE

To create the illusion that the fly gets squashed when it gets hit with the fly swatter, you need to swap the image of the healthy fly with an image of a squashed fly. The following exercise will walk you through the steps to continue developing this animation and swap the fly image.

If you want to start fresh with a file that is ready for the next steps, open time.htm in the “animate” folder and start with step 1. Otherwise, just continue where you left off.

To swap images in an animation

1. Images (like Behaviors) must have a name before they can be manipulated by JavaScript. Before you can swap images, you have to name them. To do so, click to select the first keyframe in the timeline so the fly returns to the starting position in the animation sequence. Then select the fly image (make sure you select the image, not the layer), and in the top left of the Property inspector, enter “flyimage” in the name field. Warning: Don’t abbreviate this name to “fly.” You’ve already named the layer “fly,” and you cannot name an image the same as you named the layer.
2. Select the last keyframe of the fly sprite in the timeline. Make sure you have just selected that frame, and not the entire sprite. If the entire line is darkened, you’ve selected the entire sprite.

3. Choose Modify > Add Behavior to Timeline. The Behaviors inspector opens.

4. With the words “OnFrame25” selected in the left pane, choose the + in the right pane and select Swap Image, as seen in Figure 6-9.

5. In the Swap Image dialog box seen in Figure 6-10, choose the fly image in the Named Images field and then browse to locate the image squashed.gif in the “images” folder in the “animate” folder. Double-click squashed.gif to select it. Click OK.

6. Close the Behaviors inspector and save the page.

7. Save the page and preview your work in a browser.

**CONTROLLING LAYER VISIBILITY**

The final step in completing this silly animation is to change the visibility of the fly swatter layers and create the illusion of motion as the swatter swats the fly at the end of the sequence. Continue where you left off in the last set of steps, or open the file swap.htm in the “animate” folder and begin with step 1 in this exercise.

**To change the visibility of layers in an animation**

1. In the Timeline inspector, click to select the “up” sprite and then move the keyframe marker to frame 25.

2. Choose **Modify > Timeline > Add Keyframe**.

3. In the Property inspector, scroll down the Vis menu and select hidden, as seen in Figure 6-11. This will make the layer invisible when it is previewed in a browser.

4. Select the down sprite in the timeline and move the keyframe marker to the first frame. In the Property inspector, scroll down the Vis menu and select hidden.

**Figure 6-9**
*You can apply behaviors such as Swap Image to keyframes in a timeline.*

**Figure 6-10**
*Changing the fly image in the Swap Image dialog box*

**Figure 6-11**
*Use the Vis menu in the Property inspector to control the visibility of a layer.*
5. With the down sprite still selected, move the keyframe marker to frame 25 and choose Modify > Timeline > Add Keyframe.

6. Select just the keyframe at frame 25 of the down sprite. In the Property inspector, change the Vis option to visible.

   This will cause the down sprite to be visible only at frame 25 in the sequence, providing the appearance of a quick strike of the fly swatter.

7. Save the file. Then choose File > Preview in Browser > and select Netscape 4.0 or Internet Explorer 4.0 to see the results of your animation.

   The fly should buzz around your screen until it gets swatted, and the entire sequence should end with the squashed fly visible and the swatter back in the up position as seen in Figure 6-12.

The rollover effect and animation you created in this lesson represent just the beginning of what you can do with DHTML. Dreamweaver provides an extensible library of behaviors, and you can add your own if you know JavaScript. You can also download new behaviors and install them easily. You’ll find a growing list of additional behaviors at the Dreamweaver Web site at www.dreamweaver.com. Now let’s link this file to the rest of your site. Open coming.htm and change the “shoo fly” link from flydone.htm to fly.htm.

**MORE EXERCISES TO SHARPEN YOUR SKILLS**

**DHTML**

1. Add additional behaviors to the button in the first exercise.

2. Go back to the fly animation and add more keyframes to the fly sprite so the fly moves around the screen more before it gets swatted.

3. Follow the steps to create a rollover effect using your own images.
USING FTP TO UPLOAD YOUR WEB SITE

OBJECTIVES

In this lesson you will learn:

• how FTP enables you to transfer documents around the Internet
• why you need an FTP account, a login ID, and a password to get access to a server
• how to use Dreamweaver’s built-in FTP capabilities
• how to access your Web site and transfer documents

CONTEXT

After you build and test your Web site on your own computer, you’ll want to transfer the site to a server. To do this you need File Transfer Protocol (FTP) software. To make things easy for you, Dreamweaver includes this capability and integrates file-transfer functions with other related features, such as a Check Out feature to help you keep track of files other people might be working on in the same site. If you use relative links as you create HTML pages on your own computer, you can transfer the directory lock, stock, and barrel to the Web server. As long as the various elements remain in the same position relative to each other, all of your links and other references will work the same way on the server as they work on your hard drive.

Most servers are case-sensitive Unix boxes. If you use Dreamweaver’s browse feature to set your links, all of the file names and link references should be fine, but if you enter the path and filenames manually, make sure you are consistent in your use of upper and lowercase. Links on Windows machines don’t have to match case, but they do on a Unix system. If you find that some of your links are broken when you transfer your site, case is a likely cause. A good way to avoid broken links is to get into the habit of naming your files consistently, either all uppercase or all lowercase.

SETTING UP DREAMWEAVER TO WORK WITH YOUR SERVER

Before you can transfer your Web site to your server, you’ll need some information from your Internet Service Provider (ISP) or system administrator. You will need to know:

• Your server’s Internet address
• Your login ID
• Your password
To Set up Dreamweaver to Work with your Server

1. Choose File > Open Site > Edit Sites.

   The Site Information dialog window opens as seen in Figure 6-13.

2. Next to FTP Host enter the name of your server (for example, ftp.server.com).

3. Next to Host Directory enter the path to your Web site.

   The path represents the location of the directory where you store your site on the host server and usually looks something like this: /users/mywebsite/

4. Next to Login, enter your user name for your server.

5. Next to Password, enter your password.

   Your password appears in the box as asterisks (*) to help protect your privacy from anyone who might be looking over your shoulder or who might gain access to your computer while you are away.

6. Check the Save box if you want Dreamweaver to remember your name and password so you don’t have to enter it every time you log on to your server.

   Be aware that if you do this, anyone using your computer can gain access to your site.

7. Click OK.

Activate CheckIn and CheckOut Capability

1. Choose Edit > Preferences.

2. When the Preferences Dialog box opens select Site FTP.

3. Make sure that Enable File Check In/Check Out is active. Check the box if it is not already checked.

   This feature will help you to accurately “mirror” your local site on the remote server so that both have exactly the same file structure, and maintain version control, especially when more than one person are working on the same files from different computers. This prevents overwriting someone else’s changes.

Although it is possible to use Dreamweaver’s FTP capability to move files back and forth between your local server and your remote Web server without using the CheckIn/CheckOut feature it is not recommended. It’s too easy to overwrite a file accidentally, especially if more than one person is working on the same site.

CheckIn/CheckOut allows only one version of a file to be “hot.” Typically this will be the one on the Web server until someone “Checks Out” that file to work on it. The process may seem complex until you get the hang of it, but once you get comfortable, it can save you wasted time and energy.
Transfer Files Between your Hard Drive and a Remote Server

1. Choose File > Open Site.
2. From the Remote Site list, select the name of the site you want to upload.
3. Click the Connect button.

   If you’re not already connected to the Internet, the Connect button should start your dial-up connection. If you have trouble connecting this way, try establishing your Internet connection as you usually do to check email or surf the Web, and then choose Connect again. After you’re online, Dreamweaver should have no trouble establishing an FTP connection with your host server.

   Figure 6-14
   Dreamweaver displays the contents of the remote server as a directory listing in the left side of the Site window. In the right-hand window, you can see the files on your local machine.

4. Take a look at the Sites window. If you have successfully connected to your server, you will see on the left a list of the contents of your Web site folder on your server. On the right, you’ll see a list of the contents of the Web site folder on your own computer.

   You’re almost ready to transfer the first of your files.

5. At the top of the page identify the standard FTP Get and Put buttons. You could use these buttons to move files back and forth, but this is not the recommended procedure. The most secure way to transfer files is via the CheckIn and Check Out feature mentioned earlier.

   You could check files in and out with the Checked Out checkbox next to the Get and Put buttons, but there’s still a better way. This checkbox is most useful as an indicator of a file’s current status—to tell you if a highlighted file is checked in or out.

6. The recommended way to upload files to your server is to highlight the file(s) you want to transfer, then Right click (PC) or Control click (Mac) to open the context dialog box seen in Figure 6-15, and select Check In.

7. A dialog box will open asking if you want to include dependent files (images and other objects linked to the page, or pages linked in a frameset). If you want to be absolutely certain all files and links are current, click Yes.

8. Dreamweaver will then copy and upload the selected files to the Web server. You will see a lock icon on the files on your local server after you check in a file, indicating that the remote file is the active version. You will need to check the file out from the remote server before working on it again.

9. To check out a file so you can work on it again, highlight the file you want and right click or Control click to open the Context menu, then choose Check Out. You will now see a green checkmark on both versions of the file. Anyone else accessing the same site while you have checked out the file will see a red check telling them the file is checked out and they cannot make any changes.
Figure 6-15
The best way to check files in and out is with the Context menu that opens when you highlight one or more files and then right click (PC) or Control click (Mac). This ensures that you always have the current version of a file posted on the Web, and that only one person at a time is working on the same file.

MORE EXERCISES TO SHARPEN YOUR SKILLS

- Experiment with transferring files to and from your server using the Get and Put commands and then with the Check In and Check Out feature.
- If possible, set up a connection to another server.