LESSON 3: INTERACTIVITY BASICS

OBJECTIVES

In this lesson, you’ll learn to:

• make your Flash movie interactive
• apply actions to specific frames
• create interactive buttons
• create and edit symbols in the Library

CONTEXT

Thus far you’ve built a multi-layered animation from scratch. When you publish your movie to the Web, you could just let the movie play over and over again. But wouldn’t it make your Web site visitors happy if they could start, stop, and otherwise control the animation?

Flash offers a great set of tools for adding interactivity to your movies. You can apply controls to individual frames of your movie, or you can create buttons that launch actions such as starting an animation, stopping, switching between scenes, and even launching another Web site.

EXERCISES

ASSIGNING AN ACTION TO A FRAME

Flash provides a variety of Actions which you can apply to frames or buttons. Actions include starting or stopping an animation, jumping to a particular frame, switching to a different scene in the movie, or going to another Web site. You’ll start with a simple example: adding a Frame Action to your ant movie to make the movie loop.

Use the Go To Action to Loop Your Movie

You may want your movie to loop, which means that it will play over and over again. While you can assign a “loop” attribute to the HTML tag which plays your movie on the Web (see Lesson 6 for more details), you may want to build this function into the movie itself.

If your movie ant.fla is not currently open, open it now and go to the Animation scene that you built in the previous lesson.

1. First, check the Control menu to see if Loop Playback is turned on. If it is on, select it again to turn it off (the check mark should disappear).
2. Play your movie with the Controller. Notice that the animation plays just once and then stops. You’ll now add a new frame action to make the movie play continuously.
3. It’s a good idea to place frame actions on their own layer. Choose Insert > Layer, and name the new layer “Actions.”
4. Click on frame 20 of the Actions timeline. This should be the last frame of the entire animation.
5. Choose Insert > Keyframe to add a keyframe at frame 20. You can apply actions only to keyframes.
6. Double-click frame 20 to bring up the Frame Properties dialog box.
7. Click the Actions tab.

8. The first button shows a plus sign and a small arrow. Click the + button for access to the various actions which you may add to your frame. Select Go To. Flash will add this command to the list of actions on the left.

9. The Parameters area will be displayed on the right. Leave most of the choices on their default settings. Check the box next to Go to and Play (Figure 3-1).

10. Click OK to finish. You have just told Flash that when the animation reaches the last frame, it should go back to the very first frame and play the animation again. This will occur each time the animation ends, creating an endless loop.

11. Choose Control > Enable Frame Actions to show how the action will work.

12. Using the Controller, play the animation. With the frame action you just added, the movie should once again loop continuously.

![Figure 3-1](image)

*Figure 3-1*

*The Actions tab in the Frame Properties dialog box*

**CREATING INTERACTIVE BUTTONS**

The same actions you saw in the Frame Action dialog can be added to buttons on your animation, which users can then click to control the movie. You’ll add three control buttons to your animation: Stop, Start, and Flash Info, which will take users to the Macromedia Flash Web site.

Note that buttons must be symbols, although you can convert a normal graphic into a button by making it a symbol.

**Create a STOP Button**

1. Make sure nothing on the Stage is currently selected
2. Choose Insert > Create Symbol.
3. In the Symbol Properties dialog box, type the name “Stop,” and select the behavior Button. Then click OK to finish.
4. The screen changes to Symbol editing mode. The cross-hair in the middle of the Stage gives you a reference point for the center of your button. Notice also that the Timeline status display (right under the Layers area, as shown in Figure 3-2) changes to indicate you’re editing a symbol rather than a movie scene. Notice also that the right-hand tabs have changed to give you access to the symbols currently in your Library.
5. Use the drawing tools to draw a simple button. Select the Pencil tool in Rectangle mode. Choose a deep blue for the color and a solid one-point line. Draw a rectangle centered around the crosshairs.
6. Add text to your button. Choose the Text tool and select blue as the text color. Set the type as Helvetica or Arial 18 point Bold. Click the Text tool inside the rectangle and type “STOP.” Use the Arrow tool to position the text so that it is centered on the button. If you need to change the point size of the text, do so now.

7. Save your work.

![Image of the Timeline and Stage in Symbol Editing mode.](image)

Figure 3-2
The Timeline and Stage in Symbol Editing mode. Notice that the Timeline status display indicates you are working on a button called Stop.

Add States to the Button

Every Flash button has four different states: Up, Over, Down, and Hit. The Up frame is the default for the button. The Over frame is displayed when a user rolls the cursor over the button. The Down frame is displayed as the button is being clicked. The Hit frame is a little different from the other states; it indicates which area of the button actually responds to a mouseclick. The user will never actually see the Hit frame, so it can be larger or smaller than the button image itself.

Notice how Flash has already created frames for these four states in your button symbol timeline. In this exercise, you’ll create images for the four frames of your STOP button. Refer to Figure 3-3 to see how they should look.

1. The four button states are listed at the top of the Layer 1 timeline. The Up state already has a keyframe and an image, which is the button you just created. In the timeline, click and drag from the Over frame to the Hit frame to select all three empty frames.

2. Choose Insert > Keyframe.

3. Click on the Over frame in the timeline to work on the Over state of the button.

4. Select the Paint Bucket tool from the toolbar, and choose a light blue color from the Fill Color pop-up. Fill the inside of the button rectangle with this blue color.

5. Click on the Down frame in the timeline.

6. Select the Text tool and highlight the word “STOP” on the button by double clicking it. In the Text Color pop-up on the toolbar, select white to turn the text white.

7. Select the Paint Bucket tool, and choose a deep blue similar to the border of the button. Fill the inside of the button with this color.

8. Changing the Hit frame will be a bit more complicated. First, click on the Hit frame in the timeline.
9. To quickly select all the parts of the button, choose Edit > Select All. Now delete the button using the Backspace or Delete key.

10. Turn on onion skinning using the Onion Skin button at the top left of the Timeline. You should see a blue rectangle where the button is drawn.

11. Select the Pencil tool in Rectangle mode. Choose black from the Line Color pop-up. On the Stage, draw a rectangle over the blue rectangle of the button. The black rectangle should be at least as big as the button; it can be a little larger if you’d like.

12. Select the Paintbucket tool with black as the Fill Color. Fill the inside of the black rectangle. This solid black area is the Hit area of your button.

13. Save your work.

![Figure 3-3](image)

*The four frames of the STOP button: Up, Over, Down, and Hit.*

Create the Start Button by Copying from the Library

Since you just did all that work to make the STOP button, you might as well save time by reusing it for the START button. This will also guarantee that the START and STOP buttons are the same size, color, and typeface.

1. Turn Onion Skinning off.

2. Choose Window > Library. Notice that the Stop button has been added as a new symbol to the Library. Click the name “Stop” in the list of symbols to select it.

3. In the Library window (Figure 3-4), the down-pointing arrow at the top right is the Symbol pop-up menu. Click this pop-up, and select Duplicate to create a copy of the STOP button.

4. A new Symbol Properties dialog appears. Give the new button the name Start, and click OK.

5. The Library should now include the new START button symbol. The button (which currently looks exactly like the STOP button) should show up on the Stage, with the four states intact. Now all you’ll need to do is change the text on the button from “STOP” to “START.”

6. On the Timeline, click on the Up frame.

7. Using the Text tool, select the word “STOP” on the button and type in “START.”

8. Repeat this change for the Over frame and the Down frame. You don’t need to change the Hit frame at all.

9. Save your work.

![Figure 3-4](image)

*The Library window*
**Create the Flash Info Button**

You’ll create the last button in the same way, but you’ll probably need to make the text smaller to fit inside the button.

1. With the START button selected in the Library window, choose Duplicate from the Symbol pop-up menu.
2. In the Symbol Properties dialog, name the new button “Flash” and click OK.
3. Click on the Up frame of the new button in the Timeline.
4. Using the Text tool, change the button text from “START” to “Flash Info.” Highlight the text and change the font size to 12 points.
5. Change the text in the Over and Down buttons in the same manner.
6. Save your work.

**Add Buttons to Your Animation**

Now that you’ve created three buttons, it’s time to add them to your animation and attach the appropriate actions.

1. Choose **Edit > Edit Movie** to exit Symbol Editing mode and return to your animated movie.
2. Choose **Insert > Layer**, and give the layer the name “Buttons.” You’ll place the buttons on this layer.
3. In the Library window, highlight the STOP button. The button image should appear in the top part of the window. Drag the image of the button onto the Stage, and place it under the grass on the left side of the Stage.
4. Do the same with the START button, placing it next to the STOP button.
5. Drag the Flash button onto the Stage, placing it at the lower right side of the Stage. The Stage should now look like Figure 3-5.

![Figure 3-5](image)

*Where’s the picnic?*

*Place the new buttons on their own layer in the animation.*
Define Button Actions

Finally, you’ll add the appropriate actions to your buttons.

1. With the Arrow tool, click on the STOP button to select it.
2. Choose Modify > Instance. (An Instance refers to one occurrence of a Library symbol which has been placed on the Stage. You could use the STOP button in several different places in your movie; each placement would be a separate Instance.)
3. When the Instance Properties dialog appears, click the Actions tab.
4. Click the + button and select Stop from the Frame Actions pop-up. Since there are no parameters to set, click OK to finish.
5. Double-click the START button. Double-clicking is a shortcut to the Instance Properties dialog. In the Actions tab, click the + button and select the Play action. Click OK.
6. Double-click the Flash Info button. You’ll program this button to go to the Macromedia Flash Web site. In the Actions tab, click the + button and select Get URL. In the Parameters area, type “http://www.macromedia.com/flash” in the URL area. Click OK to finish.
7. Now that you’ve programmed all the buttons, save your work.

Test Your Buttons

1. Select Control > Enable Buttons. This control allows your buttons to work properly on the stage. If you later wish to edit the buttons, you’ll need to turn Enable Buttons off.
2. Using the Controller, play the movie.
3. Try clicking each button to see how it works. Notice when the different button states are displayed.
4. The Flash Info button won’t work from within Flash. You’ll see it in action in Lesson 6 when you export your movie. For now, you’ll just have to go on faith that it works.

MORE EXERCISES TO SHARPNEN YOUR SKILLS

• Create a new introductory scene. Make a “Start the Movie” button, and program it to switch to the Animation scene and run the movie.
• Try attaching different actions to the frames and buttons in your animations. Experiment with different parameter settings.
• Design some more buttons. Try different ways of changing how the buttons look in their different states.
• Refer to the Flash Help Topics and Guided Tour to learn more about adding interactivity to your movies.