LESSON 5: ADVANCED DRAWING TECHNIQUES

OBJECTIVES

In this lesson, you’ll learn how to:

• apply gradient fills
• modify graphics by smoothing, straightening, and optimizing
• understand the difference between grouped and ungrouped images
• master the use of Library symbols

CONTEXT

Now that you’ve been through the basic steps of creating an interactive animation, it’s time to learn some more advanced drawing techniques. In this lesson, you’ll learn various ways of modifying the images you’ve already created, and you’ll learn to use some tools which have not yet been covered.

EXERCISES

CREATING GRADIENT FILLS

A gradient is a blend between more than one color. So far, you’ve only used solid colors in your animation. In this exercise, you’ll draw a sky and fill it with a blue gradient.

Draw a Sky

1. If your movie file ant.fla is not already open, open it now.
2. Create a new layer and name it “Sky.”
3. Drag the Sky layer down to the bottom layer of your Timeline.
4. Click on the Sky layer icon and choose Hidden Others. This will make it a little easier to work on the new layer.
5. Select the Pencil tool in Ink mode, and choose a light blue color from the Line Color pop-up. Select a two-point Line Thickness. The Line Style should be Solid.
6. Draw a free-hand outline of a shape for the sky. See Figure 5-1 for an example of how it might look.

Figure 5-1
The Sky layer, with other layers hidden
Select the Paint Bucket tool. In the Fill Color pop-up menu, notice the row of special buttons along the bottom. These are the pre-mixed gradients. The single button on the bottom row is for the Colors window, where you can create your own custom colors and gradients.

8. Select the **Colors window** button. The Colors window will appear (Figure 5-2).

![Figure 5-2](image)

**Figure 5-2**

Mix gradients and solid colors in the Colors window.

9. Click the **Gradient** tab.
10. The **Type** pop-up menu should say **Linear**. If **Radial** is selected instead, change it to Linear.
11. Just above the Type pop-up is the **Gradient Definition bar**. This shows the colors in your gradient. Each of the two **Color pointers** above the bar represents a point on your gradient. Click the Color pointer on the right.
12. The large colorful rectangle on the right is the **Color Space**, and to the right of it is the **Hue Bar**. Click on a blue area toward the top of the Color Space, and drag the arrow on the Hue Bar until you’ve picked a medium sky blue.
13. Go back to the Gradient Definition bar and click the Color pointer at the top left of the bar. Once again, choose a blue color from the Color Space. But this time use the Hue Bar to select a light blue.
14. By now you should have a subtle blue gradient for the sky. Click the **New** button at the bottom left of the dialog box, and then close the Colors window.
15. With the Paint Bucket tool, click inside the sky outline to fill it with the blue gradient. If nothing happens when you click the Paint Bucket, you may not have completely closed the outline of the sky. No problem! In the modifier area for the Paint Bucket tool, click the **Gap Size** button (it’s right underneath the Fill Color pop-up), select **Close Large Gaps**. You should now be able to fill the sky.
16. Save your work.

**RESHAPING LINES AND FILLS**

In Flash, you can change the shape of lines, fills, and brush strokes. You’ll practice these techniques by touching up the sky which you just created.

**Reshape the Sky Using the Arrow Tool**

1. Select the Arrow tool from the toolbar. Move the Arrow cursor over the edge of the sky until you see a small curve or angle appear just to the side of the Arrow cursor (Figure 5-3). This indicates that you can begin reshaping a line.

![Figure 5-3](image)

As you reshape curves, the Arrow cursor changes.
2. Click and drag on the edge of the sky to change its shape. Notice that both the outline and fill change together.

3. Now, click once on the outline of the sky to select it. Delete it using the Backspace or Delete key.

4. Notice that you can continue reshaping the sky, even after you've deleted its outline.

**Reshape the Sky Using Smooth, Straighten, and Optimize**

In freehand drawing, the lines you draw are often not as straight as you would like them to be, and your curves may have extra bumps and squiggles. Flash provides some tools to automatically straighten and smooth your drawings.

1. Click on the sky with the arrow tool to select it. The entire blue area should be highlighted.

2. Choose **Modify > Curves > Smooth**. Notice how the shape of the sky changes. You can invoke the same command by clicking on the Smooth button in the modifier area of the toolbar (this is the button labelled with a curvy “S”). Click the Smooth button a few more times and watch as the shape of the sky becomes progressively smoother. If you wish, choose Edit > Undo several times to restore the shape of the sky.

The **Straighten** command has a different effect depending on what type of shape you apply it to. In some situations it will simply straighten the individual line segments of a shape. In others, it will perform shape recognition: that is, it will try to turn the original shape into a recognizable geometrical form such as a circle, square, or triangle.

1. To illustrate this difference, first draw the outline of a star, using the Pencil tool in Ink mode. Draw it quickly, somewhere on the blank area of the Stage.

2. Deselect the sky shape. Double-click the star to select its outline. Choose **Modify > Curves > Straighten** or click the Straighten button on the toolbar (right next to the Smooth button). Reapply Straighten until the segments making up the star are completely straight. This should take only a few applications.

3. Deselect the star and select the sky.

4. Click the Straighten button a number of times. Watch as the sky shape eventually becomes an oval.

5. Choose **Edit > Undo** to restore the sky to a shape you like.

The final curve modifier, **Optimize**, is similar to both Smooth and Straighten. It smooths shapes by optimizing the number of curves making up a complete shape. By doing so, it also helps reduce the file size of your Flash movies.

1. With the sky selected, choose **Modify > Curves > Optimize**. Leave the default settings and click OK. Flash will report on how many curves were eliminated during optimization.

2. Deselect the sky and double-click to select the star. Delete the star.

3. Save your work.

**UNDERSTANDING GROUPS AND STACKING**

This set of exercises will help you become more familiar with the Flash drawing environment. It will also teach you how to arrange overlapping elements in your images. Using layers on the Timeline is one way of placing elements in front of and behind one another. But as your drawings become more complex, the number of layers can quickly multiply and become difficult to manage. Fortunately, there is another way to arrange your images. By selectively using Group and related commands, you can gain more control over drawings within a single layer in your animation.
Create a Cloud

While Flash is a vector-based drawing tool, it doesn’t always preserve the integrity of the shapes you draw. This can complicate things when you want to reposition different objects on the same layer. To demonstrate this, draw a cloud on top of the sky.

1. Select the Brush tool. Choose a large brush size, and select light gray from the Fill Color pop-up.
2. Draw a cloud-like shape which overlaps some of the sky and some of the blank Stage. It might look something like the shape in Figure 5-4.
3. Now reposition the cloud. Select it with the Arrow tool, and move it to the right. Notice that the shape of the sky has changed in a manner which would be difficult to fix.
4. Choose Edit > Undo several times to delete the cloud and restore the sky to its original shape.

Fortunately, there is a way to draw objects which allows them to hold their shape even while overlapping other objects. The key is to turn individual objects into grouped objects.

1. Use the Arrow Tool to select the sky. Choose Modify > Group. Deselect the sky.
2. Select the Brush tool again, with a large brush size and a light gray color.
3. On an empty section of the Stage, draw a new cloud.
4. Select the cloud with the Arrow tool and choose Modify > Group.
5. Move the cloud on top of the sky. Move it around, and notice that the sky maintains its shape. Leave it in roughly the same position as the cloud in Figure 5-4.

Change the Stacking Order

Turning parts of your drawing into groups also allows you to easily change how they overlap, even on the same layer. As a demonstration, try changing the stacking order of the sky and cloud.

1. Select the cloud.
2. Choose Modify > Arrange > Send to Back. Note that the cloud is now partially hidden by the sky.
3. With the cloud still selected, choose Modify > Arrange > Bring to Front to bring the cloud back to the top of the stack.

You’re now done with these drawing exercises. To view the sky with the rest of your animation, click the Sky layer icon and choose Show All. You may keep this layer or delete it. (To delete, click the Sky layer icon and choose Delete Layer.)

CHANGING LIBRARY ELEMENTS

In this last exercise, you’ll learn more about Library elements. You’ll create new Instances of the ant character, and then modify both the Instances and the Library symbol.

Create a New Ant Scene

1. Choose Insert > Scene.
2. Double-click on the new Scene tab to bring up the Scene Properties dialog. Name the scene “Marching Ants.”
3. Choose Window > Library.
4. Select the Ant symbol in the Library, and drag it onto the Stage.
5. Choose Modify > Transform > Scale and Rotate. Enter “50” into the Scale % field. Click OK to finish.
6. Choose **Edit > Duplicate** to copy the ant. Move the copy to the side. Duplicate again. You should now have three small ants on your screen. Arrange them in a marching line from left to right.

7. Each of these ants is an Instance of the Ant symbol in the Library. How can you be sure? Double-click the third ant to bring up the Instance Properties dialog. Click on the Definitions tab, and you’ll see the list of symbols in your Library. Notice that “Ant” is highlighted.

**Modify Instances of the Ant**

Now, you’ll turn two of the ants into fire ants by making them red. But you’ll change the ants using different methods.

1. Deselect the third ant, and select the second one. Double-click on it to bring up the Instance Properties dialog.

2. Click on the **Color Effect** tab. Choose **Tint**.

3. In the Tint Amount % box, type “50” In the Red box, type “255”. Notice the preview of your ant in the upper left.

4. Click OK to finish. You’ll see that the ant has been shaded red.

5. Now deselect this ant and select the third ant. Rather than changing the color of the entire ant, you’ll turn selected areas of the ant’s body bright red.

6. Choose the Paint Bucket tool, and pick a fiery red color from the Fill Color pop-up. Click the Paint Bucket on the third ant. Why doesn’t anything happen? Because you can’t modify individual pieces of an instance of a symbol.

7. So, you’ll need to break the ant into its constituent pieces. Choose **Modify > Break Apart**. Notice that the crosshair has disappeared, indicating that the link between this instance and the master Ant symbol has been severed.

8. Choose **Edit > Edit Selected**. (If Edit Selected is not available in the menu, you can double-click on the ant instead.) This will allow you to edit the separate parts of the ant without ungrouping it. Notice that the other two ants are faded back.

9. Choose the Paint Bucket tool again and a bright red color. Now fill each of the three parts of the ant’s body with the red. This time, it should work like a charm.

10. To return to normal editing mode, choose **Edit > Edit All**.

**Modify the Ant Symbol**

What if you want to make a global change to the ant, say turn its antennae purple? The Symbol Library makes this easy.

1. In the Library window, click on the Ant character. In the top pane, double-click on the Ant image to launch Symbol Editing mode. The ant will appear on its own stage, ready for editing.

2. Select the Ant, and choose **Modify > Ungroup**. (Don’t worry, this won’t affect how the Ant symbol works.) Choose **Edit > Deselect All**.

3. Choose the **Ink Bottle** tool from the toolbar. This tool will change the attributes of lines in your drawing. In the modifier area, select a bright purple color, and a one-point line.

4. To change the color of the antennae, click with the Ink Bottle on each small line segment making up the antennae. You may need to zoom in on the image to do so. It will probably take you about seven clicks to change both antennae.

5. When you’re finished, choose **Edit > Edit Movie** to return to your animation. Notice that the Ant symbol in the Library now has purple antennae.

6. Look at each of the three ants in your scene. The first two now have purple antennae just like the master Ant symbol. But the third ant, the one which was broken apart, still has black antennae. That’s because this ant is no longer an instance of the master Ant symbol.

7. Switch back to your Animation scene by clicking on its scene tab. Guess who else has purple antennae!

Hopefully this exercise has helped you understand the relationships between Symbols, Instances, and Groups. In summary, just remember that you can make only certain changes to an Instance while it’s still linked to its Symbol. These include scaling, rotating, animating, and applying Color Effects.
MORE EXERCISES TO SHARPEN YOUR SKILLS

• Try drawing new images with some of the techniques you’ve just learned.
• Draw a number of different shapes and test how they are affected by Smoothing, Straightening, and Optimizing.
• Create several shapes, make each shape a group, and practice changing their stacking order.
• In addition to creating your own drawings in Flash, you can also import graphics in bitmap format, or from other drawing programs. Refer to the Flash Help Topics on how to use the File > Import command.
• Feeling ambitious? Select the Ant symbol in the Library and animate it. To do so, launch Symbol Editing mode, and then use the Ant symbol’s timeline just as you would a normal timeline. Try making its legs and antennae move. Also, try moving the eyes so it seems to be looking around. Then, return to your Animation scene and watch as the ant moves its legs while it runs across the screen; it’s an animation within an animation!