# TABLE OF CONTENTS

Introduction ........................................................................................................ iv

Lesson 1: The Fireworks Environment
Learn the differences between vector and bitmap graphics,
how to set up a Fireworks document, how to use the Fireworks
tools and palettes, and how to work with layers. ................................. 1

Lesson 2: Working with Vector Graphics and Text Objects
Get familiar with the basic tools for creating and modifying
images in Fireworks. Create and import graphics, use the text
tool and attach text to a path. Create shapes, curved and
straight line segments, and create paths with the brush tool.
Get acquainted with the align tools. Apply fills and gradients.
Work with the Web 216 palette. ................................................................. 11

Lesson 3: Buttons, Rollovers, and Live Effects
Add effects, create masks, and attach text to a path. Edit
bitmap graphics. Create standard buttons using the default
button states. Apply Fireworks “Live Effects” to text and
shapes. Create your own custom rollover effects for buttons,
and use the Paste Inside command. ....................................................... 21

Lesson 4: Animation
Animation adds interest to a Web page. Learn to incorporate
Fireworks animation techniques into your Web page. Use layers
with frames. Create symbols and instances. Use tweening for
motion and for creating transformations. Set the timing of
an animation. ................................................................................................... 29

Lesson 5: Image Optimization
Optimizing images for the Web is an important part of the graphic
development process. Learn the differences between the main
image formats. Set palette options and create transparent GIFs.
Use Fireworks to create GIF animations. Use the Export Preview
dialog box to preview different formats and settings, and batch
process images for efficiency and then export them. ......................... 35

Lesson 6: Image Maps and Slicing
Adding links to selected parts of your graphics is an integral part
of building a visually interesting, effective site. Learn to create
and edit links and build an image map with URL objects. Learn
how to use Fireworks to slice graphics and generate HTML,
inTEGRATING ROLLOVERS. ................................................................. 41
INTRODUCTION

Fireworks simplifies the process of creating and optimizing graphics for the Web.

Traditionally, Web designers used a bitmap tool like Photoshop to create images, a vector-based drawing program to create text, a hodge-podge of filters, utilities, and shareware to apply effects and make image maps and animations, DeBabelizer to optimize JPEG and GIF graphics, and then a browser for preview. Revising a graphic often forced designers to erase and start over.

Fireworks gives you the ability to combine vectors and bitmaps, apply Live Effects, optimize palettes, and preview image quality. There’s no need to switch to other applications and utilities with Fireworks. It is the start-to-finish solution for creating and optimizing Web graphics.

Using Fireworks, you can slice apart your Web graphics to mix compression types and file formats for the fastest downloads possible. You can even incorporate rollovers into sliced graphics, set text blocks as GIFs, crunch photos as full-color JPEGs, and automatically generate an HTML table to reassemble your sliced graphics.

It also generates the JavaScript for rollovers, including image preloads for fast action when the mouse moves over the button.

In this hands-on course you’ll learn how to use Fireworks’ features to create graphics incorporating both bitmap and vector elements, using an exciting toolbox full of special effects. You’ll build buttons, and add rollovers, and create a GIF animation. You’ll learn to optimize images, and use the Export Preview to compare formats and palette choices before making a final decision. And you’ll learn to use Fireworks to make image maps and slice graphics.

Fireworks comes with an extensive online Help system you can reference when you have a question. Most of the tool palettes also feature Screen Tips that describe icon functions when you hold the cursor over them. In addition, a PDF of the Fireworks manual is located at program/macromedia/fireworks/using-fireworks for the Windows platform and in the Fireworks application folder, using Fireworks directory for the Macintosh.

You can also check the Macromedia Web site at www.macromedia.com for software updates, news, and tips to make your work more productive.

You’ll find Fireworks to be a versatile, useful tool which will make your Web design efforts easier and more fun. We hope you enjoy it.
LESSON 1: THE FIREWORKS ENVIRONMENT

OBJECTIVES

In this lesson you will learn:

• the differences between vector and bitmap graphics
• how to set up a Fireworks document
• how to use the Fireworks tools and palettes
• how to work with layers

CONTEXT: VECTOR AND PIXEL BASED IMAGES IN ONE ENVIRONMENT

Fireworks is both a vector graphics and a bitmap graphics application. Typically computer graphics are one of two types: vector objects created in an application such as Macromedia FreeHand, and bitmap images created in an application such as Adobe Photoshop.

Vector objects are composed of paths, and bitmap objects are composed of individual pixels. Fireworks combines the organic look of bitmap objects with the flexibility, control, and editability of Bezier paths in a single environment. In this lesson we’ll get acquainted with Fireworks’ interface, tools, and work environment, and learn how to work with vector graphics and bitmaps at the same time.

EXERCISES

An Image with Vector and Bitmap Components

1. Launch the Fireworks application.
2. Choose File > Open from the menu bar and select 2type.png, which you will find inside the folder “Lesson 1,” inside the folder “FWlessons” that you transferred from the CD-ROM.
3. Click Open. The image you see in the document window has both a bitmap image (the butterfly) and vector graphics (Figure 1-1).

Figure 1-1
The document window. A Fireworks canvas can be up to 6000 pixels wide by 6000 pixels tall. You can move and resize the panels, toolbox, and toolbars to customize your environment.
4. Select the Pointer tool on the Fireworks toolbox (Figure 1-2).

5. Click once on the butterfly bitmap portion to select it.

6. Select the Magnification tool and click and drag a rectangle around a small part of the butterfly bitmap image (Figure 1-3).

7. Select 100% from the Document magnification pop-up menu located on the View Control toolbar in the lower-left corner of the screen (Figure 1-4).

8. Select the Subselection tool and click once on the outermost path of the more free-form vector image. Once a path has been selected with the Subselection tool, the points become visible (Figure 1-5).

9. Select the Magnification tool, and use it to click and drag a rectangle around a small part of the selected path. Select 100% from the Document magnification pop-up menu located in the lower-left corner on the View Control toolbar (Figure 1-6). Using the Subselection tool, click on one of the point handles and rotate it slightly.

The path reshapes and the shadow reshapes as well. By creating editable paths with bitmap attributes, Fireworks ensures that your work is fully editable throughout every stage of the design process.

Fireworks blurs the distinction between vector graphics and bitmap image graphics. The path of a Fireworks object has an editable vector path. Yet it may also have a wide, textured stroke, an image fill, and an effect such as a drop shadow, bevel, or glow.
Figure 1-7
Expanded Toolbar. The toolbox on the left side of the document window contains 32 tools, some of which are contained in tool groups which are shown expanded in this figure. To display a tool group, press and hold any tool with triangle in the lower right-hand corner. For an explanation on the use of each tool see the following page.
<table>
<thead>
<tr>
<th><strong>Use this tool</strong></th>
<th><strong>To</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Pointer</td>
<td>Select and drag objects</td>
</tr>
<tr>
<td>Select Behind</td>
<td>Select objects behind other objects</td>
</tr>
<tr>
<td>Crop</td>
<td>Discard portions of an image</td>
</tr>
<tr>
<td>Export Area</td>
<td>Export a portion of your document</td>
</tr>
<tr>
<td>Subselection</td>
<td>Select an object within a group or points on a path</td>
</tr>
<tr>
<td>Marquee</td>
<td>Select a rectangular pixel area in Image Edit mode</td>
</tr>
<tr>
<td>Ellipse Marquee</td>
<td>Select an elliptical pixel area in Image Edit mode</td>
</tr>
<tr>
<td>Lasso</td>
<td>Select a freeform pixel area in Image Edit mode</td>
</tr>
<tr>
<td>Polygon Lasso</td>
<td>Select a polygonal pixel area in Image Edit mode</td>
</tr>
<tr>
<td>Magic Wand</td>
<td>Select pixel areas of similar color in Image Edit mode</td>
</tr>
<tr>
<td>Hand</td>
<td>Pan the view of the document</td>
</tr>
<tr>
<td>Magnify</td>
<td>Change view magnification</td>
</tr>
<tr>
<td>Line</td>
<td>Draw straight lines</td>
</tr>
<tr>
<td>Pen</td>
<td>Draw paths by anchoring points</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Draw rectangles, rounded rectangles, and squares</td>
</tr>
<tr>
<td>Ellipse</td>
<td>Draw ellipses and circles</td>
</tr>
<tr>
<td>Polygon</td>
<td>Draw polygons and stars</td>
</tr>
<tr>
<td>Text</td>
<td>Create text blocks</td>
</tr>
<tr>
<td>Pencil</td>
<td>Draw one-pixel pencil strokes</td>
</tr>
<tr>
<td>Brush</td>
<td>Draw brush strokes using Brush panel settings</td>
</tr>
<tr>
<td>Redraw Path</td>
<td>Redraw portions of a selected path using Brush panel settings</td>
</tr>
<tr>
<td>Scale</td>
<td>Resize and rotate objects</td>
</tr>
<tr>
<td>Skew</td>
<td>Slant and rotate objects, and change perspective</td>
</tr>
<tr>
<td>Distort</td>
<td>Distort and rotate objects</td>
</tr>
<tr>
<td>Freeform</td>
<td>Pull a path segment or push a path segment using a resizable cursor</td>
</tr>
<tr>
<td>Reshape Area</td>
<td>Reshape a selected path within the area of the resizable cursor</td>
</tr>
<tr>
<td>Path Scrubber (+)</td>
<td>Increase stroke characteristics controlled by pressure or speed</td>
</tr>
<tr>
<td>Path Scrubber (-)</td>
<td>Decrease stroke characteristics controlled by pressure or speed</td>
</tr>
<tr>
<td>Eyedropper</td>
<td>Sample a color and apply it to the active color well</td>
</tr>
<tr>
<td>Paint Bucket</td>
<td>Fill objects with color, gradients, or patterns and adjust fills with Paint Bucket handles</td>
</tr>
<tr>
<td>Eraser</td>
<td>Remove or replace portions of image objects and cut paths</td>
</tr>
<tr>
<td>Rubber Stamp</td>
<td>Clone portions of an image object</td>
</tr>
</tbody>
</table>
TWO SETS OF TOOLS IN ONE

Fireworks has two basic modes—Object mode and Image Edit mode:

**Object mode** is where vector graphic creation and some image manipulation occurs, and **Image Edit mode** is where pixel editing occurs within an image or background. They share the same toolbox, and some, but not all of the same tools. Tools that are unavailable in a specific mode are grayed out when you are working in that mode.

**Image Edit mode**

1. Enter Image Edit mode by double-clicking on the butterfly bitmap image.
2. Note the striped border, which indicates that Fireworks is now in Image Edit mode. Image editing tools such as the Marquee tool, Lasso tool, Eraser tool and the Rubber Stamp tool are now active and available to be used.
3. Click outside the image or on the Stop button located on the bottom status bar (PC), or on the opacity toolbar (Mac), to exit image edit mode (Figure 1-8).

Activities in Image Edit mode include:

- creating and editing images for the Web
- editing images imported from the Web
- editing pixels with the Pencil tool
- replicating image elements with the Rubber Stamp tool
- painting in color with the Brush tool
- erasing to transparency or to another color
- applying Xtra filters to pixel selections
- editing imported GIFs, JPEGs, and PNGs
- creating composite images

**Object mode**

Object mode is the default mode. Some tools such as the Pen tool and Text tool are only active in object mode.

Activities in object mode include:

- drawing paths by dragging a basic shape tool or the Line tool, placing points with the Pen tool, or drawing a path with a pixel-wide stroke with the Pencil tool
- drawing paths with a wide variety of brush strokes, including textures and patterns with the Brush tool
- editing paths with the Freeform, Reshape Area, Redraw Path, Eraser, Path Scrubber, and other tools
- editing paths by moving points and adjusting Bezier handles
- typing and editing text
- importing, positioning, and applying effects to bitmap images
- importing and editing documents with vector graphics created in applications such as FreeHand...
FLOATING PANELS

Fireworks panels float above the document. Place them anywhere on your screen. The Layers and Frames and the Brushes and Fills panels are tabbed. The other two panels are the Tool Options and Color Mixer panels. Close any of these panels using the standard close box. Open or close them by choosing the appropriate command from the Window menu.

THE LAYERS AND FRAMES PANEL

Layers and Frames controls are located on one panel with different tabs.

Layers

1. Choose Window > Layers to open the Layers and Frames panel (Figure 1-9).
2. If it is already open, click the Layers tab to bring it to the front.
3. Click the background layer name to select the background layer. The active layer is highlighted. The background layer is always at the bottom of the stacking order.
4. Click the Text layer name to activate the Text layer.
5. Using the Pointer tool, click on the line of text on the image. The blue square indicates in which layer the selected object resides. The butterfly image and the vector images are on the foreground layer. To move a selected object to a different layer, drag the blue square icon up or down the list.
6. Click the area in the second column to the left of a layer name to lock that layer. A padlock indicates that a layer is locked (Figure 1-10). Objects on a locked layer are not editable until the layer is unlocked.
7. Click the area in the first column to the left of a text layer name to hide that layer (Figure 1-11). The show/hide icon disappears as well as the text within the document. Hiding a layer hides all objects on that layer, but does not remove them from the document. Showing a layer shows all objects on that layer. A hidden layer cannot be an active layer.
8. Click the square in the first column to the left of the layer name to show that layer. Only objects on visible, unlocked layers are editable. Many of the actions associated with layers—add, duplicate, rename, remove, hide or show, and lock or unlock layers—are located in the Options pop-up.
Frames

1. If the Layers and Frames panel is not open, choose Window > Frames to open it with the Frames tab forward (Figure 1-12).
2. If the panel is already open, click on the Frames tab to move it forward.

Brushes and Fills

Figure 1-13
The Brush panel has four sections.

- Brush category and type
- Brush tip
- Brush stroke texture
- Brush stroke preview and color well

Figure 1-14
The Fill panel has four sections.

- Fill category and name
- Edge type
- Texture and transparency
- Fill preview and color well

Effect

Figure 1-15
The Effect panel controls the attributes of an effect applied, or to be applied, to an object. The Effect panel has three sections, which vary slightly depending on which effect is chosen.
COLOR MIXER

Figure 1-16
The Color Mixer is used to create a color that can be dropped into the active color well. Enter values of Red (R), Green (G), and Blue (B) or use the pop-up sliders to mix a color, or move over the color bar at the bottom to pick a color using the Eyedropper tool. Additionally, the Color Mixer can be used in Hexadecimal, CMY, HSB, or Grayscale.

TOOL OPTIONS

If the Tool Options panel is not open, you can open it by double-clicking on a tool.

With the panel open, click several of the tools in the Toolbox to investigate the various tool options.

DOCUMENT PROPERTIES

When you begin to create a new document, check all of the Document Properties (Figure 1-18). By carefully planning your document’s design and final output requirements, you can decide in advance which settings are best. Although many of the document properties can be changed as needed, sometimes these changes may have unexpected results. Thinking and planning ahead are the best strategies.

1. Close 2type.png by choosing File > Close. (Do not save any changes.)
2. Create a new file by choosing File > New or by clicking the New button on the Main toolbar.

Canvas size

Set the Canvas size in the New Document dialog box to define the size of your document.

Type 600 into the Width field and 400 in the Height field.

Canvas dimensions can be set using pixels, inches, or centimeters. If you later want to alter the canvas size choose Modify > Document > Canvas Size or use the Crop tool to crop the background image.

Resolution

Resolution is defined in the New Document dialog box as either pixels per inch or pixels per centimeter. Consider the intended delivery medium when assigning resolution. For example, Web graphics are usually saved at 72 pixels per inch due to the standard resolution of computer monitor display.

For the Web the best resolution is 72 pixels per inch.
**Canvas color**

The canvas is the bottom layer of your document, under the Background layer. Transparent areas of the background layer appear as the canvas color. You can choose a white canvas, a transparent canvas, or a color canvas in the New Document dialog box (Figure 1-18).

Fireworks will anti-alias to your canvas color, so for most pleasing results set your canvas color to the background color of your Web page.

![New Document dialog box](image)

**Figure 1-18**
Be sure to set the resolution properly in the New Document dialog box. Once your document's resolution has been set, it cannot be changed.

*Often when working with a custom page color and file format that support transparency (such as GIF), it is advisable to create Web graphics with a transparent canvas. However, it can be visually difficult to create graphics against the checkerboard pattern that indicates transparency. Instead try creating your graphics with a white canvas and changing the canvas later by choosing Modify > Document > Canvas Color.*

**Number of undo steps**

Choose **Edit > Undo** to reverse an action. Enter a value of up to 100 in the **File > Preferences > General > “Undo Steps”** field.

Note that RAM requirements increase as the number of undo steps increases. The recommended setting for the Undo preferences is 8.

Changes to the Undo preference do not take effect until Fireworks is restarted.
**Rulers**

To show or hide rulers, choose **View > Rulers**. Note that regardless of the document’s unit of measurement, rulers always display in pixels.

**Grid**

The grid is a background of horizontal and vertical lines you can use to position your work.

1. Choose **View > Grid** to display the grid.
2. Choose **View > Grid** to turn off the grid.
3. With **View > Snap to Grid** checked, dragging an object near a grid line causes that object to snap to the grid.

**Guides**

Use guides, which like the grid, are non-exporting guidelines, to precisely align and place objects.

1. Choose **View > Guides** to show or hide guides.
2. To add a guide the rulers are visible. Drag guides out from either the horizontal or the vertical ruler.
3. With **View > Snap to Guides** checked, objects snap when dragged near guides.

**MORE EXERCISES TO SHARPPEN YOUR SKILLS**

- Spend some time looking at the different ways that graphics are used on the Web today.
- Visit five Web sites that use graphics as an important part of the “message” and analyze what part the graphics play. Do they tell the story? Do they help illustrate the point? Do they sell the product? Are they part of the corporate message? Are they intended to amuse? Try to find five very different sites.
- Finally, try to analyze what type of graphics you are viewing, vector or bitmap? The file type indicates the type of graphic and so looking at the HTML source for a page can be helpful. To view the source in Navigator choose **View > Page Source**; to view the source in Internet Explorer choose **View > Source**.