LESSON 3: BUTTONS, ROLLOVERS, AND LIVE EFFECTS

OBJECTIVES

By the end of this lesson you’ll be able to:

• edit bitmap graphics
• understand the use of rollovers in Fireworks documents
• understand standard button behavior
• create standard buttons using the default button states
• apply Fireworks Live Effects to text and shapes
• create your own custom rollover effects for buttons
• use the Paste Inside command

CONTEXT

In this lesson, you will be creating the front-page graphic of a travel agency that specializes in Australian Outback tours. You will be using some of the tools you have already learned, adding some new techniques that allow you to create masks, add effects, and attach text to a path.

EXERCISES

Editing and Creating Masks

A mask isolates part of an image, so another image shows through the outline, or everywhere BUT within the outline. In this exercise we will paste an image inside an object (a pre-defined button), so that only part of the image will show through the button outline.

2. In the New Document dialog box, type “650” in the Width field and “500” in the Height field. Leave the Resolution at 72 ppi.
3. Click the Custom radio button and click on the color square. When the Color palette opens on a Windows computer or a Mac running system 8.1, type “255” into the Red field, “204” into the Green field and “102” into the Blue field.
   On other Macs enter the following mathematical values:
   Red 100%, Green 80%, and Blue 40%.
4. Click OK.
5. Choose File > Save, and name the document in your “Lesson 3” folder as outback.png. Click OK.

Working with Bitmap Images

Fireworks’ Image Edit mode allows you to edit bitmap images pixel by pixel. You enter this mode by double-clicking on a bitmap image. A striped border will appear around the selected image or background to let you know you are in this mode.

You can use Image Edit mode to create composite images, edit pixels with the Pencil or Eraser tool, paint color with the Brush tool and edit imported GIFs, JPEGs, and PNGs. You’ll find more information about this in Chapter 1.
1. With outback.png open, choose Window > Layers (or click the Layers icon on the top toolbox).
2. Rename the Foreground layer by double-clicking the layer name and typing “Map” into the field.
   Click OK.
3. Choose File > Import and select map.jpg from the “Lesson 3” folder. Click Open.
4. Click with your cursor in the upper-left corner of your document to import the graphic at its
   default size.

The graphic is a stylized antique map of Australia. You are going to give it a softer, more
organic shape.

1. Double-click the map graphic to enter Image Edit Mode.
2. Choose the Lasso tool and draw a large selection somewhat like the shape of the bottom of Florida.
   (If at any time during this exercise you want to see the finished graphic, look at Figure 3-14.)
3. Choose Select > Feather from the main menu bar (Figure 3-2) and type “5” into the pixel field of the
   Feather selection panel (Figure 3-3). Click OK.
4. Choose Select > Inverse to select the pixels outside of the shape that you’ve drawn.
5. Press the Delete key to delete the selected pixels.
6. To exit Image Edit mode click the Stop button at the bottom of the document window (PC) or click
   the Stop button on the Opacity toolbar (Mac).

**Effects**

**Live Effects** are pixel-based effects that apply to path, image, and text objects and redraw to reflect
subsequent editing. Examples of Live Effects are Drop Shadow, Emboss, Bevel, and Glow.

Applying a Live Effect does not permanently change the original object. The object to which the effect is
applied remains editable and the effect itself remains editable and removable. Multiple effects can be
used as well.

With other graphics programs in use today, designers can only apply such effects to bitmap objects.
Text and paths have to be converted to bitmaps before a simple effect such as a drop shadow can be
added. And after the text or paths had been turned into bitmaps they are no longer editable. A simple
change in the text in a Web graphic can entail many hours of rework. Fireworks changes all that. Let’s
take a look:
1. Click the map shape with the Pointer tool.
2. Choose **Window > Effect** to access the Effects tab on the Brushes and Fills palette (or if it’s already open click the **Effect tab** to move it forward.
3. On the **Effect panel**, choose **Drop Shadow** from the **Effect category** pop-up menu and **Basic** from the **Effect name**. Modify the Distance setting to 10 (Figure 3-4). You will now see a drop shadow behind the image you are working on.

   A second effect could be added by grouping the image (**Modify > Group**) and applying the second effect.

**Locking Layers**

To keep from accidentally selecting the map, you can lock the layer that contains it. Locking layers that are completed makes your working environment easier to handle.

1. On the **Layer palette**, click the square in the second column to the left of the layer name to lock the layer.
2. A padlock indicates that a layer is locked. If you want to edit something in a locked layer, simply click on the padlock icon to unlock the layer. Let’s leave it locked for now so we don’t accidentally make changes to that layer.

**Adding the Text**

You are going to add the text for the title of the Web page.

1. Click the Layers tab in the Layers and Frames panel.
2. Choose **New Layer** from the Options pop-up menu. Type “Title” in the layer name field. Click OK.
3. Click on the **Text tool** and click on the top of the document.
4. In the Text editor panel, type “OUTBACK ADVENTURE” in all capital letters in Times New Roman font, 64 point text and 72% Horizontal scale field, Center. Press Enter (Return) and type TOURS in 24 point text and 150% Horizontal scale field. You may find it easier to type the text first, then assign the font characteristics.
5. Click OK.
6. Using the **Pointer tool**, select the text. Be sure that the fill well is selected. Expand the Swatches panel by clicking the Expand button (Figure 2-6). Click on a bright yellow Color swatch.
7. If the text box is not wide enough to allow the words OUTBACK ADVENTURE on one line, simply drag the selection handle outward to expand the text box.

Remember that you can see this art work finished in Figure 3-14.
Applying an Effect to Text

Live Effects are especially useful for text and creating custom fonts.

1. Using the Pointer tool, select the text.
2. Click the Effect tab in the Brushes and Fills panel.
3. Choose Glow from the Effect category pop-up menu and Basic from the Effect type pop-up menu. Type “7” in the Softness field and “5” in the Width field. Select a deep brown color for the glow by double-clicking in the color square (Figure 3-6) and choosing a color from the color palette.

Applying a Live Effect does not permanently change the original object. The object to which the effect is applied remains editable. The effect itself remains editable and removable. Live Effects allow you to experiment with many different combinations of effects because of the ease with which they are changed and removed.

ADDING ROLLOVERS

JavaScript Rollovers are images that change appearance in a Web browser when you move the mouse over them or click on them. JavaScript Rollovers are created by drawing different images (representing different rollover states) and then using JavaScript to switch from one image to the other.

Because buttons are the most common type of JavaScript rollovers, Fireworks includes Live Effects presets to simplify the creation of common button appearances. In this exercise, however, you are going to create your own buttons. For the sake of simplicity, we will only create the Up and the Over states.

Creating the Buttons

Let’s create some custom buttons by using some imported graphics and a Mask Group. A Mask Group has two primary uses, both of which are based on isolating part of an image.

– Pasting an object inside another object, so it shows through the outline made by the top object.
– Pasting an object inside another object, so it is visible EXCEPT where covered by the top object.

1. Click the Layers tab in the Layers and Frames panel.
2. Choose New Layer from the Options pop-up menu and name it “Buttons.” Click OK.
3. Choose the Ellipse tool from the basic shapes tool group in the toolbox (Figure 3-7).
4. Hold down the Shift key and draw a circle that is 95 pixels wide (Figure 3-8). (You can see the measurements in the Info window, accessible from the menu bar via Windows > Toolbars > Info.) The Shift key constrains the shape to a perfect circle.

5. Click the Brush tab of the Brushes and Fills panel. Choose Basic from Brush category pop-up menu and Hard Rounded from the Brush type pop-up menu. Enter “4” into the Brush tip size field.

6. Click the Fill tab of the Brush and Fill panel. Choose Solid from the Fill category pop-up menu.

Adding More Buttons

The circle we made is the template for our buttons. We will need four buttons altogether.

1. With the circle selected, choose Edit > Duplicate from the menu bar three times.

2. Distribute the buttons on the page, leaving room between them and an open area on the leftmost side of the graphic for an animation that you will add in the next lesson.

3. Choose File > Import and select nanzi.jpg. Click Open. Then click once in the document to import the graphic as is.

4. Position the graphic so that it covers one of the buttons. Do not deselect the graphic.

5. Choose Edit > Cut.

6. Select the button that was beneath the graphic you just cut. Choose Edit > Paste Inside. If you need to reposition the graphic you can do so before you deselect it.

7. If you deselect your button and then decide you want to reposition the graphic, select it again and double-click the blue and white Mask icon. Use your Pointer tool to reposition the contents pasted inside (Figure 3-9). You will only see the object’s outline but will be able to see the effects of the adjustment within the other object.

8. Repeat with the other three buttons, by importing the graphics obidi.jpg, redrock.jpg and yuca.jpg and following the directions above.

Creating the Rollovers

You create rollovers by creating frames in which the alternate images reside. When an event, such as the mouse passing over image, triggers the JavaScript, then the alternate image is displayed. Although the term rollover often applies to a button, the technique can be used to give visual feedback anywhere on a Web page. A good use for a rollover is additional information about an item on your page that appears when the user moves his mouse over a “hotspot.”

Creating the Frame for the Rollovers

The graphic for your rollover state needs to be in a new frame.

1. Click the Frames tab of the Layers and Frames panel.

2. From the Frames panel Options pop-up menu, choose Add Frames (Figure 3-10). Accept the default of one frame after the current frame by clicking OK.

3. Return to Frame 1 by clicking the Frame 1 frame name.

4. Using the Pointer tool and holding down the Shift key, select all the buttons in the first frame.

5. Choose Copy to Frames from the Frame pop-up menu. Choose All Frames and click OK.
6. Click the Layers tab, select, and then unlock the map layer by clicking on the padlock icon.

7. Using the Pointer tool, select the map.

8. Click the Frames tab and choose Copy to Frames from the Options pop-up menu (Figure 3-11). Select All Frames and click OK.
   You need to copy anything that will be visible in the rollover state to the second frame. That is why you copied the map into the second frame as well. You are next going to add the text that will display when the mouse rolls over the buttons.

9. Relock the map layer by clicking the Layers tab and clicking the empty box next to the map layer name.

Creating the Rollover Image

You are going to create text that seems to wrap around your round buttons. Attaching text to paths is a useful tool that gives sophisticated results.

1. Click the Frames tab and select Frame 2 by clicking on the frame name.

2. Choose the Text tool and type “NANZI MESA” in all capital letters in Arial or Helvetica font, font size 12, and type “20” in the Kerning field. Leave the Horizontal scale and Leading at 100%. Click the Left aligned button. Click OK.

3. Choose the Ellipse tool and hold down the Shift key. Click and drag a circle over the button that contains a mountain. The circle should be slightly larger than the button.

4. With the ellipse still selected, hold down the Shift key and select the text as well.

5. Choose Text > Attach to Path (Figure 3-13).

Copy and Paste to Save Time

You will now copy the text you just created and paste it. It is a good habit to pay attention to your production process and pinpoint ways to save time. Copying and editing are excellent ways to save effort and precious time.

1. Using the Pointer tool, select the NANZI MESA text. Choose Edit > Duplicate three more times.

2. Arrange each of the duplicated text items around the remaining buttons.
3. Double-click the text around the button with the cactus, type “Obidi Gorge” and click OK.
4. Double-click the text around the button with the rock arch, type “Red Rock Ridge” and click OK.
5. Double-click the text around the button with the joshua tree, type “Yuca Canyon” and click OK.
The buttons with text will replace the buttons without text during a mouse rollover.

**GENERATING THE JAVASCRIPT**

Now that you have created the alternate rollover images for your buttons, the next step is creating the JavaScript that will switch the images. You can export files or portions of files in various ways: using the Slice tool, using the Export command or using the Export Area tool. In the next portion of this exercise, you are going to use the Export Area tool to export one of the rollovers that you have just created. The Export Area tool allows you to export a designated area of a file.

1. Choose the Export Area tool from the toolbox (Figure 3-15).
2. Click and drag a marquee around one of your round buttons. Be sure to leave enough space on the left and top sides for the text of the rollover image.
3. When you release the mouse button, the export area remains highlighted by a marquee. Drag any of eight marquee handles to resize the export area (Figure 3-16).
4. Double-click inside the Export Area marquee to open the Export Preview dialog box.
5. Choose GIF rollover from the Format pull-down menu in the Export Preview dialog box (Figure 3-17).
6. Click Export.
7. In the Export dialog box, type the file name “Test” and choose “Lesson 3” as your destination folder.

**Figure 3-14**
Figure 3-14 shows the Outback Adventure’s graphic. The main image is Frame 1, inset is one button of Frame 2.

**Figure 3-15**
The Export Area tool

**Figure 3-16**
Drag any of eight marquee handles to resize the export area.

**Figure 3-17**
Choose GIF rollover from the Format pull-down menu in the Export Preview dialog box.
8. Be sure that Generate HTML is selected and then click Save (Figure 3-18).
9. To see what your button rollover looks like, choose File > Save and then File > Close. Minimize Fireworks.
10. Navigate to your “Lesson 3” folder and double-click the test.html file to launch your Web browser and open the file.

You can also view the JavaScript created for you by choosing View > Page Source in Netscape and View > Source in Internet Explorer. This JavaScript can be cut and pasted into any HTML document. The JavaScript generated by Fireworks performs pre-caching of rollover states. This means that when the HTML file is first loaded into the Web browser, all of the rollover images, even those not initially visible, are loaded into the browser’s cache. When the cursor is moved over a Fireworks JavaScript rollover, the alternative state is immediately swapped, instead of having to wait for it to download.

MORE EXERCISES TO SHARPEN YOUR SKILLS

Create three buttons with four states: Up, Over, Down, and On Click. Each of these buttons should be in its own file.

- Make the first button a basic beveled button. (Hint: Bevel is a Live Effect located on the Effect panel.)
- Make the second a button with a drop shadow. (Hint: a depressed button with a drop shadow would be closer to the page.)
- Make a third button of your own choosing.