COMPUTER-GENERATED RENDERING

DIANE M. BENDER
JON D. VREDEVOOOGD

©2001
# TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>MODULE TITLE</th>
<th>PAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>MODULE R1</td>
<td>5</td>
</tr>
<tr>
<td>Course Introduction</td>
<td></td>
</tr>
<tr>
<td>MODULE R2</td>
<td>9</td>
</tr>
<tr>
<td>Preparing to Render</td>
<td></td>
</tr>
<tr>
<td>MODULE R3</td>
<td>17</td>
</tr>
<tr>
<td>Rendering Materials</td>
<td></td>
</tr>
<tr>
<td>MODULE R4</td>
<td>81</td>
</tr>
<tr>
<td>Importing and Exporting Materials</td>
<td></td>
</tr>
<tr>
<td>MODULE R5</td>
<td>85</td>
</tr>
<tr>
<td>Orienting Materials</td>
<td></td>
</tr>
<tr>
<td>MODULE R6</td>
<td>95</td>
</tr>
<tr>
<td>Scanning and Inserting Materials</td>
<td></td>
</tr>
<tr>
<td>MODULE R7</td>
<td>101</td>
</tr>
<tr>
<td>Creating Lights and Shadows</td>
<td></td>
</tr>
<tr>
<td>MODULE R8</td>
<td>113</td>
</tr>
<tr>
<td>Designing Scenes</td>
<td></td>
</tr>
<tr>
<td>MODULE R9</td>
<td>119</td>
</tr>
<tr>
<td>Adobe Photoshop</td>
<td></td>
</tr>
<tr>
<td>MODULE R10</td>
<td>133</td>
</tr>
<tr>
<td>3D Studio Max</td>
<td></td>
</tr>
<tr>
<td>MODULE R11</td>
<td>135</td>
</tr>
<tr>
<td>Project Guidelines</td>
<td></td>
</tr>
<tr>
<td>APPENDIX</td>
<td>139</td>
</tr>
<tr>
<td>3D Solids</td>
<td></td>
</tr>
</tbody>
</table>
MODULE R1

Course Introduction
HED 454 COURSE SYLLABUS  
**SUMMER 2001**

Design Communication Methods: Computer Generated Rendering

Professor: 
Diane Bender  
benderdi@msu.edu

Office hours: 
Immediately following lectures; via email  
Tuesday 3:00pm-5:00pm 102 Human Ecology

CAD Technology Coordinators: 
Jon D. Vredevoogd & Diane Bender

Classrooms: 
Lecture  
106 Farrall Hall  
Tues. 10:20am-12:10pm

CAD Labs  
216 Bessey Hall  
106 Farrall Hall  
218 Natural Resources  
102 Human Ecology  
B15 Wilson Hall

MSU CAD Labs schedule:  
http://www.msu.edu/service/mlab/web/index.htm

Course websites: 
Course site:  
http://www.msu.edu/course/hed/454/  
MSU CAD Program website  
http://cad.msu.edu  
MSU computer labs schedule:  
http://www.msu.edu/service/mlab/web/index.htm

Catalog Description  
Advanced computer aided design and rendering course covering photo real representations of three dimensional objects displayed on the computer. The computer generated renderings will include the attachment and manipulation of materials, lights, shadows, scenes and the placement of multiple cameras.

*Course prerequisite:*  
HED 240 (HED 250 is recommended)

Course Objectives  
This class has been created for all design majors. The assignments are designed to help students operate the software and demonstrate its ability to represent computer rendered objects.

1. The student will be able to operate the MSU computer network and other technologies to access computer hardware and software as required for this class.
2. The student will be able to demonstrate his/her ability to use AutoCAD Release 2000 to:
   a. Set the system defaults
   b. Define, attach and detach materials
   c. Orient and scale materials
   d. Define lights
   e. Define shadows
   f. Create and render scenes
3. The student will demonstrate his/her ability to use computer generated rendering principles and strategies to produce both screen and hard copy renderings in a timely fashion.

Materials  
Coursepack, available at the Student Bookstore (SBS), which includes:
   * Required textbook:*  
     CAD Rendering (2001), Diane M. Bender & Jon D. Vredevoogd

   * Course CD-rom  
   Recommended textbook:  
     Computer-Aided Design for Designers (2001), Diane M. Bender & Jon D. Vredevoogd

   * Email address & MSU AFS site  
   * AutoCAD R2000 software (recommended; available at SBS)
Project Descriptions

[1] Setting up the defaults
[4] Scanning and inserting images
[5] Lights, Shadows & Scenes
[6] Project - a rendering applied to your own personal CAD project

Uploading Files
All assignments will be electronically submitted as IMAGE files. To upload assignments, please see the website http://cad.msu.edu/ - go to the TOOLS section and read the instructions for Uploading. To upload, go to Assignments on the course website (http://www.msu.edu/course/hed/454) and pick on the “Upload” link at the bottom of the page. Follow the instructions to submit your assignments.

Late Work Policy
Assignments are due at the designated lecture time. You are responsible for getting the submission uploaded on time. Assignments will not be accepted in the faculty office, faculty mailbox or to be viewed from your personal AFS site. Late work will not be accepted. If the assignment is incomplete, the student should submit whatever he/she has completed. Under extenuating circumstances with proper written documentation, (i.e. Illness=Physicians report, Death in the family=Obituary notice), the due date will be extended. Please make every effort to notify the faculty prior to the due date.

If you wish to be absent from class to observe a religious holiday, please make arrangements in advance. If you must miss a class to participate in an officially-sanctioned athletic game or in a required activity for another course, provide the instructing faculty with adequate advanced notice, such as a team schedule or a written authorization from the faculty member of the other course.

Cheating
Michigan State University adheres to the policies on academic honesty as specified in General Student Regulations 1.0, Protection of Scholarship and Grades, and in the all-University Policy on Integrity of Scholarship and Grades, which are included in “Spartan Life: 1998 Student Handbook and Resource Guide” and on the MSU Web site.

It is to your benefit to work on your drawings independently. The assignments in this class are designed to help you understand the software and the process of computer generated rendering. Help will be available as much as possible, but it is your responsibility to complete the assignments. Cheating is not tolerated. IDENTICAL DRAWINGS WILL BE PULLED AND GIVEN A 0.0 GRADE.

Lab Hours
Assistance is made available outside of class in various CAD labs on campus and via the Internet. The labs are open 7 days a week (excluding holidays). Assistance will be available at posted hours, to be determined by the second week of class and posted on the course AFS site. Assisted hours will vary during the semester.

Grading
All assignments are PASS/FAIL.

HED 454 Grading Matrix

<table>
<thead>
<tr>
<th>Assignment</th>
<th>Scan</th>
<th>16%</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defaults</td>
<td>Scan 1</td>
<td>16%</td>
</tr>
<tr>
<td>Materials</td>
<td>Scan 2</td>
<td>16%</td>
</tr>
<tr>
<td>Mapping</td>
<td>Scan 3</td>
<td>16%</td>
</tr>
<tr>
<td>Scanning</td>
<td>Scan 4</td>
<td>16%</td>
</tr>
<tr>
<td>Lights, Shadows &amp; Scenes</td>
<td>Scan 5</td>
<td>16%</td>
</tr>
<tr>
<td>Project</td>
<td>Scan 6</td>
<td>25%</td>
</tr>
<tr>
<td></td>
<td></td>
<td>100%</td>
</tr>
</tbody>
</table>
### HED 454 COURSE OUTLINE SUMMER 2001

<table>
<thead>
<tr>
<th>DATE</th>
<th>MODULE &amp; LECTURE TOPIC</th>
<th>SUBMISSION DUE</th>
</tr>
</thead>
<tbody>
<tr>
<td>5/15</td>
<td>[R1] Course Introduction</td>
<td></td>
</tr>
<tr>
<td></td>
<td>[R2] Preparing to Render</td>
<td></td>
</tr>
<tr>
<td></td>
<td>[R3] Rendering Materials</td>
<td></td>
</tr>
<tr>
<td>5/22</td>
<td>[R3] Rendering Materials (cont.)</td>
<td></td>
</tr>
<tr>
<td>5/29</td>
<td>[R4] Importing and Exporting Materials</td>
<td>Project 1: Defaults</td>
</tr>
<tr>
<td></td>
<td>[R5] Material Orientation</td>
<td></td>
</tr>
<tr>
<td>6/5</td>
<td>[R6] Scanning &amp; Inserting Materials</td>
<td>Project 2: Materials</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Project 3: Mapping</td>
</tr>
<tr>
<td>6/12</td>
<td>[R7] Lights &amp; Shadows</td>
<td>Project 4: Scanning</td>
</tr>
<tr>
<td></td>
<td>[R8] Scenes</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Project checkpoint</td>
<td></td>
</tr>
<tr>
<td>6/26</td>
<td>[R9] Adobe Photoshop</td>
<td></td>
</tr>
<tr>
<td>6/28</td>
<td>[R11] <em>Final projects uploaded by 5pm</em></td>
<td>Project 6: Project</td>
</tr>
</tbody>
</table>

Projects 1 through 5 are to be uploaded to the course AFS site by NOON on the due dates listed above.

---

Note: Students with disabilities should contact OPHS (Disability Resource Center), 120 Bessey Hall, or by phone at 353-9642 (voice) or 355-1293 (TTY) for evaluation of need for reasonable accommodation, if any.
MODULE R2

Preparing to Render
AN EXAMPLE:

TOOLS NEEDED TO COMPLETE THE MODULE:

- Drawing file: MSU_CAD_Technologies.dwg
INSTRUCTIONS FOR COMPLETING THE MODULE:

The purpose of this assignment is to:
- Be introduced to the purpose and protocol for developing rendered views
- Explore the 3 rendering destinations
- Explore the 3 AutoCAD renderers

Purpose of Rendering

The purpose for rendering is to help us gain confidence in our design and to communicate the design to the client for their approval and direction. The representation needs to be reasonably accurate and at the same time, it should not require an inordinate amount of time to develop.

You will want to understand each of the rendering components and how they affect the image.

Think of yourself as the photographer who is hired to generate your portfolio photographs. Like the photographer, you will need to pay careful attention to the composition of the photo (the perspective created with the Dview command) and the lighting. Like the photographer, you may even need to add some studio lights just for the purpose of the photo.

Then you will need to assure that what you see in the camera (your computer screen) is accurately represented in the final print.

In rendering, you will also need to pay attention to the accurate representation of each of the materials, considering their color, their scale, and their orientation on the object.

All of these subtleties can be accomplished because AutoCAD is a very robust piece of software.

You will soon find that all of the renderings’ components are interrelated. For example, increasing the light intensity changes the appearance of both patterns and color, or increasing or decreasing ambient light affects the whole image. It is difficult to recognize what setting change caused what change in the image. It is tempting to just keep changing variables without getting closer to the desired end result. For this reason, you need to approach this rendering in an organized fashion. You will want to use the protocol described in the following modules initially. Then, once you are comfortable with rendering and AutoCAD, you can modify and vary the protocol.

The rendering protocol:

1. Construct the view
2. Make a complete list of all the materials you will be rendering
3. Make a complete list of all the lights that are required for the rendering
4. Check the settings for the render output
5. Define each material
6. Define each of the lights
7. Define the scene
8. Render each object
9. Make necessary material and light modifications until you are satisfied with the results

Mark up your course pack as you go. Make notes. You will need them.

Preparing the Drawing for Rendering

There are four steps in preparing your drawings for rendering:

1. Construct the views you intend to render
2. Check for solid surfaces
3. Freeze unused layers
4. Remove hidden surfaces
1 Construct the views you intend to render.

Open the drawing MSU_CAD_Technologies.dwg (located on the course CD). This will come up as a perspective. If not, use the command View and restore View2.

2 Make sure everything in the view has been drawn as either a 3D solid or a 3D surface.

To check that everything is drawn in 3D solid or 3D surface:
Use the hide command.

If an object has been drawn as a wire diagram, it will not render. You would use the 3D face command, the PFace command, or the 3D solid command to correct the situation. The drawing you are viewing was created with 3D regions and solid objects.

3 Use the layer command to freeze any layers that will not appear in the rendering.
This will help reduce computation time.

There is no new protocol here!
And there are no layers to freeze at this point in the tutorial drawing.

4 Remove hidden surfaces - surfaces that will not be rendered because they are not visible in this particular view.

To remove hidden surfaces:
From the View pull down menu:
Select Render
Select Preferences

In the RENDERING PREFERENCES DIALOG BOX under rendering options:
Select More Options...

In the real PHOTO RENDER OPTIONS DIALOG box, under face controls:
Select Discard Back Faces

Select OK to exit the render options dialog box.
Select OK to exit the rendering preferences dialog box.

At this point you are ready to specify the rendering destination.

An important note:
BE CONSISTENT - -

Be consistent with your drafting style.
If you use extrude to construct walls, construct all of the walls using extrude.
If you use box to create a floor tile, use box to create all of the floor tiles.
Be just as consistent in your approach to rendering.

You will have the option of attaching materials:
to an object,
to all objects on a layer, or
to all objects sharing the same ACI (AutoCAD Color Index).
Recommendation:
Place objects on layers based on how you will render them.
This allows you to quickly freeze everything but the object(s) you are working on rendering.

If you choose to attach materials based on layers, use that technique throughout the rendering process. If you choose to attach materials based on objects, use that technique throughout the rendering process.

Being consistent will help you avoid confusion and will save you time later.

This is a good time to adjust your drawing.

- Make a list of each of the materials you will require.
- Look at a photo of the object/environment you’re trying to duplicate and list the materials you’ll need to include.
- Set up layers based on those requirements.

If you check our list of layers and associated colors, you will see that the organization has already been done.

**Setting the Rendering Destination**

You will want to select one of the three primary destinations to display rendering.

1. **To render to a viewport:**
   - From the View pull down menu:
     - Select Render
     - Select Preferences
     - Use the drop-down menu and highlight Viewport

2. **To render to a separate render window:**
   - From the View pull down menu:
     - Select Render
     - Select Preferences
     - Use the drop-down menu and highlight Render Window

Rendering to the render window can save render time if you make the Render window smaller than your viewport.

The Render window cannot be closed or deleted while AutoCAD is running. It will close automatically when you exit AutoCAD.

Rendering to the render window will give you the extra capabilities, like integration with other software. For example, you can copy images to the clipboard for use in other applications such as Adobe Photoshop, Corel Draw, and MS paint.

You may want to make further changes to your rendering using one of these other applications, but keep in mind that when you use another application, the rendering is no longer interactive with AutoCAD. You cannot import the changes back into AutoCAD.

Screen resolution is a function of the number of pixels displayed. The resolution is inversely related to the displayed pixel size; that is, the greater the screen resolution, the smaller the pixels (given the same size screen). Like color depth, resolution depends on your display driver.

From the Render Window, you can also easily print to the system printer or render to a file using several formats.
3. **To render to a file:**
   From the View pull down menu:
   - Select Render
   - Select Preferences
   - Use the drop-down menu and highlight File

   Choose the More Options... button to further define the output file. (Check out the AutoCAD help menu)

   The file that is generated now is a bitmap file (*.bmp).
   When you render later, the computer will ask you where you want to save the .bmp file. The advantage of rendering to a file is that you can view the file later in another program, or import it back into AutoCAD with the `image` command.

   **Set Viewport as your render destination for the remaining tutorials.**

   **AutoCAD Renderers**

   AutoCAD provides three renderers:
   - Render
   - Photo Real
   - Photo Raytrace

   The renderers vary in the amount of detail and shadow they display - -
   the greater the detail, the longer the render time.

   You can easily change renderers as you work. In fact, you might want to begin with the Render renderer and finish with the Photo Raytrace renderer.

   Let's look at each renderer and see an example of its output.

   Open the drawing `MSU_CAD_Technologies.dwg`.
   Restore View 1 (use the `view` command).
   Current layer: 0

   **Here's an important note:**

   The Render Preferences dialog box and the Render dialog boxes look identical, except for the buttons at the bottom. The Render Preference dialog box will only allow you to set up the preferences and you exit with the OK button. But the Render dialog box allows you to change your rendering preferences, plus you can select the button RENDER at the bottom. **Only through the Render dialog box can you process a rendering procedure.**
The 3 Renderers

1. **Render** is the basic AutoCAD renderer.
   - This renderer gives the best overall performance.
   - This renderer provides the best trade off between detail and speed.
   - This renderer does not generate patterns or shadows.

   **To select Render as the renderer:**
   - From the View pull down menu:
     - Select Render
     - Select Preferences
   - From the RENDER PREFERENCES DIALOG BOX:
     - Find the RENDERING TYPES TEXT BOX
     - Use the drop-down menu and highlight *Render*
     - Push OK
   - To render:
     - From the View pull down menu:
       - Select Render
     - Click on the render button to render the view

2. **Photo Real** is a photo realistic renderer.
   - This renderer has the ability to generate both patterns & shadows.
   - This is the option is usually used to show for detail.

   **To select the Photo Real renderer:**
   - From the View pull down menu:
     - Select Render
   - Find the RENDERING TYPES TEXT BOX
   - Use the drop-down menu and highlight *Photo Real*
   - Push OK
   - Click on the render button to render the view

3. **Photo Raytrace** is also a photo real renderer.
   - Raytrace uses raytracing to generate reflections, refraction, and more.
   - Raytrace produces the most precise shadows and realistic view.
   - Because of its extreme accuracy, the Raytrace option takes the longest time to generate a rendered image.

   **To set Photo Raytrace as the renderer:**
   - From the View pull down menu:
     - Select Render
   - Find the RENDERING TYPES TEXT BOX
   - Use the drop-down menu and highlight *Photo Raytrace*
   - Push OK
   - Click on the render button to render the view

*Save or discard this drawing file when done.*
CHECKLIST:

1. What are the components or steps of a typical rendering protocol?
2. What are the 4 steps to use when preparing your drawing for rendering?
3. Why should you have consistency in your drawing and rendering preparation?
4. What are the 3 rendering destinations? When and why would you use each one?
5. Do you know the difference between the Render Preferences dialog box and the Render dialog box?
6. What are the 3 renderers? What is the difference between them?
Forms and colors gain meaning only as they are related to our inner selves. Used separately or in relation to one another they are the means of expressing different emotions and movements: they have no importance of their own.

Walter Gropius
Architect & Founder of the Bauhaus school
Using Materials in Rendering

Working with materials in a rendering involves:

1. Defining materials
2. Attaching materials
3. Importing and exporting materials

The process of creating color, shading, and pattern is substantially different using computer media than it is for traditional media processes.

In traditional media you are familiar with mixing pigments. Most of the colors you see around you are pigment colors. This is called the subtracted system of color. Pigments are described using their Hue (color name), Lightness (value), and Saturation (purity) characteristics. The AutoCAD renderers define pigments as HLS (Hue, Lightness, and Saturation). The primary pigment colors are red, yellow, and blue. When you mix color based on its appearance on a printed page, you are using pigments.

Now you are going to define the printed copy using the color that appears on your monitor.

When sunlight hits a red rose petal, the petal absorbs all the colors of the spectrum except red, which reflects back to your eyes. Your monitor is a source of light that emanates color rather than reflecting it. You are not seeing pigment color but light color. Mixing light colors uses the additive system of color. The primary light colors are red, green, and blue. This is the reason computer color systems are called “RGB” systems. The AutoCAD renderers define light using the RGB option.

This is important to remember when you are generating your rendering because you generate it using the light color system and you print your rendering using the pigment color system. That’s why the results may appear different on the screen than they do on the printed page. What’s more, color often varies from monitor to monitor and printer to printer.

A key component of materials is their surface color variation.

IMPORTANT NOTE!
Each of the rendered material actually specifies three color variables:

1. Its diffuse color is the object’s main color.
2. Its ambient color is the color which appears on those faces lighted by ambient light alone (i.e. the shadow color).
3. Its reflection color (or specular color) is the color of a highlight on a shiny material.

After you define the color of a material, you can readjust any or all of these variables. Each material will have several additional variables.
MODULE R3-B

Attaching Materials
AN EXAMPLE:

TOOLS NEEDED TO COMPLETE THE MODULE:

- Drawing file: attach.dwg
INSTRUCTIONS FOR COMPLETING THE MODULE:

The purpose of this assignment is to:

• Learn how to attach a standard material to a 3D object
• Explore the Rendering dialog box
• Discuss the peripheral rendering options
• Saving and redisplaying renderings

Attaching Materials

Having defined a material, you will want to apply or attach it to one or more objects in the drawing.

Open the drawing: attach.dwg from the course CD Rom
Save as a name of your choice.
Current layer: 0

You can attach a material to:

1. Individual objects
2. All objects with a specific AutoCAD color index (ACI) number
3. Layers

To attach a material directly to one or more objects:

From the View pull-down menu:
Select Render
Select Materials

Under Materials, highlight the material you want to use:
Highlight PAINT
Press the Attach button
Select the objects in the drawing that you want the material attached to by picking on the object(s)
Press Enter or right mouse click when finished selecting the objects
For example, select a wall column
Press OK

Render the model again to see the effect. Use the Render command.
Set the Rendering Type to Photo Real and the destination to Viewport.
Push Render.

- OR -

From the View pull-down menu:
Select Render
Select Materials

Under Materials:
Highlight a material already attached to another object in the drawing

Push the Attach button
Press Enter or right mouse click when finished selecting the objects
Press OK
(Render the model again to see the effect)
To attach a material to all objects in the drawing with a specific ACI number:
From the View pull-down menu:
   Select Render
      Select Materials
   Under Materials, highlight a material
      Press the By ACI... button
   In the attached by AutoCAD Color Index Dialog Box
      Highlight the ACI number (Colors 1-8 are also named)
      Press OK
      (Render the model again to see the effect)

To attach a material to all objects on a specific layer:
From the View pull-down menu:
   Select Render
      Select Materials
   Under Materials, highlight a material
      Press the By Layer button
   In the Attached by Layer Dialog Box, highlight the layer you want the material attached to
      Press OK
      (Render the model again to see the effect)

Render dialog box

To process a rendering and to view it on your screen or as a file, you must tell the computer to render the drawing. Use the dialog box to determine the preferences for your rendering.

From the View pull-down menu:
   Select Render
      Select Render

Rendering type:
   • Render - see previous module
   • Photo Real - see previous module
   • Photo Raytrace - see previous module

Scene to render - pick from available scene you set up before rendering (see module on scenes)

Rendering Procedures
   • Query for Selections - pick only the objects you want rendered; saves time
   • Crop Window - pick only the area on your screen that you want rendered
   • Skip Render Dialog - skip the render dialog box and go right to rendering the current viewport
Rendering Options

- Smooth Shade - smooths rough surfaces by blending colors over multiple faces
- Apply Materials - renders the materials as attached to each object; always check unless you’d like rendering to occur by ACI
- Shadows - calculates shadows; only used with Photo Real or Photo Raytrace
- Render Cache - rendering information is stored in a cache (or temporary) file on your harddrive; saves time when rendering the same drawing; can only be used during the current drawing session

Destination

- Viewport - see previous module
- Render window - see previous module
- File - see previous module

Sub Sampling - reduces rendering time at the expense of the rendering quality; a ratio of 1:1 is highest quality/slowest time while a ratio of 1:8 is lowest quality/fastest time

Render toolbar

From the View pull-down menu:
Select Toolbars...
Select Render
Push Close

Keyboard command is to or toolbar (not plural)

Toolbar options:
- Hide
- Background
- Shade
- Fog
- Render
- Landscape New
- Scenes
- Landscape Edit
- Lights
- Landscape Library
- Materials
- Render Preferences
- Materials Library
- Statistics

Render Preferences
Command line: rpref
Rendering preferences creates the variables for the rendering, such as scene, shadow, lights, cropping window, smoothing angle, etc.

Render Statistics
Command line: stats
Statistics can NOT be obtained from a rendered picture or graphic file (i.e. a bmp or jpeg file). Information can be obtained only from the actual drawing file.

All the information ever needed about a rendered drawing such as: scene name, last rendering type, rendering time, total faces and total triangles. For information about the drawing itself, use the command STATUS.
Peripheral options

An additional feature in computer-generated rendering is the manipulation of the drawing environment. You can manipulate the background or what is seen behind and beyond the rendered image, introduce fog and depth cueing, and bring in landscape objects. All of these options can provide more visual stimulation to the viewer.

Background

From the View pull-down menu:
Select Render
Select Background

The Background dialog box allows you to select the backing for your rendering. The default setting is the color of the AutoCAD screen, which is controlled with the Preferences command.

There is also the option to have a solid background of one color, to use a gradation of colors, to import an image file or to use the current AutoCAD image as the background.

An important note:
You can ruin a perfectly good rendering by cluttering the background with “visual noise”. Use background images and colors sparingly!

Push Cancel to exit the Background dialog box.

Fog

From the View pull-down menu:
Select Render
Select Fog

The Fog/Depth Cue dialog box allows you to establish depth within your drawing. This gives the viewer of your drawing more visual information about the distances between objects and between the objects and the camera. A white, colored or black fog can start and stop at any point in your drawing. You can control the distance and amount of fog to include. But beware - 100% fog placed in front of your drawing objects will blank out your screen.

Push Cancel to exit the Fog/Depth Cue dialog box.

Landscape

From the View pull-down menu:
Select Render
Select Landscape New...

The Landscape New dialog box contains images that you can insert into your rendering. These images include a limited amount of vegetation, people and even a road sign.
The Geometry

The heights of these images are controlled by the slide bar at the right or you can type in a known height.
Select a Landscape object from the listing on the left. Push the Position< button. Select a point on your screen for this object.

Push OK to exit the Landscape New dialog box.

From the View pull-down menu:
Select Render
Select Landscape Edit...

Transfer to the command line:
Select a Landscape object: pick the object you just inserted

Once a landscape object is inserted into your drawing, you can edit that object by using the Landscape Edit option found under the View, Render pull-down menu the keyboard command is lsedit). A dialog box identical to the Landscape New box will appear and allow you to make changes to the inserted images in your drawing.

A listing of available images is found in the Landscape Library. Here you have the options to modify or delete existing images. A nice feature is the New option. This brings up the Landscape Library New dialog box where you can import your own scanned images and bring them into AutoCAD’s Rendering Landscape library.

Push Cancel to exit the Landscape Edit dialog box.

Saving & Redisplaying Renderings

Rendering can be a time-consuming process, but redisplaying previously rendered images is an instantaneous process.

Three options for saving your renderings:

1. Saving a rendering directly to a file
2. Saving a viewport rendering
3. Saving a render window rendering

Saving a rendering directly to a file
No matter how your display is configured, you can bypass the screen and direct your rendering to its own file.

An advantage of not rendering to the screen is that you can render to a higher resolution than your current display configuration permits. You can then replay that image on other computer systems with higher resolution displays. A disadvantage is that you cannot view this rendering before it becomes a file. To both see the rendering and save it to a file, see the section on saving a render window rendering.

There are 5 types of files that can be created:

1. BMP (bitmap file)
2. PCX
3. Postscript (print file)
4. TGA (Targa file)
5. TIFF (Tagged Image file)

The type of file you select will depend on the end result and ultimate use of this image file. The type of file you select will make certain options available for adjustment. Not all types of files will allow total adjustment and modification.
To render an image directly to a file:
From the View pull-down menu:
    Select Render

    In the Render dialog box in the Destination area:
        Choose File from the drop-down menu
        Push the More Options... button

    In the File Output Configuration dialog box:
        Select a file type from the drop-down menu at the top
        Adjust any of the other options as needed
        (remember that not all options may be available)
        Push OK when done with your adjustments

    Back in the Render dialog box:
        Push Render

In the Rendering File dialog box:
        Give the file a name of your choice
        Locate a directory/file in which the file can save
        Push Save

Saving a viewport rendering

After rendering a model to a viewport, you can use the AutoCAD SAVEIMG command to save the screen image to one of the following formats: BMP, TGA, or TIFF.

To save a rendered image to a viewport display:
From the View pull-down menu:
    Select Render

    In the Render dialog box in the Destination area:
        Choose Viewport from the drop-down menu
        Push Render

From the Tools pull-down menu:
    Select Display Image
    Select Save

    In the Save Image dialog box:
        Select a file format: BMP, TGA, or TIFF
        Accept the default full-screen size or specify the size and offsets for the image
        Push OK
In the Image File dialog box:
- Give the file a name of your choice
- Locate a directory/file in which the file can save
- Push Save

Saving a render window rendering
You can also render to AutoCAD's render window. Once displayed in this window, the rendering can then be saved as various types of files, like bitmaps and postscript files.

To render to the render window:
From the View pull-down menu:
  Select Render

  In the Render dialog box in the Destination area:
  Choose Render Window from the drop-down menu
  Push Render

The AutoCAD render window will appear on top of your graphics screen. The rendering will display with its file information displayed at the top. You can now continue by saving this to a file. This feature is advantageous because you can see the rendering before making it into a file.

To save a rendered image as a bitmap file:

1. Make the render window the current window by picking on it's icon in the Windows toolbar at the bottom of your screen
2. From the render window File pull-down menu, choose Save...
3. In the Save File dialog box, enter a file name
4. Select a location to save this file (i.e. c:\temp)
5. Save file as type: BMPs (*.bmp)
6. Push OK
7. Return to the AutoCAD graphics screen

You can save a Render window image as a Postscript file by using the AutoCAD Export Data feature. Use the EXPORT command.
**Redisplaying a rendered image**

To redisplay a rendered image in a viewport:

*From the Tools pull-down menu:*
  - Select Display Image
  - Select View

  *In the Replay dialog box:*
    - Type the file name or select an existing file name

  *In the Image Specifications dialog box:*
    - Accept the default full-screen size
    - OR
    - Specify the size and the offsets for displaying the image

  Press OK

  The rendered image will reappear in your current viewport.

  *An important note:*
  - The keyboard command `REPLAY` redispers a BMP, TGA, or TIFF format file in a viewport.
  - The keyboard command `SAVEIMG` saves a rendered screen image in a viewport to a BMP, TGA, or TIFF format file.

  To redisplay a rendered image to the Render window:

    1. Make the render window the current window by picking on its icon in the Windows toolbar at the bottom of your screen
    2. From the render window File pull-down menu, choose Open...
    3. In the Select File dialog box, enter the name of the bitmap file or select an existing file name
    4. Push OK
    5. The rendered image will reappear in the render window.

**Modifying a rendered image**

To crop a rendered image in a viewport:

    1. From the Tools menu, choose Display Image > View
    2. In the Replay dialog box, enter a filename or select an existing file name
    3. Push Open
    4. In the Image Specifications dialog box under Image, specify 2 diagonal points to define the area that you want displayed. You can do this by clicking with your mouse or typing in new offset numbers for the X and Y directions. AutoCAD draws a red box to mark the balance of the crop image.
    5. Push OK
    6. The rendered image (or just the part you cropped) will reappear in your current viewport.

To offset a rendered image in a viewport:

    1. From the Tools menu, choose Display Image > View
    2. In the Replay dialog box, enter a filename or select an existing file name
    3. Push Open
    4. In the Image Specifications dialog box under Screen, select a point in this box to offset the center of the image; do this by picking a point with your mouse
    5. Push OK
To copy a rendered image from the Render Window to the clipboard:

1. Make the render window the current window by picking on it's icon in the Windows toolbar at the bottom of your screen
2. From the render window Edit pull-down menu, choose Copy

You can now go to another computer software application and Paste this image to a new or open document. This process will not work in ALL software applications.

CHECKLIST:

1. Do you understand the different ways to attach a material?
2. Can you save a rendering directly to a file?
3. Can you save a viewport rendering?
4. Can you save a render window rendering?
5. Can you redisplay a rendered image?
6. Do you understand how to modify a rendered image?
MODULE R3-C

Defining New Materials
AN EXAMPLE:

TOOLS NEEDED TO COMPLETE THE MODULE:

- Drawing file: standard.dwg
- Image file: whiteash.tga
- Image file: checkers.tga
- Image file: 3d.tga
- Image file: grybrick.tga
INSTRUCTIONS TO COMPLETE THE MODULE:
The purpose of this assignment is to:
• Learn how to apply a standard material to a 3D object
• Assimilate a previously rendered image as closely as possible

A STANDARD MATERIAL

Open the drawing: standard.dwg from the course CD Rom
Save as a name of your choice.
Current layer: architecture
Current view: onept

For our example, we are going to look at defining the walls as a Standard material.

For each object in your rendering:

1. Identify a material type -
   - Standard
   - Wood
   - Marble
   - Granite

2. Name the material
3. Define the material’s characteristics or attributes
4. Preview the result
5. Make necessary adjustments
6. Save the settings

Of the four material types, most materials will be defined as a Standard material.

Think of a standard material as a nondescript piece of plastic - you can decide the inherent color of the plastic & it’s surface texture. You can decide to paint a pattern on the plastic. You can make the plastic opaque or transparent. You can make this material into most anything you want.

To define a new Standard material:

1. From the View pull-down menu:
   choose Render > Materials . . .

2. In the MATERIALS dialog box:
   Find the Drop-down menu under the Button NEW . . .
   Highlight the material type ‘Standard’
   Click the button NEW . . .

3. In the NEW STANDARD MATERIAL dialog box:
   In the Material Name text box: Type the name PAINT
   (the names you choose for each material must be
   unique and have no more than 16 characters)

4. You are now ready to specify both a color and value for the material.

You need to go through each of the variables to define a New Standard Material like paint.

White boxes in the menu indicate the need for a decision - -
gray boxes indicate no decision available.
In the Attributes area:

- **COLOR/PATTERN** C.1
- **AMBIENT** C.2
- **REFLECTION** C.3

...are used to define the material's color and value.

The COLOR/PATTERN is defined using the components in the Color area. To activate your options, UNCHECK “By ACI”. ACI stands for “AutoCAD Color Index”.

The color can be defined using one or more of the following color systems found in this area:

- the HLS Color System
- the RGB Color System
- the Color menu

You access this color menu by double-clicking on the color swatch to the right of the Drop-down Color System.

You can make the AMBIENT and REFLECTION colors the same as the color/pattern color by checking the radio button box LOCK when it is available.

You can assign color using the ACI AutoCAD Color Index by checking the radio box ACI. (You assigned an ACI color when you selected the layer color or changed the color property of an object. With ACI checked, you do not have access to the Color System options).

In the Value area, you specify the lightness or darkness of the material.

The remaining categories have only value options:

- **ROUGHNESS** C.4
- **TRANSPARENCY** C.5
- **RETRACTION** C.6
- **BUMP MAP** C.7

5. Choose preview to see if the values you specified produce the effect you want. (Under the preview button, remember to select the Cube option since we will be applying the paint to wall panels)

6. Change the values and continue to preview the changes until you're satisfied with the material's appearance.

7. Choose OK to exit the New Standard Material dialog box.

8. Choose OK to exit the Materials dialog box.

Now, we will proceed through each of the seven radio buttons and their sub-menus.

Qsave <-
C.1 COLOR/PATTERN
Continue with the standard.dwg drawing file. Remain on the same current layer.

*Rmat* <-
Highlight PAINT
Push Modify...
Continue the exercise.

The color/pattern settings define the base color reflected by the object, known as diffuse reflection. In our example, this is the color of the plastic. (You adjust the diffuse color with the Color and Value controls. You view the result in the preview window).

To set the COLOR/PATTERN:

In the Attributes area:
Select the radio button Color/Pattern

In the Value area:
Use the slide bar or type .70 in the text box.
(This is the default setting. Begin with this setting).

In the Color area:
ACI radio button box: select the button to UNCHECK this box, indicating that you are not going to assign the AutoCAD color index color.

The Color System: options now become available.

Color System: Use the Color System drop-down menu to change from one system to another.

Highlight HLS

You will notice that the box headings change to:
Hue, Lightness, and Saturation.
Use the HLS slider bars or the text boxes to match the wall color of the front door.

Remember that the HLS color is based on pigment.

For our example begin with:
Hue: .15
Lightness: .56
Saturation: .23

Use the Color System drop-down menu again:

Highlight RGB

Use the RGB slider bar or the text boxes to further match the wall color of the front door. The numbers that appear are related to the HLS and were defined when you input values for Hue, Lightness, and Saturation.

Remember that the RGB color is based on light. (Notice that the RGB option does not allow you to change the Lightness option).
Move the sliders to adjust the RGB. Note that the numbers change as you move the sliders.
You will find that the preview and sample windows will go to gray when your setting are at the high end of the sliders. *Don't panic!* They will often appear in the rendering.

Finally, double-click on the color sample to the right of the drop-down menu to access the Color dialog box.

Select one of the Basic colors with a single click.
Modify the color selection by selecting and dragging the target in the rainbow window.

Select and drag the arrow slider on the right of the box to change the value.

Select OK to make the change to the color system sample.

Note that the color selection now appears in four places in the Modify Standard Material dialog box.
1. The Color/Pattern color box
2. The Ambient color box
3. The Reflection color box
4. The sample color box

**Preview button:**
Click on the Preview button.
This presents an example of a rendered sphere.
Use the drop-down menu below Preview to highlight the Cube option.
Click on the Preview button again.
This presents an example of a rendered cube.

The Preview provides a general impression of the color.

**File Name text box:**
The File text box name is used to locate and attach a bitmap (BMP) or targa (TGA) image file to the Color/Pattern Attribute.

**Bitmap and targa files are image files.** They could be a face or a wood sample, or any other image.

This will appear on the object as an image slide projected on to the object. The image will size itself to fit the object.
AutoCAD image files are often located under c:\program files\autocad\textures.

**Find File . button:** Use the button: Find File... to locate the image file you want to project on to the object.

This may very likely be an image of wood or fabric. It could be an image that you scanned. You can use this technique to include an exact representation of a sample in your rendering.

**To see how this works:**

1. Select the button: Find File...
2. The Bitmap File dialog box appears
3. Select the button: Find File...
4. The Browse/Search dialog box appears
5. Select the tab: Search
6. Find the File Types: drop-down menu
7. Highlight *.tga
8. Find the Search Location area
9. Select the radio button: All Drives
10. Select the button: Search
11. To the left, the available .tga files will appear
12. Find and highlight the file WHITEASH.tga
13. In the text box Search Pattern:, the file and its path appear
14. Select the button: Open
15. You are returned to the Modify Standard Material dialog box
16. In the text box: File Name:, the file and its path appear
17. Select the Preview button to see the effect of Whiteash
**Bitmap Blend:** The bitmap blend text box and slider are used to determine how transparent the bitmap will be in relation to the Color/Pattern you just defined.

Move the Bitmap Blend slider from the right to the middle - note that the number changes from 1.0 (opaque) to 0.5 (semi transparent).

Click on the button Preview - note that the image now allows the Color/Pattern to show through the image.

Moving the slider to 0.0 will cause the image to disappear.

*Leave 0.0 as the ending setting.*

**Adjust Bitmap:** The button: Adjust Bitmap brings up the dialog box ADJUST MATERIAL BITMAP PLACEMENT. This dialog box is used to locate and scale the image on the object. This is discussed in more detail in the module on Mapping.

To remove an image file from the File Name: box, you can highlight the file name and use the delete key or simply backspace out the file name.

After viewing this box but making no changes to it, click OK to exit this box.

Click OK to exit the Modify Standard Material dialog box.

**C.2 AMBIENT**
The settings for the ambient color define the material’s shadow color.

An example of ambient color might be paint on a column next to seating arrangement with bright colored fabric.

To set the **AMBIENT** color:

In the Attributes area:
- Select the radio button Ambient

In the Value area:
- Use the slider or type in the text box: .50 (Begin with this setting).
In the Color area:

**Lock radio button box**
Checked, this box will set the Ambient color to be the same as the diffuse color.
Unchecked, the lock box allows you to access the ACI option.

**Uncheck the radio box: Lock**

**ACI radio button box**
Checked, this box will use the same ACI color as the ambient color. Unchecked, the ACI box will allow you to access the Color System options (RGB, HLS, and Sample box).

**Uncheck the radio box: ACI**

**Color System drop-down menu & sliders**
Use the same procedure described under Color/Pattern Color System to adjust the HLS, RGB, and sample. Because you UNCHECKED the Lock button previously, you have the opportunity to adjust the color of the shadows.

**Check the radio button: Lock**

Check the Preview before leaving this section

---

### C.3 REFLECTION

The reflection settings determine the color of the reflected highlights. You may see this referred to as specular reflection. Surfaces with reflected color almost appear as white.

**To set the REFLECTION:**

In the Attributes area:
Select the radio button Reflection

In the Value area:
Set the value to 0.30
(For a shiny effect, set the value for reflection to 0.70, and set the value for Color/Pattern to 0.30).

In the Color area:

**Lock radio button box**
Checked, this box will set the Ambient color to be the same as the color/pattern diffuse color.
Unchecked, the lock box allows you to access the ACI option.

**ACI radio button box**
Checked, this box will use the same ACI color as the reflection color. Unchecked, the ACI box will allow you to access the Color System options (RGB, HLS, and Sample box).

**Mirror radio button box**
Checked, this option renders a mirrored reflection when you use one of the Photo Realistic renderers. (See Module 16 or the ACAD Help menu for more information on this topic).

**File Name text box:**
The File Name text box is used to locate and attach a bitmap image file to the Reflection Attribute.

This bitmap is an image file just like the image file you attached to the color/pattern attribute. The image appears projected on to the object and will size itself to fit the object. The difference is that the image will render it differently. The image will appear on the shadow side of the objects. It seldom appears on a cube.
Let's try it!
We will use the CHECKERS.TGA file.

**Find File . . button**
Use the Find File button to locate the image file you want to project on to the object. These image files could be images you scanned. Scanning provides an exact representation of a sample in your rendering.

1. Select the button: Find File...
2. The Bitmap File dialog box appears
3. Select the button: Find File...
4. The Browse/Search dialog box appears
5. Select the tab: Search
6. Find the File Types: drop-down menu
7. Highlight *.tga
8. Find the Search Location area
9. Select the radio button: All Drives
10. Select the button: Search
11. To the left, the available .tga files will appear
12. Find and highlight the file CHECKERS.tga
13. In the text box Search Pattern:, the file and its path appear
14. Select the button: Open
15. You are returned to the Modify Standard Material dialog box
16. In the text box: File Name:, the file and its path appear
17. Select the Preview button to see the effect of the Checkers bitmap

**Bitmap Blend:**
The bitmap blend is used to determine how transparent the bitmap will be in relation to the Color/Pattern you just defined.

Move the Bitmap Blend slider from the right to the middle - - note that the number changes from 1.0 (opaque) to .50 (semi transparent).

Moving the slider to 0.0 will cause the image to disappear.

*Leave the setting at .50*

Click on the Preview button - - note that the image now allows the Color/Pattern & ambient attributes to show through the image. The checkered reflection will be very subtle.
Adjust Bitmap...
The Adjust Bitmap button brings up the dialog box ADJUST MATERIAL BITMAP PLACEMENT. This dialog box is used to locate and scale the image on the object.

An important note:
At this point you could have two image files attached to the material called PAINT - the first WHITEASH.TGA attached to the diffuse color/pattern and the second CHECKERS.TGA attached to the reflection color.

Change the bitmap blend of the CHECKERS.TGA file and use the Preview to see the result.

Set the bitmap blend of the CHECKERS.TGA file to 0.0 before leaving this section

<table>
<thead>
<tr>
<th>Bitmap Blend</th>
<th>0.50</th>
</tr>
</thead>
<tbody>
<tr>
<td>File Name</td>
<td>C:\CHECKERS.TGA</td>
</tr>
</tbody>
</table>

C.4 ROUGHNESS
The roughness setting determines the size of the reflected highlight. Roughness values have no effect if you have not entered a value for reflection under Attribute Reflection.

To set the ROUGHNESS:

In the Attributes area:
Select the radio button Roughness

In the Value area:
Keep the value setting .50

In the Color area:
Make no changes at this time.

C.5 TRANSPARENCY
The transparency settings allow you to make all or part of an object transparent or translucent.

To set the TRANSPARENCY:

In the Attributes area:
Select the radio button Transparency

In the Value area:
The value you enter adjusts the material’s degree of transparency from 0 - 1.
The setting 0.00 displays the material as opaque
The setting 1.00 displays the material as transparent material

Use the slider or in the Value text box, type 1.00
Select the Preview button to see the effect

Use the slider or in the text box: Value, type .50
Select the Preview button to see the effect

Use the slider or in the text box: Value, type 0.00
Select the Preview button to see the effect

Keep the value setting at 0.00
**File Name:**

The File Name text box is used to locate and attach a bitmap image file to the Transparency Attribute. The bitmap is an image file. It could be a face, a wood sample, or any other image. This image file will appear as a projection on the object. The image will size itself to fit the object.

This image file will function as an opacity map - causing parts of the object to appear as solid and other parts to appear as transparent.

**Find File...**

Use this button to locate the image file you want to project on to the object.

1. Select the button: Find File...
2. The Bitmap File dialog box appears
3. Select the button: Find File...
4. The Browse/Search dialog box appears
5. Select the tab: Search
6. Find the File Types: drop-down menu
7. Highlight *.tga
8. Find the Search Location area
9. Select the radio button: All Drives
10. Select the button: Search
11. To the left, the available .tga files will appear
12. Find and highlight the file 3D.tga
13. In the text box Search Pattern:, the file and its path appear
14. Select the button: Open
15. You are returned to the Modify Standard Material dialog box
16. In the text box: File Name:, the file and its path appear
17. Select the Preview button to see the effect of 3d

**Bitmap Blend:**

The bitmap blend is used to determine how transparent the bitmap will be in relation to the Color/Pattern you just defined.

Move the Bitmap Blend slider from the right to the middle - - note that the number changes from 1.0 (opaque) to .50 (semi transparent).

Moving the slider to 0.0 will cause the image to disappear.

*Leave the setting at .50*

Click on the Preview button - - note that the image now allows the Color/Pattern to show through the image
Adjust Bitmap... The Adjust Bitmap button brings up the dialog box ADJUST MATERIAL BITMAP PLACEMENT. This menu is used to locate and scale the image on the object.

An important note:
At this point you could three image files associated with this material - WHITEASH.TGA attached to the diffuse color/pattern, CHECKERS.TGA associated with the reflection color, and 3D.TGA associated with the transparency attribute.

An important note:
At this point you could three image files associated with this material - WHITEASH.TGA attached to the diffuse color/pattern, CHECKERS.TGA associated with the reflection color, and 3D.TGA associated with the transparency attribute.

Change the bitmap blend of the WHITEASH.TGA , the CHECKERS.TGA, and the 3D.TGA.

Use the Preview button to monitor the changes.

Remove the bitmap before leaving this section.

C.6 REFRACTION
The refraction setting lets you set a refraction index for transparent materials. Refraction means to bend a ray of light as it passes through one object and is projected onto another. Retraction values have no effect on your material unless you have entered a value for the Transparency of your material.

To set the REFRACTION:

In the Attributes area:
Select the radio button Refraction

In the Value area:
Keep the value setting 1.0000

In the Color area:
Make no changes at this time

C.7 BUMP MAP
Bump mapping an image gives the appearance of embossing against a flat background, even though the geometry has not changed. This is the method for getting a pattern to appear 3 dimensional.

Bump map values are translated into apparent changes in the height of the surface of an object.

To set the BUMP MAP:

In the Attributes area:
Select the radio button Bump Map

File Name: The file name box is used to locate and attach a bitmap image file to the Bump map Attribute. The bitmap is an image file.

Find File... Use this button to locate the image file you want to project on to the object.

1. Select the button: Find File...
2. The Bitmap File dialog box appears
3. Select the button: Find File...
4. The Browse/Search dialog box appears
5. Select the tab: Search
6. Find the drop-down menu: FileTypes:
7. Highlight *.tga
8. Find the Search Location area
9. Select the radio button: All Drives
10. Select the button: Search
11. To the left, the available .tga files will appear
12. Find and highlight the file GRYBRICK.TGA
13. In the text box Search Pattern:, the file and its path appear
14. Select the button: Open
15. You are returned to the Modify Standard Material dialog box
16. In the text box: File Name:, the file and its path appear
17. Select the Preview button to see the effect.

**Bitmap Blend:**
The bitmap blend is used to determine how high the bitmap will appear in relation to the surface of the object.

Move the Bitmap Blend slider from the right to the middle - - note that the number changes from 1.0 to .50. Moving the slider to 0.0 will cause the image to appear flat on the surface.

*Leave the setting at .00*

**Adjust Bitmap...**
The Adjust Bitmap button brings up the Adjust Material Bitmap Placement menu. This menu is used to locate and scale the image on the object.

At this point you could have four image files available -

- WHITEASH.TGA linked to the Color/Pattern
- CHECKERS.TGA associated with the Reflection
- 3D.TGA associated with Transparency
- GRYBRICK.TGA associated with Bump Map

Change the bitmap blend of each and use the preview button to understand their relationship.

*Remove each of the bitmap image files before leaving this section.*

Choose Preview to see if the values you specified produce the effect you want. (Under the Preview button, remember to select the Cube option since we will be applying the paint to wall panels).

Change the values and continue to preview the changes until you're satisfied with the material's appearance.

Choose OK to exit the Modify Standard Materials dialog box.

Choose OK to exit the Materials dialog box.

**You have just defined and modified a standard material which we called ‘PAINT’.

Don’t forget to use the on-line help menu available in each of the menu screens.
CHECKLIST:

1. A standard material is one of how many materials you can create and define?
2. What 3 radio buttons are used to define the material's color and value?
3. What are the 3 ways to access and define a color?
4. HLS stands for...
5. RGB stands for...
6. What are the 2 shapes you can select to preview a sample of your material?
7. What is a bitmap image?
8. Onto which 4 radio buttons can you attach a bitmap image?
9. Do you understand how to locate and attach a bitmap image?
10. What does the value of the bitmap blend option control?
11. What is the ambient color?
12. If the lock button is left checked, how will the ambient color appear?
13. What does reflection control?
14. What does roughness determine?
15. If the transparency value setting is at 0.50, will the object be opaque, translucent, or transparent?
16. What does refraction control?
17. Which radio button gives the appearance of embossing against a flat background?
PROJECT 1 SUBMISSION

TOOLS NEEDED TO COMPLETE THE PROJECT:

- Drawing file: firstscan.dwg
- Image file: our_example_copy.bmp
- Image file: clock.tga
- Image file: checkers.tga

Open firstscan.dwg and match your rendered image on the left to the one created on the right. Your color should be a shade of purple, not some other color. Use the mview provided and render to this viewport, using the render command. If our example does not appear, use the image command. Push the Browse...button and select your CDrom as the drive. Find and select the file "our_example_copy.bmp". Push OK to exit the image command.

You will be creating a NEW Standard material with a name of your choice. The 3 colors (color/pattern, ambient, and reflection) are all different. It's the combination of the 3 distinct colors that produces the 1 color you see on the screen.

The same standard material is attached to both the sphere and the cube. There are 2 bitmap images attached to the same material: checkers.tga and clock.tga. Besides duplicating the color as closely as possible, it is your task to determine where the 2 bitmap images are attached to the material.

After you have created the standard material, attach it to the sphere and the cube with the rmat command. Continue modifying, previewing and rendering the image until you are satisfied with the results.
To submit your drawing, render your drawing with the Photo Real option.
Change the destination to File.
Push the More Options... button.
In the File Output Configuration box, change the File Type to TIFF. Under Colors, select 32 bit.
Push OK.

Push Render.

In the Rendering File box, name your rendering as follows:
Label the file with the first 6 letters of your last name _ 1
(For example, my uploaded files would look like this - - bender_1)

Save to a directory of your choice.

See the MSU CAD Technologies website, http://cad.msu.edu/ Tools section, for detailed instructions on uploading.

Upload this file by NOON on lecture day.
See the course outline for specific due dates.
AN EXAMPLE:

TOOLS NEEDED TO COMPLETE THE MODULE:

- Drawing file: wood.dwg
INSTRUCTIONS FOR COMPLETING THE MODULE:
The purpose of this assignment is to:

- Define a material with wood pattern
- Adjust the light and dark colors of wood grain
- Add reflection, roughness and scale values to wood grain
- Understand the differences in ring density, width and shape and its affect on the appearance of wood

A WOOD MATERIAL

Open the drawing: wood.dwg from the course CD Rom
Save as a name of your choice.
Current layer: shelving

For each object in your rendering:

1. Identify a material type -  
   Standard  
   Wood  
   Marble  
   Granite

2. Name the material
3. Define the material's characteristics or attributes
4. Preview the result
5. Make necessary adjustments
6. Save the settings

There are two methods you can use to define a wood surface:
1. The easiest method is to define a Wood material as described in the previous section. You would define the diffuse, ambient, and reflection color and attach a bitmap of wood to the diffuse color. There are some limitations to the graining patterns that can be achieved.
2. The second method is to use a special procedural material for rendering solids. Procedural materials allow you to scale the bitmap patterns on to the objects. This procedure requires one of the photorealistic renderers. At rendering time, this material generates a 3D pattern in tw or more colors and applies it to an object. The pattern is controlled by parameters that vary the material. This material is also known as a template material. You cannot export a procedural material to other applications.

To define Wood as a special procedural material:

1. From the View pull-down menu:  
   Choose Render > Materials
2. In the Materials dialog box:  
   Use the arrow key under New... to select Wood
   Push New...
3. In the New Wood Materials dialog box:  
   Enter a name in the Material Name box  
   (the name must be unique and have no more than 16 characters)

   For this exercise, enter the Material Name:  
   ASH
4. Set the color and specify a value for each of the material's attributes using the New Wood Material menu.
The first three categories define the color and value options:

**LIGHT COLOR** C.8
**DARK COLOR** C.9
**REFLECTION** C.10

The color can be defined using the components in the Color box:
- **the Color System** Hue, Lightness, Saturation HLS option and/or
- **the Color System** Red, Green, Blue option and/or
- **the Color System** color swatch box (to the right of the RGB/HLS box. You access this color swatch by double clicking on it, a color menu will appear)

You can make the Light Color, Dark Color, and reflection colors the same by checking the Lock box or,
You can assign a different color for each category or,
You can assign color using the ACI AutoCAD Color Index check box
(You assigned an ACI color when you selected the layer color or changed the color property of an object. With ACI checked, you do not have access to the Color System options).

The remaining categories have only value options:

**ROUGHNESS** C.11
**LIGHT/DARK** C.12
**RING DENSITY** C.13
**RING WIDTH** C.14
**RING SHAPE** C.15
**SCALE** C.16
**BUMP MAP** C.17

Let's go through each of the settings for defining a new Wood material like Ash.
You will want to play with each of the settings and view the effect on the rendered output.

First, use the setting defined in this script and then use the setting in its lowest position (slider left), use the setting in its highest position (slider right), and finally return the setting to the script setting.

White boxes in the menu indicate the need for a decision - - gray boxes indicate no decision available.

### C.8 LIGHT COLOR

The Light Color settings define the lightest component of the wood, the background color.
(You adjust the Light Color with the Value and Color controls. You can view the result in the preview window)

**To set the LIGHT COLOR:**

In the Attributes area:
Select the Light Color radio button

In the Color area:
Color system: Use the arrow button to select HLS
(You will notice that the box headings change to Hue, Lightness, and Saturation).

*Try changing the HLS using the sliders.* You will see that the numbers change.
Color system: Use the arrow button to select **RGB** 
(Notice that the RGB option does not allow you to change Lightness).

You will find that the preview and sample windows will go to gray when your setting are at the high end of the sliders. Don’t panic, they will often appear in the rendering.

*Try changing the RGB using the sliders. You will see that the numbers change.*

Double-click on the color sample to access the Color menu.
  - Select the Basic colors with a single click.
  - Modify the color selection by selecting and dragging the target in the rainbow window to change the color selection. Select and drag the arrow slider on the right of the box to change the value.
  - Select OK to make the change to the color system sample.

Note that the color selection appears in two places on the menu screen -
  - The *Light Color* color box
  - The sample color box

Push Preview - The Preview provides a general impression of the Light Color of the wood.

**C.9  DARK COLOR**

The settings for the Dark Color define the color of the wood’s grain.

To set the **DARK COLOR**:

In the Attributes area:
  - Select the Dark Color radio button

In the Color area:
  - **Color System**
    - Use the same procedure described under Color/Pattern Color System for adjusting HLS, RGB, and the color sample

Begin with the sample on the second row from the bottom and second from your right.

Adjust the color until you are satisfied with the color of the wood grain.

Check the Preview before leaving this section

**C.10  REFLECTION**

The reflection settings determine the color of the reflected highlights. You may see this referred to as *specular reflection*.

To set the **REFLECTION**:

In the Attributes area:
  - Select the Reflection radio button

In the Value area:
  - Set the value to **.23**

(For a shiny finish, set the value for reflection to 0.7, and set the value for Color/Pattern to 0.3).

In the Color area:
  - **ACI box**
    - Checking this box will use the ACI color as the ambient color

Unchecking the ACI box will allow you to access the Color System options. RGB, HLS, and Sample box. This allows you to set a color unlike the other colors.

*Place a check in the By ACI box*
Mirror box

By checking the Mirror box, you can achieve a mirrored reflection when you use one of the Photo Realistic renderers.

*Leave the Mirror box unchecked*

File Name:

The file name box is used to locate and attach a bitmap image file to the Reflection Attribute.
The bitmap is an image file. It could be a face or a wood sample, or any other image.

This will appear on the object as a slide of the image was projected on to the object. The image will size itself to fit the object.

Find File...

Use this button to locate the image file you want to project on to the object.

Bitmap Blend:

The bitmap blend is used to determine how transparent the bitmap will be in relation to the Color/Pattern you just defined.

Moving the Bitmap Blend slider from the right to the middle - - changes the bitmap from 1.0 (opaque) to .50 (semi transparent). Moving the slider to 0.0 will cause the image to disappear.

Adjust Bitmap...

The Adjust Bitmap button brings up the Adjust Material Bitmap Placement menu. This menu is used to locate and scale the image on the object. This is discussed in more detailed in the Mapping module [18].

**C.11 ROUGHNESS**

The roughness setting determines the size of the reflected highlight.
Roughness values have no effect if you have not entered a value for reflection under Attributes Reflection.

To set the **ROUGHNESS**:

In the Attributes area:
Select the Roughness radio button

In the Value area:
Keep the value setting at .50

**C.12 LIGHT/DARK**

The Light/Dark setting allows you to control the proportion of light to dark rings in the wood.

To set the **LIGHT/DARK**:

In the Attributes area:
Select the Light/Dark radio button

In the Value area:
Set the value 0.80

The setting 0.00 displays almost all wood *grain color*
The setting 1.00 displays almost all wood *background*
C.13 RING DENSITY

The Ring Density Value specifies the number of rings in the wood relative to the object or objects on which you attach the wood material; higher scale values result in a finer, tighter grain.

To set the RING DENSITY:

In the Attributes area:
Select the Ring Density radio button

In the Value area:
Preview the default value of 6.00 and then try higher numbers like 12.00 and 24.00.
Set the value to 12.000

C.14 RING WIDTH

The Ring Width value controls the variation of the width of the rings.

A ring width of:
0.00 gives completely uniform rings
1.00 gives the greatest ring variation

To view the Ring Width variation, first go to the Attributes area:
Select the Scale radio button and change the Value from 6.2500 to 2.0000
Select OK

To set the RING WIDTH:

In the Attributes area:
Select the Ring Width radio button

In the Value area:
Pay attention to the end grain to see the variation in the ring widths.

Preview with a value of 0.00
(Top illustration)

Preview with a value of 1.00
(Bottom illustration)

Set the value to 0.50
C.15  RING SHAPE

The Ring Shape Value controls the irregularity of the shape of the rings.

- A shape of:
  - 0.00 gives completely circular rings
  - 1.00 gives the most irregular rings

To set the RING SHAPE:

In the Attributes area:
  - Select the Ring Shape radio button

In the Value area:
  - Pay attention to the end grain to see the variation in the ring widths.
    - Preview with a value of 0.00 (Top illustration)
    - Preview with a value of 1.00 (Bottom illustration)

Set the value to 0.50

---

C.16  SCALE

Defines the scale of the wood grain relative to the object or objects on which you attach the wood material.

An important note:
This means that the wood grain pattern will appear THE SAME whether it is attached to a 1" cube or a 3' table. You will need to image how many times the grain pattern needs to be repeated on the object to correctly represent the wood you select.

To set the SCALE:

In the Attributes area:
  - Select the Scale radio button

In the Value area:
  - Preview with a value of 0.010 (slider left)
  - Preview with a value of 0.800 (slider middle)
  - Preview with a value of 10.00 (slider 3/4 to the right)

*The slider values range from 0.010 to 100.00

Set the value to 0.50 (Illustration at right)
C.17 BUMP MAP

Bump mapping an image gives the appearance of embossing against a flat background, even though the geometry has not changed. This is the method for getting a pattern to appear 3-dimensional.

Bump map values are translated into apparent changes in the height of the surface of an object.

To set the BUMP MAP:

In the Attributes area:

- Select the Bump Map radio button

File Name: The file name box is used to locate and attach a bitmap image file to the Bump map Attribute. The bitmap is an image file.

Find File... Use this button to locate the image file you want to project on to the object.

Select the Preview button to see the effect.

Bitmap Blend: The bitmap blend is used to determine how high the bitmap will appear in relation to the surface of the object.

Move the Bitmap Blend slider from the right to the middle.

Note that the number changes from 1.0 to .50.

Moving the slider to 0.0 will cause the image to disappear on the surface.

Leave the setting at 0.00

Push Preview

Adjust Bitmap... The Adjust Bitmap button brings up the Adjust Material Bitmap Placement dialog box. This box is used to locate and scale the image on the object. This is discussed in more detail in the Mapping module [18].

Like a Standard material, you can attach more than one bitmap to a wood material. You can attach these images under the options Reflection and Bump Map only. You can change the bitmap blend of each and use the Preview button to understand their relationship to the wood. Refer to Module 17B - Standard Material for a more detailed explanation of bitmap images.

Push Preview to see if the values you specified produce the effect you want.

(Under the Preview button, remember to select the Cube option since we will be applying the ASH material to rectangular cabinetry.

Change the values and continue to preview the changes until you're satisfied with the material's appearance.

Push OK to exit the New Wood Material dialog box.

You have just defined a wood material which we called ‘ASH’.

Don't forget to use the on-line help menu available in each of the menu screens.

CHECKLIST:

1. Which 3 radio buttons control the end resulting color of the wood?
2. The size of the reflected highlight is controlled by which option?
3. The light/dark option controls the proportion of what?
4. A high ring density value results in what?
5. A ring width value of 0.00 will produce what sort of wood grain?
6. What does the scale value control?
7. Under which radio buttons can you attach a bitmap image?
AN EXAMPLE:

TOOLS NEEDED FOR THE MODULE:

- Drawing file: marble.dwg
INSTRUCTIONS FOR COMPLETING THE MODULE:

The purpose of this assignment is to:

- Assign a marble pattern to an object
- Use the color system to manipulate the vein color and the stone color
- Adjust the values of reflection, roughness, scale, sharpness and turbulence to a marbled material

A MARBLE MATERIAL

For each object in your rendering:

1. Identify a material type -
   - Standard
   - Wood
   - Marble
   - Granite
2. Name the material
3. Define the material’s characteristics or attributes
4. Preview the result
5. Make necessary adjustments
6. Save the settings

There are two methods you can use to define a marble surface:

1. The easiest method is to define a *marble* material as described in the Standard Materials section.
2. The second method is to use a special procedural material for rendering solids as described in the Wood Materials section.

Open the drawing: *marble.dwg* from the course CD-Rom or AFS site

Current layer: *table*

To define *Marble* as special procedural material:

1. From the View menu, choose Render > Materials
2. In the Materials dialog box:
   - Use the arrow key under New... to select Marble
   - Push New...
3. In the New Marble Materials dialog box:
   - Enter a name in the Material Name box
   - (the name must be unique and have no more than 16 characters)
   - For this exercise enter the Material Name: *TOP*
4. Set the color and specify a value for each of the material’s attributes using the New Marble Material menu
The first three categories define the color and value options:

- **STONE COLOR** C.18
- **VEIN COLOR** C.19
- **REFLECTION** C.20

The color can be defined using the components in the Color box:

- the Color System Hue, Lightness, Saturation HLS option and/or
- the Color System Red, Green, Blue option and/or
- the Color System color swatch box (to the right of the RGB/HLS box. You access this color swatch by double clicking on it and a color menu will appear)

You can:

- make the Stone Color, Vein Color, and Reflection colors the same by checking the Lock box
- or -
- you can assign a different color for each category
- or -
- you can assign color using the ACI AutoCAD Color Index check box

The remaining categories have only value options:

- **ROUGHNESS** C.21
- **TURBULENCE** C.22
- **SHARPNESS** C.23
- **SCALE** C.24
- **BUMP MAP** C.25

Let’s go through each of the settings for defining a new Marble material like TOP. You will want to play with each of the settings and view the effect on the rendered output.

First, use the setting defined in this script and then use the setting in its lowest position (slider left), use the setting in its highest position (slider right), and finally, return the setting to the script setting.

White boxes in the menu indicate the need for a decision
- - gray boxes indicate no decision available.
C.18 STONE COLOR

The Stone Color settings define the marble matrix
(You adjust the Light Color with the Value and Color controls. You can view the result in the preview window).

To set the STONE COLOR:
You should be in the NEW MARBLE MATERIAL dialog box, with the material named TOP.

In the Attributes area:
Select the Stone Color radio button

In the Color area:
Color system: Use the arrow button to select HLS
(You will notice that the box headings change to Hue, Lightness, and Saturation).

Try changing the HLS using the sliders. You will see that the numbers change.

Color system: Use the arrow button to select RGB
(Notice that the RGB option does not allow you to change Lightness).

You will find that the preview and sample windows will go to gray when your setting are at the high end of the sliders. Don’t panic, they will often appear in the rendering.

Try changing the RGB using the sliders. You will see that the numbers change.

Double-click on the color sample to access the Color menu.
Select the Basic color sample on the fifth line and second from your left with a single click.
Modify the color selection by selecting and dragging the target in the rainbow window to change the color selection. Select and drag the arrow slider on the right of the box to change the value.
When you are satisfied with the background color, select OK to make the change to the color system sample.

Note that the color selection appears in two places on the menu screen -
The Stone Color color box
The sample color box

Push Preview - The Preview provides a general impression of the Stone Color of the marble.

C.19 VEIN COLOR

The settings for the Vein Color define the vein color of the marble. The vein color slices through the background and creates the "lighting" effect on the marble material.

To set the VEIN COLOR:
You should be in the NEW MARBLE MATERIAL dialog box, with the material named TOP.

In the Attributes area:
Select the Vein Color radio button

In the Color area:

Use the same procedure described under Color/Pattern Color System for adjusting HLS, RGB, and sample colors.

Suggestion: Double-click on the color sample box to access the Color dialog box. Select the sample on the second row from the bottom and second from your right. This is a deep purple.
Adjust the color until you are satisfied with the color of the marble vein.

Check the Preview before leaving this section.

## C.20 REFLECTION

The reflection settings determine the color of the reflected highlights. You may see this referred to as \textit{specular reflection}.

### To set the REFLECTION:

You should be in the NEW MARBLE MATERIAL dialog box, with the material named TOP.

In the Attributes area:

- Select the Reflection radio button

In the Value area:

- The value setting is a scalar value.
- 0.00 displays the material with no reflection (see top illustration)
- 1.00 displays the material with high reflection (see bottom illustration)

Try various settings.

Set the value to 0.23

In the Color area:

- ACI box Checking this box will use the ACI color as the ambient color.
- Unchecking the ACI box will allow you to access the Color System options: RGB, HLS, and sample box. This allows you to set a color unlike the other colors.

\textit{Place a check in the By ACI box}

- Mirror box By checking the Mirror box, you can achieve a mirrored reflection when you use one of the Photo Realistic renderers.

\textit{Leave the Mirror box unchecked}

### File Name:

The file name box is used to locate and attach a bitmap image file to the Reflection attribute.

- The bitmap is an image file. It could be a face or a wood sample, or any other image. This will appear on the object as a slide of the image was projected on to the object. The image will size itself to fit the object.

Find File . . Use this button to locate the image file you want to project on to the object.

### Bitmap Blend:

The bitmap blend is used to determine how transparent the bitmap will be in relation to the Color/Pattern you just defined. Moving the Bitmap Blend slider from the right to the middle, changes the bitmap from 1.0 (opaque) to .50 (semi transparent). Moving the slider to 0.0 will cause the image to disappear.

### Adjust Bitmap ... The Adjust Bitmap button brings up the Adjust Material Bitmap Placement menu. This menu is used to locate and scale the image on the object. This is discussed in the module on Mapping.
C.21 ROUGHNESS

The roughness setting determines the size of the reflected highlight. The lower the level of roughness, the smaller the highlight. Roughness values have no effect if you have not entered a value for reflection under the Reflection attribute. (NOTE: This may not be apparent until the scale has been manipulated).

To set the ROUGHNESS:
You should be in the NEW MARBLE MATERIAL dialog box, with the material named TOP.

In the Attributes area:
Select the Roughness radio button

In the Value area:
Keep the value setting at 0.50

C.22 TURBULENCE

Turbulence defines the degree of the vein’s motion or randomness. (NOTE: This may not be apparent until the scale has been manipulated).

To set the TURBULENCE:
You should be in the NEW MARBLE MATERIAL dialog box, with the material named TOP.

In the Attributes: box,
Select the Turbulence radio button

In the Value area: The value setting is a scalar value.

0 displays the material little vein pattern
(see top illustration)

100 displays the material with high vein pattern; too high to view in the preview
(see bottom illustration)

Higher Turbulence values result in more of the vein color with more swirling.
Higher Turbulence values take longer to render; values in the range of 1-10 are recommended.

Try various settings.
Set the value to 2

C.23 SHARPNESS

Sharpness controls the clear definition and distinction of the veins. The stone and vein colors can be distinct or can blend at the edges of the veins. (NOTE: This may not be apparent until the scale has been manipulated).

To set the SHARPNESS:
You should be in the NEW MARBLE MATERIAL dialog box, with the material named TOP.

In the Attributes area:
Select the Sharpness radio button
In the Value area:

Preview the default and then try various settings from 0.00 to 1.00.
Lower settings blend the color at the edges of the veins.
Higher settings sharpen the color at the edges of the veins.

Set the value to 0.20

---

C.24 SCALE

The Scale option defines proportion, ratio or scale of the marble pattern relative to the object or objects on which it is attached.

This means that the marble pattern will appear the SAME whether it is attached to a 1" cube or a 3' table. You will need to image how many times the vein pattern needs to be repeated on the object to correctly represent the marble.

To set the SCALE:
You should be in the NEW MARBLE MATERIAL dialog box, with the material named TOP.

In the Attributes area:
Select the Scale radio button

In the Value area:

Preview with a value of 0.0100
(see top illustration)

Preview with a value of 0.6000
(see middle illustration)

Preview with a value of 2.00
(see bottom illustration)

Try other various settings as well.

Set the value to 0.6000

---

C.25 BUMP MAP

Bump mapping an image gives the appearance of embossing against a flat background, even though the geometry has not changed. This is the method for getting a pattern to appear 3-dimensional.

Bump map values are translated into apparent changes in the height of the surface of an object.

To set the BUMP MAP:
You should be in the NEW MARBLE MATERIAL dialog box, with the material named TOP.

In the Attributes area:
Select the Bump Map radio button

File Name: The file name box is used to locate and attach a bitmap image file to the Bump map attribute. The bitmap is an image file.
Find File . . Use this button to locate the image file you want to project on to the object. Select the Preview button to see the effect.

Bitmap Blend: The bitmap blend is used to determine how high the bitmap will appear in relation to the surface of the object. Move the Bitmap Blend slider from the right to the middle. Note that the number changes from 1.0 to .50. Moving the slider to 0.0 will cause the image to disappear on the surface.

*Leave the setting at 0.00*

Click on the Preview button

Adjust Bitmap ... The Adjust Bitmap button brings up the Adjust Material Bitmap Placement menu. This menu is used to locate and scale the image on the object.

Choose Preview to see if the values you specified produce the effect you want.

(Under the preview button, remember to select the Cube option since we will be applying the marble a table top).

Change the values and continue to preview the changes until you’re satisfied with the material’s appearance.

Push OK

*You have just define a marble material which we called ‘TOP’.*

Don’t forget to use the on-line help menu available in each of the menu screens.

**CHECKLIST:**

1. Do you understand the difference between the stone color and the vein color?
2. Which two options allow you to attach a bitmap image to the marble material?
3. To see a polished marble, would you set the reflection value high or low?
4. If the sharpness value is set to 0.00, will the veins be clear or blended?
5. A scale of 0.10 will produce what kind of effect on the granite?
AN EXAMPLE:

TOOLS NEEDED TO COMPLETE THE MODULE:

- Drawing file: granite.dwg
- Image file: pat0148.tga
INSTRUCTIONS TO COMPLETE THE MODULE:
The purpose of this assignment is to:
• Define granite as a special material
• Assign values to granite’s 4 colors
• Adjust the reflection, sharpness and scale values for granite
• Attach a bitmap to a granite material

A GRANITE MATERIAL

For each object in your rendering:
1. Identify a material type -
   Standard
   Wood
   Marble
   Granite
2. Name the material
3. Define the material’s characteristics or attributes
4. Preview the result
5. Make necessary adjustments
6. Save the settings

There are two methods you can use to define a granite surface:
1. The easiest method is to define a granite material as described in the Standard Materials section.
2. The second method is to use a special procedural material for rendering solids as described in the Wood Materials section.

Open the drawing file: granite.dwg from the course CD-Rom or AFS site
Current layer: floor_tile
View, restore: View1

To define Granite as a special procedural material:
1. From the View menu, choose Render > Materials
2. In the Materials dialog box:
   Use the arrow key under New... to select
   Granite
   Push New...
3. In the New Granite Materials dialog box:
   Enter a name in the Material Name text box
   (the name must be unique and have no more than 16 characters)

   For this exercise, enter the Material Name: FLOOR
4. Set the color and specify a value for each of the material’s attributes using the New Standard Material menu.
The first five categories define the color and value options:

**FIRST COLOR**  C.26
**SECOND COLOR**  C.27
**THIRD COLOR**  C.28
**FOURTH COLOR**  C.29
**REFLECTION**  C.30

The color can be defined using the components in the Color box:
- the Color System  Hue, Lightness, Saturation HLS option and/or
- the Color System  Red, Green, Blue option and/or
- the Color System  color swatch box (to the right of the RGB/HLS box; you access this color swatch by double clicking on it and the color menu will appear)

You can make the First Color, Second Color, Third Color, Fourth Color, and Reflection colors the same
- or -
You can assign a different color for each category
- or -
You can assign color using the ACI AutoCAD Color Index check box
(You assigned an ACI color when you selected the layer color or changed the color property of an object. With ACI checked, you do not have access to the Color System options).

The remaining categories have only value options:

**ROUGHNESS**  C.31
**SHARPNESS**  C.32
**SCALE**  C.33
**BUMP MAP**  C.34

Let's go through each of the settings for defining a new Granite material.
You will want to explore each of the settings and view their effects on the rendered output.

First, use the default settings and then use the setting in its lowest position (slider left), use the setting in its highest position (slider right), and finally return the setting to the script setting.
White boxes in the menu indicate the need for a decision - -
gray boxes indicate no decision available.
C.26 FIRST COLOR

To set the FIRST COLOR:
You should be in the NEW GRANITE MATERIAL dialog box, with the material named FLOOR.
In the Attributes area:
    Select the First Color radio button

In the Value area: The value specifies the relative amount of each color in the granite pattern.
    Setting the value to 0.00 removes that color from the pattern.
    Setting the value to 1.00 shows the maximum of the color.
    If each of the four colors in the granite are set to 1.00, each color will represent 25% of the pattern. If three colors are set to 0.00, the remaining color will represent the total pattern.
    Set the value to 0.50

In the Color area:
    Color system: Use the arrow button to select HLS
        (You will notice that the box headings change to Hue, Lightness, and Saturation).
        Try changing the HLS using the sliders. You will see that the numbers change.
    Color system: Use the arrow button to select RGB
        (Notice that the RGB option does not allow you to change Lightness).
        You will find that the preview and sample windows will go to gray when your settings are at the high end of the sliders. Don’t panic, they will often appear in the rendering.
        Try changing the RGB using the sliders. You will see that the numbers change.

Double-click on the color sample to access the Color menu.
    Select one of the Basic colors with a single click.
    Modify the color selection by selecting and dragging the target in the rainbow window to change the color selection. Select and drag the arrow slider on the right of the box to change the value.
    Select OK to make the change to the color system sample.

Note that the color selection appears in two places on the menu screen -
    The First Color color box
    The sample color box

Preview the color you’ve created by pushing the Preview button
    This presents an example of a rendered sphere.
    Use the arrow to the right of word ‘Sphere’ to select the Cube option.
    Click on Preview again
    This presents an example of a rendered cube.

Don’t be shocked by the fact that the default is completely out of scale.
The Preview just provides a general impression of the color.
C.27 SECOND COLOR

To set the **SECOND COLOR**:  
You should be in the NEW GRANITE MATERIAL dialog box, with the material named FLOOR.  
In the Attributes area:  
Select the Second Color radio button

In the Value area:  
The value specifies the relative amount of each color in the granite pattern.  
Setting the value to 0.00 removes that color from the pattern.  
Setting the value to 1.00 shows the maximum of the color.  
If each of the four colors are set to 1.00, each color will represent 25% of the pattern.  
If three colors are set to 0.00, the remaining color will represent the total pattern.  
Set the value to **0.50**

In the Color area:
- **Color system:** Use the arrow button to select HLS (You will notice that the box headings change to Hue, Lightness, and Saturation).
  *Try changing the HLS using the sliders.* You will see that the numbers change.
- **Color system:** Use the arrow button to select RGB (Notice that the RGB option does not allow you to change Lightness).
  You will find that the preview and sample windows will go to gray when your settings are at the high end of the sliders.  Don’t panic, they will often appear in the rendering.  
  *Try changing the RGB using the sliders.* You will see that the numbers change.

Double-click on the color sample to access the Color menu.  
Select one of the Basic colors with a single click.  
Modify the color selection by selecting and dragging the target in the rainbow window to change the color selection.  
Select and drag the arrow slider on the right of the box to change the value.  
Select OK to make the change to the color system sample

Note that the color selection appears in two places on the menu screen -  
The Second Color color box  
The sample color box

Preview the color you’ve created by pushing the Preview button  
This presents an example of a rendered sphere.  
Use the arrow to the right of word ‘Sphere’ to select the **Cube** option.

Click on Preview again  
This presents an example of a rendered cube.

Don’t be shocked by the fact that the default is completely out of scale.  
The Preview just provides a general impression of the color.
C.28  THIRD COLOR

To set the THIRD COLOR:
You should be in the NEW GRANITE MATERIAL dialog box, with the material named FLOOR.
In the Attributes area:
    Select the Third radio button

In the Value area:
    The value specifies the relative amount of each color in the granite pattern.
    Setting the value to 0.00 removes that color from the pattern.
    Setting the value to 1.00 shows the maximum of the color.

If each of the four colors are set to 1.00, each color will represent 25% of the pattern. If three colors are set to 0.00, the remaining color will represent the total pattern.

Set the value to 0.50

In the Color area:
    Color system: Use the arrow button to select HLS
    (You will notice that the box headings change to Hue, Lightness, and Saturation).
    Try changing the HLS using the sliders. You will see that the numbers change.

    Color system: Use the arrow button to select RGB
    (Notice that the RGB option does not allow you to change Lightness).
    You will find that the preview and sample windows will go to gray when your settings are at the high end of the sliders. Don’t panic, they will often appear in the rendering.
    Try changing the RGB using the sliders. You will see that the numbers change.

Double-click on the color sample to access the Color menu.
    Select one of the Basic colors with a single click.
    Modify the color selection by selecting and dragging the target in the rainbow window to change the color selection. Select and drag the arrow slider on the right of the box to change the value.
    Select OK to make the change to the color system sample

Note that the color selection appears in two places on the menu screen -
    The Third Color color box
    The sample color box

Preview this color as you did the previous colors.

C.29  FOURTH COLOR

To set the FOURTH COLOR:
You should be in the NEW GRANITE MATERIAL dialog box, with the material named FLOOR.
In the Attributes area:
    Select the Fourth Color radio button

In the Value area:
    The value specifies the relative amount of each color in the granite pattern.
    Setting the value to 0.00 removes that color from the pattern.
    Setting the value to 1.00 shows the maximum of the color.

If each of the four colors are set to 1.00, each color will represent 25% of the pattern. If three colors are set to 0.00, the remaining color will represent the total pattern.
Set the value to 0.50

In the Color area:

Color system: Use the arrow button to select HLS
(You will notice that the box headings change to Hue, Lightness, and Saturation).

*Try changing the HLS using the sliders.* You will see that the numbers change.

Color system: Use the arrow button to select RGB
(Notice that the RGB option does not allow you to change Lightness).

You will find that the preview and sample windows will go to gray when your settings are at the high end of the sliders. Don’t panic, they will often appear in the rendering.

*Try changing the RGB using the sliders.* You will see that the numbers change.

Double-click on the color sample to access the Color menu.
Select one of the Basic colors with a single click.
Modify the color selection by selecting and dragging the target in the rainbow window to change the color selection. Select and drag the arrow slider on the right of the box to change the value.
Select OK to make the change to the color system sample.

Note that the color selection appears in two places on the menu screen -
The Fourth Color color box
The sample color box

Preview this color as you did the previous colors.

**C.30 REFLECTION**

The reflection settings determine the color of the reflected highlights. You may see this referred to as *specular reflection*.

To set the REFLECTION:
You should be in the NEW GRANITE MATERIAL dialog box, with the material named FLOOR.

In the Attributes area:
Select the Reflection radio button

In the Value area:
Setting the value to 0.00 gives a matte finish
Setting the value to 1.00 gives a polished finish

Set the value to 0.30

In the Color area:
ACI box
Checking this box will use the ACI color as the ambient color
Unchecking the ACI box will allow you to access the Color System options. RGB, HLS, and Color Sample box. This allows you to set a color unlike the other colors.

Mirror box
By checking this option, you can achieve a mirrored reflection when you use one of the Photo Realistic renderers.

File Name:
The file name box is used to locate and attach a bitmap image file to the Reflection Attribute.
The bitmap is an image file. It could be a face or a wood sample, or any other image. This will appear on the object as a slide of the image projected on to the object. The image will size itself to fit the object.

Find File . .
Use this button to locate the image file you want to project on to the object. This may very likely be an image of wood, fabric, person, etc. that you scan. This will be the technique for including an exact representation of a sample in your rendering.
Find the file:  *pat0148.tga*
  Click on:    Find File . . . button
  The Bitmap File dialog box appears
  Click on:    Find File . . . button

The Browse/Search dialog box appears
  Click on the Search tab at the top
  Search Pattern:       Type - - *pat0148.tga*
  Select Open

You are returned to the New Granite Material dialog box.
  The path and file name appear in the File Name: box
  Select the Preview button to see the effect.

Bitmap Blend:     The bitmap blend is used to determine how transparent the bitmap will be in relation to the
                  Color/Pattern you just defined.

Move the Bitmap Blend slider from the right to the middle - - note that the number changes from
1.0 (opaque) to .50 (semi transparent).  Moving the slider to 0.0 will cause the image to
disappear.

Leave the setting at 0.50

Click on the Preview button.  Note that the image now allows the Color/Pattern to show through the image.

Adjust Bitmap ... The Adjust Bitmap button brings up the
Adjust Material Bitmap Placement menu.  This menu is
used to locate and scale the image on the object.  It is not always available.  This is discussed in
more depth in Module 18 on Mapping.

Leave the bitmap blend at 0.00 before leaving this section.

**C.31 ROUGHNESS**

The roughness setting determines the size of the reflected highlight.
Roughness values have no effect if you have not entered a value for Reflection in the Attributes area of the Granite Material dialog box.

**To set the ROUGHNESS:**
You should be in the NEW GRANITE MATERIAL dialog box, with the material named FLOOR.

In the Attributes area:
  Select the Roughness radio button

In the Value area:
  Keep the value setting 0.50

**C.32 SHARPNESS**

Sharpness defines the "crispness" of the stone.  This has to do with the pixelation of the image on the screen and the printout.
Sharpness controls the pixels.  The value can make the pixels a fuzzy grey or a distinct black and white projection.

**To set the SHARPNESS:**
You should be in the NEW GRANITE MATERIAL dialog box, with the material named FLOOR.

In the Attributes area:
  Select the Sharpness radio button
In the Value area: The value setting is a scalar value. The higher the value, the more distinct the granite pattern.

0.00 displays the material as completely blurred (see top illustration)

1.00 displays the material as a transparent material (see bottom illustration)

Try various settings.

Set the value to 0.90

C.33 SCALE

Scale defines the proportion, ratio or scale of the material relative to objects on which the material is attached.

To set the SCALE:
You should be in the NEW GRANITE MATERIAL dialog box, with the material named FLOOR.

in the Attributes area:
Select the Scale radio button

In the Value area: The value setting is a scalar value. The lower the scale value, the finer the resulting pattern.

0.0100 displays the material with a fine pattern (see top illustration)

100.00 displays the material with a course pattern (see bottom illustration)

Try various settings.

Set the value to 0.50

C.34 BUMP MAP

Bump mapping an image gives the appearance of *embossing* against a flat background, even though the geometry has not changed. This is the method for getting a pattern to appear 3 dimensional.

Bump map values are translated into apparent changes in the height of the surface of an object.

To set the BUMP MAP:
You should be in the NEW GRANITE MATERIAL dialog box, with the material named FLOOR.

In the Attributes area:
Select the Bump Map radio button
File Name: The file name box is used to locate and attach a bitmap image file to the Bump map Attribute. The bitmap is an image file.

Find File . . Use this button to locate the image file you want to project on to the object. The path and file name appear then in the File Name: box.

Select the Preview button to see the effect.

Bitmap Blend: The bitmap blend is used to determine how high the bitmap will appear in relation to the surface of the object.

Move the Bitmap Blend slider from the right to the middle. Note that the number changes from 1.0 to .50. Moving the slider to 0.0 will cause the image to disappear on the surface.

Leave the setting at 0.00

Adjust Bitmap ... The Adjust Bitmap button brings up the Adjust Material Bitmap Placement menu. This menu is used to locate and scale the image on the object.

Remove any bump map bitmaps before leaving this section.

Change the values and continue to preview the changes until you're satisfied with the granite's appearance.

Push OK when you are done.

You have just defined a granite material which we called ‘FLOOR’.

Don’t forget to use the on-line help menu available in each of the menu screens for additional assistance.

CHECKLIST:

1. How many colors are needed to define granite?
2. Which two options allow you to attach a bitmap image to the granite material?
3. To see a polished granite, would you set the reflection value high or low?
4. If the sharpness value is set to 0.00, will the image be blurred or transparent?
5. A scale of 0.50 will produce what kind of effect on the granite?
MODULE R3-D

Modifying Existing Materials
AN EXAMPLE:

TOOLS NEEDED TO COMPLETE THE MODULE:

- Drawing file: modify.dwg
INSTRUCTIONS FOR COMPLETING THE MODULE:

The purpose of this assignment is to:

- Understand the procedure for changing the properties of an existing material

MODIFYING EXISTING MATERIALS

You can modify a material and/or duplicate a material using the Duplicate and Modify buttons in the Materials dialog box.

This becomes very important because it is much easier to select a material, duplicate it, and modify the new material, than it is to define a material from scratch as you did in the previous sections of this module.

Open the drawing: modify.dwg from the course CD Rom
Save as a name of your choice.
Current layer: 0
Current view: view2

To Duplicate a material:

From the View pull-down menu:
Select Render
Select Materials

Under Materials, highlight the material you want to duplicate
Highlight PAINT
Press the Duplicate button

In the New Standard Material dialog box, place your cursor in the Material Name text box
Type a new name for the material (i.e. paintchip)

Under Attributes, make the changes using the same procedure you used to define the material
Press OK when done

To modify a material:

From the View pull-down menu:
Select Render
Select Materials

Under Materials, highlight the material you want to modify
Highlight PAINT
Press the Modify button

Under Attributes, make the changes using the same procedure you used to define the material
Press OK when done

AFTER you have defined the lights in your rendering, you will use these commands again to adjust each of the materials until you are satisfied with their representation.
To manipulate a material from AutoCAD's library list:

From the View pull-down menu:
Select Render
Select Materials Library...

In the Materials Library dialog box,
Highlight a material on the right under the Library List
Push the <- Import button

A copy of the material is now transferred to the materials list of your drawing

To delete a material:

From the View pull-down menu:
Select Render
Select Materials Library...

In the Materials Library dialog box,
Highlight a material to delete (you can delete a material from the materials list of your drawing on the left, or you can delete a material from the Library List of the software)

Push the Delete button
Push OK

Materials in the drawing materials list that are attached to an object or group of objects will delete only after AutoCAD provides you with a Warning message. For example, if you select PAINT and push the Delete, a warning box like the one at right will appear.

Likewise, if changes are made to the Library List on the right, AutoCAD notifies you of a Library Modification. You can either save the changes to a new library (.mli) file, discard the changes or cancel the deletion of the material.
CHECKLIST:

1. Do you understand the difference between duplicating and modifying a material?
2. Do you understand how to manipulate one of AutoCAD’s available materials?
3. Can you delete an existing material?
PROJECT 2 SUBMISSION

TOOLS NEEDED TO COMPLETE THE PROJECT:

• Drawing file: museum.dwg

WARNING!
This is an extremely LARGE file! Use a Zip disk if available.

You will see displayed 3 cars. Create marble, granite and wood materials. Attach one material to each car. Present this rendering in the required PRESENTATION view (use the View command and set Presentation as the current view).

To submit your drawing, render your drawing with the Photo Real option.
Change the destination to File.
Push the More Options... button.
In the File Output Configuration box, change the File Type to TIFF. Under Colors, select 32 bit.
Push OK.

Push Render.

In the Rendering File box, name your rendering as follows:
Label the file with the first 6 letters of your last name _ 2
(For example, my uploaded files would look like this - - bender_2)

Save to a directory of your choice.

See the MSU CAD Technologies website, http://cad.msu.edu/ Tools section, for detailed instructions on uploading.

Upload this file by NOON on lecture day.
See the course outline for specific due dates.
MODULE R4

Importing and Exporting Materials
AN EXAMPLE:

TOOLS NEEDED TO COMPLETE THE MODULE:

- Drawing file: bookcase.dwg
INSTRUCTIONS TO COMPLETE THE MODULE:
The purpose of this assignment is to:
• Import and export materials to and from your drawing
• Understand the hierarchy of rendering materials

Importing & Exporting Materials

In addition to creating a material from scratch, you might want to import a predefined material from a materials library. It’s often easier to modify an existing material than to create a new one.

Predefined materials or images can be found in a material library. Besides the materials library files in AutoCAD, you can also use the AutoVision materials library (mli) files and 3-D studio materials library (mli) files in AutoCAD. Notice that these are not bitmap files - - like bmp, tga, etc. Those files need to be attached to one of the 4 materials - - standard, marble, granite, or wood. You cannot import or export these files in or out of a materials library.

Open the drawing: bookcase.dwg from the course CD Rom
Save as a name of your choice.
Current layer: 0

To import or export material:
From the View pull-down menu:
   Select Render
       Select Materials Library

In the Materials Library Dialog Box, the Materials List (on the left) contains materials in the drawing; the Library List (on the right) contains materials in the computer software’s library.

Highlight a material of your choice from the right of the screen (in the Library List)

Press the Preview button to see a rendering of the material before you import or export the material. You can preview with a sphere or a cube - your choice.

To add a material to the Materials List in the drawing:
   Highlight a material from the Library List (on the right)
   Press the Import button
   *the material will now appear in the drawing Materials List

To export a material from a drawing to the Library List of materials:
   Highlight a material from the Materials List (on the left)
   Press the Export button
   *the material will now appear in the software Library List, but it isn’t permanently a part of that library yet!
Under the Library List: 
Press the Save... button to save the materials in the current drawing to a named materials library (MLI) file that you can use with other drawings.
Press OK.

The computer realizes that changes have been made to its library list. The Library Modification dialog box will appear. You have 3 options:
• Save Changes
• Discard Changes
• Cancel Command

To save this library file (so you can bring these materials into another drawing file), push Save Changes. Give the library file a name and location. The .mli extension will be added automatically.

Materials Hierarchy

AutoCAD renders materials on objects according to a hierarchy - based on how the material is attached to the object. Here is the hierarchy:

1. Materials explicitly attached to an object
2. Materials attached by (ACI) AutoCAD color index
3. Materials attached by layer

Let’s imagine you assigned a material called ‘yellow paint’ to a layer called ‘walls’. On that same layer, you assigned the ACI ‘red’ to the wall fixtures and then you attached a cobalt blue to one of those fixtures.

What would the outcome be?

The one manipulated fixture would be blue - ignoring the ACI and the Layer assignment.
The remaining fixtures would be red - ignoring the Layer assignment.
The wall would be yellow.

An important note...

If you are including blocks with materials attached from another drawing, you must import materials from the original drawing into the list of materials in your current drawing. Otherwise, the block will insert without the attached material.

CHECKLIST:

1. Do you understand how to import and export a material?
2. Do you understand the materials hierarchy of CAD rendering?
MODULE R5

Orienting Materials
AN EXAMPLE:

TOOLS NEEDED TO COMPLETE THE MODULE:

- Drawing file: bookcase.dwg
- Image file: whiteash.tga
INSTRUCTIONS TO COMPLETE THE MODULE:
The purpose of this assignment is to:

- Associate standard and procedural materials with the 4 mapping procedures
- Comprehend the 4 types of mapping projections
- Learn how to manipulate bitmaps images

MAPPING

Let's look at where we are at this point. We have defined the following solid materials:

Standard: A solid material saturated with a single color.

On to this solid, we can attach as many as four separate bitmap images.

- Under the radio button Color/Pattern, we attach a texture bitmap
- Under the radio button Transparency, we attach an opacity map
- Under the radio button Reflection, we attach a reflection map
- Under the radio button Bump Map, we attach an embossing map

Since the solid standard material consists of a single color, no pattern orientation is necessary.

The texture, the opacity map, the reflection map and the bump map will, however, need both orientation and scale as they relate to the object.

Each procedure solid (i.e. wood, marble and granite) contains a changing pattern throughout. If you look at a piece of granite, a piece of marble, or a piece of wood, you will see this. Each surface is different and it varies within the pattern. For example, the pattern that appears on the surface of a marbled block is displayed differently on the outside surface than the pattern displayed 2” inside the marble. If you cut the marbled block in half, you’d see a different pattern at your cutting edge. This is referred to as a 3D solid pattern.

For these solids, both orientation and scale of the pattern will be necessary.

On each of these solids, we can attach two separate bitmap images:

- Under the radio button Reflection, we attach a reflection map
- Under the radio button Bump Map, we attach an embossing map

Mapping: The method used to position & orient the marble, granite, and wood procedure materials

- Mapping is the method used to position and orient the bitmap images.
- Mapping is the method used to scale the bitmap images.
- Mapping is the method used to process the bitmap effects.

The mapping procedure affects the projection of a 2D image onto the surface of a 3D object.

There are four mapping procedures called:

1. Texture maps The texture map appears, as if the bitmap were painted onto the object

   A texture map is the projection of an image (like a tile pattern) onto an object (like a table or chair). This procedure is only associated with the Standard material attribute called Color/Pattern.

2. Reflection maps Simulate a scene reflected on the surface of a shiny object

   A reflection map simulates the effect of the scene reflected on the surface of an object. This procedure is associated with all the materials and is located in the attribute Reflection.

   This may not be visible if the reflection setting is ZERO (i.e. it’s off)
3. Opacity maps  Specify areas of opacity and transparency

Opacity maps are projections of opaque and transparent areas onto objects creating the effect of a solid surface with holes or gaps.

- Pure white areas of the bitmap appear completely opaque.
- Pure black areas of the bitmap appear transparent.

This procedure is associated only with the Standard material attribute called Transparency.

4. Bump maps  Create an embossed or bas-relief effect

The brightness values of a bump map image are translated into apparent changes in the height of the surface of an object.

This procedure is associated with all the materials and is associated with the attribute Bump Map.

One or more of these maps may have been included when you defined a material and attached a bitmap map file.

You can attach a map to a material at any time using the Material modify procedure.

The 2D images (maps) can be in one of the following bitmap file formats:
- .bmp
- .tga
- .tiff
- .jpeg

For the bitmap effect to be seen, you must render using either:
- The Photo Real renderer
- The Photo Raytrace renderer

Open the drawing: bookcase.dwg from the course CD Rom
Save as a name of your choice.
Current layer: 0

To map (orient and scale) a bitmap to a Standard solid material:

1. SELECT AN OBJECT WITH A MATERIAL ATTACHED

Open the drawing called bookcase.dwg

The bookcase has a standard material with a white ash bitmap attached to the diffuse attribute (also known as color pattern). This looks like wood, but is only a bitmap image projected onto the 3D surface of the bookcase.

Under the View pull-down menu:
- Select Render
- Select Render

Rendering type: Photo Real
Destination: Viewport

Push the Render button
The object is rendered.

Note that the wood grain at the bottom is in the wrong direction.
Regen <-

Look at the position of the UCS. You are looking from the inside of the Lipton teahouse. The UCS is not what you might expect.

Let’s manipulate the left side panel first. You may need to zoom closer.

**Under the View pull-down menu:**
- Select Render
- Select Mapping

Select objects: **select the left side panel of the shelving unit**
Select objects: <-

*Pause here...the instructions for this drawing continue after you read about assigning mapping coordinates...*

## 2. ASSIGNING MAPPING COORDINATES

To position the map on the object:

Map coordinates are used to place and orient the map on the object. The mapping coordinates are UV coordinates. (The letters UV are used because these coordinates are independent of the XY coordinates used to define the geometry of the object).

The mapping coordinates you assign in the Mapping dialog box apply to the entire selection set and will remain with that selection set. When you move the geometry, the mapping coordinates and other mapping attributes (such as bitmap scaling), move with it.

**There are four Mapping projection types.** They are related to the geometry and how they will be affected by it.

### A. Planar projection

Planar projection maps texture onto the object with one-to-one correspondence, as if you were projecting the texture from a slide projector onto the scene. This does not distort the texture; it just scales the image to fit the object.

### B. Cylindrical projection

Cylindrical projection maps an image onto an object with a cylindrical shape; the horizontal edges are wrapped together but not the top or the bottom edges. The height of the texture is scaled along the cylinder’s axis.

### C. Spherical projection

Spherical projection wraps the texture both horizontally and vertically.

### D. Solid projection

Solid projection refers to more complex objects like wedges, octagons, and asymmetric solids where the projection plane will require an angle other than the plan view, the front view, or the side view.

These are mapped using the three mapping coordinates: U, V, W. This is similar to using the UCS command with the 3point option to locate the X, Y, Z geometry coordinates.
*These instructions are continuing from above...*

NOTE: Remember - you are about to manipulate the whiteash.tga bitmap on the rendered material, not the side of the panel itself.

The Mapping dialog box appears

Of the four projection types, the best options for the side panel are Solid or Planar

In the Projection dialog box:
Select the Planar radio button
Select the button Adjust Coordinates...

The Adjust Planar Coordinates dialog box appears
(see illustration below)

In the Parallel Plane area:

The radio buttons are used to define a bitmap plane. A bitmap plane is a surface or plane that the bitmap image will be projected perpendicular to.

Notice that each option begins with WCS - indicating that the orientation is in relation to the World Coordinate System for the geometry.

This means that for the:

- **WCS XY Plane** The image will be parallel to the plan view.
- **WCS XZ Plane** The image will be parallel to the front view.
- **WCS YZ Plane** The image will be parallel to the side view
- **Picked plane** This gives you the option of defining a plane by selecting 3 points: the lower-left of the plane, the lower-right of the plane, and the upper left of the plane. This plane can be at any angle.

The Pick Points < button provides the same options as the Picked Plane radio button.

Select the **WSC XY Plane radio button**

### 3. Locating a bitmap in relation to an object

Having located the bitmap plane in relation to the object, you now define the location of the bitmap on the bitmap plane.

**To locate the point of origin:**
The default point of origin is 0,0 - which is the lower left corner of the object.

Use the sliders in the Center Position area to move the bitmap in the X and Y directions on the bitmap plane. Notice that the changes appear below in both the X Offset text area and the Y Offset text area. You can locate the point of origin visually using the Center Position box, or you can enter numerical values in the Offsets and Rotations text boxes.

By default, the projection rectangle represents the extents of an object or selection set of objects. The diagram shows the bitmap as another rectangle: its top left edges in white, and its right and bottom edges as drawn in magenta. When you first see this dialog box, the two squares are the same size. As this implies, the default mapping scale is 1:1.
To rotate the bitmap on the object:

The Offsets and Rotations area also includes a Rotation text box with an associated slider. You can enter a numerical value for a desired rotation or you can use the slider to rotate the bitmap on the bitmap plane. The Preview appears in the Center Position area. You will see that the bitmap rotates about the center point of the bitmap plane.

An important note:

If you push the Adjust Bitmap button, the Adjust Object Bitmap Placement dialog box will appear. This dialog box is the same as the one used to specify the bitmap placement when you define a material.

Because you are now defining the location, rotation, & scale of that bitmap in relation to a specific object, the bitmap adjustment you make with this dialog box is combined with the bitmap adjustments specified for the material itself.

Keep in mind that the bitmap image was defined earlier. Any changes you make in this dialog box, will be IN ADDITION to the prior settings. So if you set the scale to 2 and now adjust the scale to 3, the ultimate scale will be 6 (2x3=6). The offset values are also altered in the same way - new values will added on to existing values.

The bitmap offset changes the origin of the bitmap relative to the origin of the UV projection coordinates set when the material was defined.

Offset values range from -1.0 to 1.0 in either dimension (U or V). You adjust the offset by using the two sliders to the right and below the diagram (enclosed by the outer box, labeled Offset) or by entering a value in the Offset U and Offset V boxes. The bitmap rectangle moves to reflect the new offset values.

To scale the bitmap to the object:

When you project a bitmap onto an object, the default setting is for the software to fit the bitmap image to the object with a ratio of 1:1. The image will stretch or contract to fit the object on which you attach it.

For example, if the U scale for the material is 2, and the number 3 is entered in this dialog box, the rendering is scaled 6:1 in the U direction.

4. TILING & CROPPING A BITMAP

You can adjust this ‘image to object’ ratio using one of the radio buttons: DEFAULT, TILE, or CROP.

DEFAULT

When the DEFAULT radio button is selected, the image is repeated based on the settings for the ‘material’ as a whole.

(see DEFINING MATERIALS - Adjust bitmap - tiling)

TILE

When the TILE radio button is selected, the bitmap is tiled or arrayed across the object or surface.

If the bitmap rectangle appears outside the projection rectangle, the bitmap is still applied to the object when you render it. (During tiling, the offset acts as a displacement, not as an absolute position).
To create a tiled effect:
From the View pull-down menu, choose Render -> Mapping
Select the object to be mapped

From the Mapping dialog box:
Select the Adjust Coordinates... button

From the Adjust Planar Coordinates dialog box:
Select the Adjust Bitmap... button

From the Adjust Object Bitmap Placement dialog box:
Select the Tile radio button

CROP
When the CROP radio button is selected, the bitmap is not tiled. The image is displayed once on the image. If the image is less than the size of the object, the 'material' color appears as a border around the image.

The bitmap is rendered only where you place it, as indicated by the diagram. So if the diagram shows the bitmap outside the projection rectangle, the bitmap does not appear in a rendering. (During cropping, the offset acts as an absolute position).

The upper-left corner pixel of a bitmap defines the bitmap key color. This color behaves as if it were transparent when you render in cropped mode; all pixels that have the same color as the upper-left pixel are rendered with the underlying color of the object material.

With cropped projection, you can place the image in a single location on an object, like a cropped "decal" effect.

To create a cropped effect:
From the View pull-down menu, choose Render -> Mapping
Select the object to be mapped

From the Mapping dialog box:
Select the Adjust Coordinates... button

From the Adjust Planar Coordinates dialog box:
Select the Adjust Bitmap... button

From the Adjust Object Bitmap Placement dialog box:
Select the Crop radio button

The Maintain Aspect Ratio check box locks the U and V scaling dimensions together. When Maintain Aspect Ratio is turned on, moving one slider will also move the other; a value entered in the Scale U or Scale V box, changes the other.
The bitmap scale is the number of times the bitmap fits onto the object in the U or V direction. Adjust the bitmap scaling by using the two sliders to the left and above the diagram (enclosed by the inner box, labeled Scale) or by entering a value in the Scale U and Scale V text boxes. The dimensions of the bitmap rectangle change to reflect the new scaling.

If the scale of the bitmap is less than 1:1, the image will appear with a border around the defined material.

For example: If you want the image repeated 6 times wider and 9 times taller without regard to maintaining the Aspect Ratio, you enter 6 in the Scale: text box U and you enter 9 in the Scale: text box V.

Push OK to exit the Adjust Bitmap Placement dialog box
Push OK to exit the Adjust Planar Coordinates dialog box
Push OK to exit the Mapping dialog box and return to your drawing

CHECKLIST:

1. Do you understand the 4 types of mapping procedures?
2. Do you understand the 4 mapping projection types?
3. What is a bitmap plane?
4. Can you rotate a bitmap on an object?
5. Do you understand the reasoning behind scaling a bitmap on an object?
6. Can you tile and crop a bitmap?
PROJECT 3 SUBMISSION

TOOLS NEEDED TO COMPLETE THE PROJECT:

- Drawing file: bookcase.dwg
- Image file: whiteash.tga

Open bookcase.dwg
Thaw all layers.
Current layer: panel

Issue the rmat command and attach WOOD-WHITE ASH to all the panels.

Adjust the mapping so the wood grain is going horizontally (in the X direction) on the top and bottom pieces and vertically (in the Z direction) on the side and divider pieces.

The shelves do not need any mapping procedure.

To submit your drawing, render your drawing with the Photo Real option.
Change the destination to File.
Push the More Options... button.
In the File Output Configuration box, change the File Type to TIFF. Under Colors, select 32 bit.
Push OK.
Push Render.

In the Rendering File box, name your rendering as follows:
Label the file with the first 6 letters of your last name _ 3
(For example, my uploaded files would look like this - - bender_3)

Save to a directory of your choice.

See the MSU CAD Technologies website, http://cad.msu.edu/ Tools section, for detailed instructions on uploading.

Upload this file by NOON on lecture day.
See the course outline for specific due dates.
MODULE R6
Scanning and Inserting Materials
AN EXAMPLE:

TOOLS NEEDED TO COMPLETE THE MODULE:

- Drawing file: *a 3D drawing of your choice*
- A textile material
INSTRUCTIONS TO COMPLETE THE MODULE:
The purpose of this assignment is to:
• Select a textile or printed pattern for scanning
• Use scanning hardware to create image files
• Create a new material with the scanned image and orient that image on a solid object

Scanning
There are a number of scanners located on-campus in labs and off-campus at copy shops like Kinko’s or Commercial Blueprint. On-campus locations include: 309 Human Ecology, Computer Center and Kresge. Call for hours of operation.

To begin scanning:
Place your object in the scanner. If the object is large or three-dimensional, the cover of many scanners can be detached and removed. From the Start menu, select Programs and HP Deskscan II. Different scanners will have different, yet similar, software packages.

From the Type: selection, pick Millions of Colors. A common error is to select Sharp Millions of Colors which will pixilate your scanned image. This is NOT desirable.

Do not adjust the scale or size of the image. Push the preview button. The zoom button will allow you to get a closer view of your scanned object but will not crop the final image. After making final adjustments and alignments, push the Final button.

In the Saveas dialog box, give the file a name and location (i.e. your afs site on P:drive or floppy disk on A:drive). The default filetype is TIFF (Targa Image File Format). Push Save.

Inserting an Image as a Standard Material
After you have scanned and manipulated your image file, begin AutoCAD and open your desired file.

Create a new standard material.

1. From the View pull-down menu:
   choose Render > Materials . . .

2. In the MATERIALS dialog box:
   Find the Drop-down menu under the Button NEW . . .
   Highlight the material type ‘Standard’
   Click the button NEW . . .

3. In the NEW STANDARD MATERIAL dialog box:
   In the Material Name text box : Give the material a name of your choice

4. Do NOT manipulate ANY of the settings!

5. With the radio button by Color/Pattern, push the Find File... button in the lower right corner of the box.
6. In the Bitmap File box, find and select your scanned image file. Push Open.

7. With the Bitmap Blend set to 1.00, all you should see in your preview is the scanned image. As you lower the bitmap blend, you will see less of your scanned image and more of the color underneath (which is probably black). If you put the bitmap blend to 0, you will no longer see your scanned image. Leave the blend at 1.00. Push OK.

8. Attach this new material to the object of your choice.

9. Use the Mapping procedure as described in the previous module to tile, crop, offset, scale and orient your scanned image correctly onto the object.

To create more than one “look” for your scanned image, create more than one standard material, using different names. These can then be scaled and oriented differently.

Map the orientation of this new material so it is aligned in the desired direction. Remember that there is a scale option under mapping so you can adjust the size of the scanned image. **Hint: If you want a larger image, reduce the scale!**

**CHECKLIST:**

1. Are you familiar with the procedure for scanning?
2. Can you create a new standard material and attach your scanned image?
PROJECT 4 SUBMISSION

TOOLS NEEDED TO COMPLETE THE PROJECT:

- Drawing file: a 3D drawing of your choice
- A textile material

Open a 3D drawing of your choice. You may use any of the course drawings (or a part of a drawing).

Select a textile pattern, preferably one with a visible pattern. Scan it into a BMP or TIFF file with the HP Deskjet scanning software.

Issue the `rmat` command in AutoCAD and create a new Standard material. On the Color/Pattern, attach the scanned image. Blend at 1.00 (or lower if you wish to achieve a varied effect).

Adjust the mapping so the scanned image is scaled and oriented correctly. The goal is to achieve as accurate a representation on the computer-generated object as the textile pattern you have in your possession.

To submit your drawing, render your drawing with the Photo Real option.
Change the destination to File.
Push the More Options... button.
In the File Output Configuration box, change the File Type to TIFF. Under Colors, select 32 bit.
Push OK.
Push Render.

In the Rendering File box, name your rendering as follows:
`Label the file with the first 6 letters of your last name _ 4`
(For example, my uploaded files would look like this - - bender_4)

Save to a directory of your choice.

See the MSU CAD Technologies website, http://cad.msu.edu/ Tools section, for detailed instructions on uploading.

*Upload this file by NOON on lecture day.*
*See the course outline for specific due dates.*
MODULE R7
Creating Lights and Shadows
AN EXAMPLE:

TOOLS NEEDED FOR THE MODULE:

• Drawing file: light.dwg
INSTRUCTIONS FOR COMPLETING THE MODULE:
The purpose of this assignment is to:

- Understand the characteristics of light and the lighting process
- Understand how to add and modify the 3 types of lights in AutoCAD
- Explore the shadow options available for each type of light source

Using Lights in Rendering

LIGHT CHARACTERISTICS
After selecting a type of light and giving it a name, there are a few characteristics of lighting that the computer will request:

- Intensity
- Attenuation
- Shadows
- Color
- Position

Attenuation is the term used to describe how the intensity of the light will diminish with distance from the light source.

The Attenuation setting options are:

- None: Light intensity does not decrease with distance from the source
- Inverse linear: Light intensity decreases by 1/2 with each increased foot from the source
- Inverse square: Light intensity decreases by 1/2 the square of distance from the source

AutoCAD recognizes four types of light:

1. AMBIENT LIGHT
2. DISTANT LIGHT
3. POINT LIGHT
4. SPOTLIGHT

The light source will be represented in your drawing with an icon but it will not appear in your rendering as a light. To see a point light as a light bulb, you will need to put the light source inside a light bulb (a translucent object).

But you won’t be able to see the light in the rendering so why put it in a light bulb? Is this just for Point lights? Why create the lighting if you can’t see it in the rendering? Isn’t that the point of doing the lighting????

The lights are automatically placed on the Ashade layer and locked. To modify the location of the lights, you will need to use the appropriate menu and unlock the layer first.

AMBIENT LIGHT

Ambient light defines a constant illumination to every surface in a mode. What is a mode?
A mode comes from no particular source and has no direction. This is unreal lighting where the light is as intense, for example, on the floor of a room as it is on the ceiling.

Here’s the dictionary definition for ambient:

am-bi-ent \am-be-ent\ adj [L ambient-, ambiens, prp. of ambire to go around, fr. ambi- + ire to go - more at ISSUE]: surrounding on all sides: ENCOMPASSING

ambient n : an encompassing atmosphere: ENVIRONMENT

Use ambient light to provide fill light to surfaces not directly illuminated by directional light. You can set the intensity of ambient light or just turn it off. (Start by keeping ambient light low).
DISTANT LIGHT

- Distant light emits uniform parallel light rays in one direction only.
- A single distant light simulates the sun.
- Light rays extend infinitely on either side of the point you specify as the light source.
- The direction of a distant light in a drawing is more critical than its location.
- With a series of views, you can simulate the changes in light throughout a day.
- Distant lights are useful for lighting objects and/or for simulating sunlight by lighting a background uniformly.
- The intensity of distant light does not diminish over distance (i.e. it has no attenuation).
- To define the distant light location, you need to define the longitude, latitude, date, and time of day.

POINT LIGHT

- A point light radiates light in all directions from its location.
- A point light is useful for simulating light from a light bulb.
- The intensity of point light diminishes over distance according to its rate of attenuation.

SPOTLIGHT

- A spotlight emits a directional cone of light. It simulates a spotlight.
- You can specify both the direction of the light and the size of the cone.
- The intensity of spotlights diminishes over distance.
- Spotlights have a hotspot and a falloff angle that together specify how light diminishes along the edge of the cone.
- When light from a spotlight falls on a surface, the area of maximum illumination is surrounded by an area of lesser intensity.
  - The hotspot cone angle defines the brightest part of the light.
  - The falloff angle defines the full cone of light.
- The greater the difference between the hot spot and the fall off angles - the softer the edge of the light.

Adding Lights

You can add any number of lights to a drawing.
You can set the color, location, and direction of each light you create.

Open the drawing file: light.dwg
Save as a name of your choice.

After creating each type of light, you can restore the view called View1 and use the render command to see the results.

SPOTLIGHT
Create and locate a new SPOTLIGHT inside the recessed cans above the circular counter.

Current layer: Ashade (unlock it first!)
Freeze all layers except 0, architecture, ashade & recessed_cans.

OSNAP: none

3D Viewpoint: Plan

Zoom closer to the recessed cans.
To add a new light:
From the View pull-down menu:
Select Render
Select Light

*The keyboard command is LIGHT.

In the Lights dialog box:
In the Ambient Light area, set the intensity to 0.70

NOTE: The 3 types of lights all have their own independent dialog box, which have some similar features.

You have the option to adjust the color of the ambient light in this box. Adjusting the color of each light is done in the independent light dialog boxes. For now, leave all of the color settings at 1.00.

Some lights are already provided in this drawing. They are listed in the Lights: area. Do not delete them.

The North Location... button will specify the intended direction of north. By default, the software accepts the World Coordinate System (WCS) as the measuring system and puts north as the positive Y direction. You can change this option to have north use an existing UCS system (in case you've created one previously in the drawing). Nine times out of 10 - you won't ever change this option.

Select a Spotlight from the drop down menu by the New... button
When done, push the New... button

To give this new light a name, place your cursor in the Light Name: box and type in a new name. This name must be unique and have no more than eight characters.

Use the Intensity slider bar to set a light intensity appropriate to the type of light and conditions you are trying to stimulate. First, use the defaults and then adjust the lights until you achieve the effect you want.

A value of 0.0 turns a light off - keep your setting very low.

In the New Spotlight dialog box, adjust the following settings:

- Attenuation: Inverse Square
- Intensity: 13000
- Hotspot: 12
- Falloff: 35
- Shadows: Do NOT check box
In the Position area:
Push the button Modify

(By default, AutoCAD will place the light in the center of the current viewport)

Transfer to the command line.

Enter light target <current>: with **no osnap**, pick the
center of one of the recessed cans
Enter light location <current>: cen
of pick the center of the same recessed can

After making your selections, you are returned to the New Spotlight dialog box.

In the Position area:
Push the button Show...

The Show Light Position dialog box will appear. Look at the X and Y coordinates - they should be very similar. Now look at the Z coordinates. If you used the center osnap correctly, the Z coordinate of the Location should be higher (like 6’8” higher) than the Z coordinate of the Target (which should be 0’).

Push OK.
You are returned once again to the New Spotlight dialog box.
Push OK to exit this dialog box.
You are returned to the Lights dialog box.
Push OK to complete the creation of your new Spotlight.

*Create one spotlight to fit inside each of the remaining recessed cans.* You will need to unlock the ASHADE layer again.

Zoom extents.
Thaw layers: counter & countertop
3D Viewpoint: SE Isometric

Render this view to see the effect of your spotlights.

**POINT LIGHT**

Create and locate a new **POINT LIGHT** inside the pendant globes near the west wall (front entry of the site).

Current layer: Ashade (**unlock it first**)!
Freeze all layers except 0, architecture, ashae & pendants.

OSNAP: **none**

3D Viewpoint: **Plan**

Zoom closer to the pendants.

To add a new light:
From the View pull-down menu:
Select Render
Select Light

In the Lights dialog box:
In the Ambient Light area, leave the intensity at **0.70**
Leave all of the color settings at **1.00**.
Select a Point Light from the drop down menu by the New... button
When done, push the New... button

To give this new light a name, place your cursor in the Light Name: box and type in a new name. This name must be unique and have no more than eight characters.

Use the Intensity slider bar to set a light intensity appropriate to the type of light and conditions you are trying to stimulate. First, use the defaults and then adjust the lights until you achieve the effect you want.

A value of 0.0 turns a light off - - keep your setting very low.

In the New Point Light dialog box, adjust the following settings:

Intensity: 15
Attenuation: Inverse Linear
Shadows: Do NOT check box

In the Position area:
Push the button Modify

(By default, AutoCAD will place the light in the center of the current viewport)

Transfer to the command line.

Enter light location <current>: with the CENTER osnap, pick on the edge of one of the pendant globes

After making your selection, you are returned to the New Point Light dialog box.

In the Position area:
Push the button Show...

The Show Light Position dialog box will appear. Notice that a Point Light does NOT have a target - the light is directed directly down. Now look at the Z coordinate. If you used the center osnap correctly, the Z coordinate of the Location should be approximately 7'0".

Push OK.
You are returned once again to the New Point Light dialog box.
Push OK to exit this dialog box.
You are returned to the Lights dialog box.
Push OK to complete the creation of your new Point Light.

Create one point light to fit inside each of the remaining pendant globes. You will need to unlock the ASHADE layer again.

Zoom extents.
Thaw layers: i-wall-full-w, west-glass-blocks & west-glass

Restore the view called VIEW2.

Render this perspective to see the effect of your point lights.
DISTANT LIGHT
Create and locate a DISTANT LIGHT outside the west wall (front entry).

Current layer: Ashade (*unlock it first!*)
Freeze all layers except 0, architecture, ashade & i-wall-full-w.
OSNAP: *none*

3D Viewpoint: *Plan*

Zoom, scale .5x. (This will allow you to select the direction of the light from OUTSIDE the building).

To add a new light:
From the View pull-down menu:
Select Render
Select Light

In the Lights dialog box:
In the Ambient Light area, leave the intensity at **0.70**
Leave all of the color settings at **1.00**.

Select the Distant Light option from the drop down menu by the New... button
When done, push the New... button

To give this new light a name, place your cursor in the Light Name: box and type in a new name. This name must be unique and have no more than eight characters.

Use the Intensity slider bar to set a light intensity appropriate to the type of light and conditions you are trying to stimulate. First, use the defaults and then adjust the lights until you achieve the effect you want.

**A value of 0.0 turns a light off - - keep your setting very low.**

In the New Distant Light dialog box, adjust the following settings:
- **Intensity:** .40
- **Shadows:** *Do NOT check box*

Push the Sun Angle Calculator... button

The **Azimuth** is the distant light’s position based on the coordinates of its determined site.

The **Altitude** also uses the same site-based coordinates for its calculations.
In the Sun Angle Calculator dialog box:

- **Date:** enter today's date
- **Clock Time:** enter the current time
- Select the time zone PST (Pacific Standard Time)

Select Daylight Savings time (if applicable)

Make no changes to the Latitude and Longitude at this time

Push the Geographic Location... button

In the Geographic Location dialog box:

- A listing of continents is available from the pull-down menu above the map section. A newly selected continent will display associative cities for your selection. Leave the continent as **North America**.

Use the scroll bar under City: to locate and highlight **Seattle, WA**

The Latitude and Longitude in the lower left corner of the dialog box will adjust accordingly.

Push OK
You are returned to the Sun Angle Calculator dialog box.
Push OK to exit this dialog box.
You are returned to the New Distant Light dialog box.

Notice the changes to the Azimuth, Altitude and Light Source Vectors. These were adjusted automatically when you selected Seattle, WA as the location for the distant light.

The location of the light itself has to be adjusted so the light can flow through the glass panes along the west wall.
Push the Modify button.

Transfer to the command line.

(By default, AutoCAD will place the light in the center of the current viewport)

Enter light direction TO <current>: with NO active osnap, pick a point on the floor somewhere inside the room, close to the west wall
Enter light direction FROM <current>: with No active osnap, pick a point outside the building

After making your selection, you are returned to the New Distant Light dialog box.

Push OK.
You are returned to the Lights Dialog box.

Push OK to complete the creation of your new Distant Light.
Zoom extents.

Thaw layers: architecture, ashade, floor_tile, i-wall-full-w, west-glass-blocks & west-glass

3D Viewpoint: NW Isometric

Zoom closer to the room.

Render this view to see the effect of your distant light.

Using Shadows in Rendering

Remember that AutoCAD uses three renderers:

1. Render
2. Photorealistic Render
3. Photo Raytrace

TIME is in direct proportion to the renderer -
Render is quick
Photoreal is slow
Photo Raytrace means go get lunch and come back later

Note: Only the photo real and photo raytrace renderers can generate shadows!

Three shadow types can be generated:

1. Volumetric Shadows
2. Shadow Maps
3. Raytraced Shadows

Volumetric Shadows

• The Volumetric shadow generator computes the volume of space cast by the shadow of an object and generates a shadow based on this volume.
• Volumetric shadows are hard edged, but their outlines are approximate.
• This technique is the quickest for simple drawings.

To generate volumetric shadows:

From the View pull-down menu:
Select Render
Select Light

If the lights you previously created are available, select one (doesn’t matter which one) and push the button Modify...

If you have not created any lights yet, do so now. Then come back to the Lights dialog box and push the button Modify...

In the dialog box for any light:
Check Shadow On
Push the Shadow Options... button

In the Shadow Options dialog box:
Check Shadow Volumes/Ray Traced Shadows
Push OK

You are returned to the appropriate Modify Light dialog box
Push OK when done
You are then returned to the Lights dialog box
Push OK when done

You have now set up your light(s) to cast volumetric shadows!

To see the volumetric shadows displayed:
Restore a view of your choice (such as VIEW1, VIEW2 or your own view)

From the View pull-down menu:
Select Render

In the Render dialog box:
Change the Rendering Type: to Photo Real or Photo Raytrace
Check the box next to Shadows in the Rendering Options area
Destination: Viewport
Push Render

Shadow Maps

• The shadow map generator forms an outline for the shadows of each light.
• You set the size of the shadow map file it will generate. The larger the shadow map - the greater its accuracy.
• Shadow maps are the only way to generate soft edged shadows which you can control.
• Shadow maps do not show the color cast by transparent or translucent objects.
• This is the most time-consuming technique.

To generate a shadow map:
From the View pull-down menu:
Select Render
Select Light
If the lights you previously created are available, select one (doesn’t matter which one) and push the button Modify...
If you have not created any lights yet, do so now. Then come back to the Lights dialog box and push the button Modify...

In the dialog box for any light:
Select Shadow On
Choose Shadow Options

In the Shadow Options dialog box:
Clear Shadow Volumes/Ray Traced Shadows
Adjust the Shadow Map Size if necessary
Push OK

You are returned to the appropriate Modify Light dialog box
Push OK when done

You are then returned to the Lights dialog box
Push OK when done

You have now set up your light(s) for shadow maps!
To see a shadow map displayed:
Restore a view of your choice (such as VIEW1, VIEW2 or your own view)

From the View pull-down menu:
   Select Render
   Select Render

In the Render dialog box:
   Change the Rendering Type: to Photo Real or Photo Raytrace
   Check the box next to Shadows in the Rendering Options area
   Destination: Viewport
   Push Render

**Ray Traced Shadows**

- Raytraced shadows have hard edges and accurate outlines.
- They transmit color from transparent and translucent objects. It can even do calculations for features like bending light through glass. This subtly changes the color, direction and speed of the light.
- Raytraced shadows are generated for each light that has the shadow option turned on, except lights set to generate mapped shadows.
- This is a somewhat time-consuming technique.
- Raytraced shadows will generate only when the Photo Raytrace option is selected in the Render command and a check mark is placed before the Shadow option.

The likelihood of using Ray Traced Shadows is slim. The larger the shadow map - the more accurate your shadow, but the longer your regeneration time.

Explore the options available with Ray Traced Shadows, but no formal exercise is required.

**CHECKLIST:**

1. Do you understand the difference in the 4 types of AutoCAD lights?
2. Can you adjust the ambient light intensity?
3. Can you create a spotlight?
4. Can you create a point light?
5. Can you create and place distant light relative to a geographic location?
6. Can you generate and display a volumetric shadow?
7. Can you generate and display a shadow map?
8. Do you understand the usage of ray traced shadows?
MODULE R8

Designing Scenes
AN EXAMPLE:

TOOLS NEEDED TO COMPLETE THE MODULE:

- Drawing file: scene.dwg
INSTRUCTIONS NEEDED TO COMPLETE THE MODULE:

The purpose of this assignment is to:

- Understand generation of new scenes
- Modify or delete an existing scene
- Learn the various ways to save a rendered scene

Using Scenes in Rendering

A scene is a combination of a named view PLUS the lights and the shadows. Scenes save time because you don’t have to set up your viewpoint and lights from scratch every time you want to render.

*Open the drawing scene.dwg.*

Current layer: 0

Create a perspective view using the `dview` command. Pretend you are standing in the FRONT (camera) of the facility and looking toward the BACK (target) of the room. (See the example perspective on the previous page).

There are only a few lights created for this area, so you may choose to add supplemental lights if you wish.

Save this view with a name of your choice (use the `view` command).

To set up a new scene:

From the View pull-down menu:
- Select Render
- Select Scene

In the Scene dialog box:
- Highlight *NONE*
- Push the New... button

In the New Scene dialog box:
- Enter a name for the scene (i.e. MYSCENE)
  (The name must be unique and have no more than eight characters).
- Select a named Dview (if available) or *CURRENT* from the list of views
- Highlight one or more available named lights (using the shift key) or *ALL* from the list of lights
- Press the OK button

You are returned to the Scenes dialog box. The scene you just created and named will appear in the list of available scenes.

Press the New button again to create another scene
OR
Press the OK button to exit the Scene dialog box
To render a scene:
From the View pull-down menu:
Select Render
Select Render

In the render dialog box:
Under Scene to Render:
Highlight one of the scenes listed (i.e. MY_SCENE)
Select a destination and make any other changes necessary
Push Render

To delete or modify a scene:
From the View pull-down menu:
Select Render
Select Scene

In the scene dialog box:
Highlight one of the scenes listed (i.e. MYSCENE)

To delete the scene:
Push the Delete button
Confirm the deletion by pressing OK in the pop-up window

To modify the scene:
Press the Modify... button

In the Modify Scene dialog box:
To rename a scene:
Enter a new scene name
To change the scene viewpoint:
Select another view
To add another light to this scene:
Select a light that is not highlighted
To remove a light from the scene:
Select a highlighted light
(Removing a light from the scene does not delete the light from the drawing)
Press the OK button

You are returned to the Scenes dialog box
Press the OK button to exit the Scene dialog box
CHECKLIST:

1. Do you understand what a scene is and why it is used with CAD rendering?
2. Can you create a new scene, combining an existing view with existing lights?
3. Can you delete a scene?
4. Can you modify an existing scene?
PROJECT 5 SUBMISSION

TOOLS NEEDED TO COMPLETE THE PROJECT:

- Drawing file: light.dwg

Open light.dwg. It is best if you use the light drawing file in which you practiced making lights.

Create lights in the back area of this tea house. Create a minimum of:

1 distant light  
4 spotlights  
2 pendant lights

Review of moving and copying in 3dimensional space:
You may copy some of the existing light fixtures from other parts of the Lipton teahouse drawing. Make sure that these are still at a Z height greater than 0 (the floor) by using the LIST command. After picking on the light fixture, the text window will appear and list the X, Y, and Z coordinates. If the Z height is not high enough, use the move command. With a base point of 0,0,0 - type in a second point of displacement as 0,0,?. This last coordinate is however much higher you’d like the light fixture.

Half of the lights should be created for a "daytime" effect and the other half for an "evening" effect. You may adjust the color of the light but do so sparingly.

Create 2 scenes - daytime and evening - using different light sources and shadows.

Freeze layers: COUNTER, COUNTER_WEDGES, & COUNTER_TOP. Restore the View called scan5_perspective before rendering.

To submit your drawing, render your drawing with the Photo Real option. Change the destination to File. Push the More Options... button. In the File Output Configuration box, change the File Type to TIFF. Under Colors, select 32 bit.
Push OK.
Push Render.

In the Rendering File box, name your rendering as follows:
_LABEL the file with the first 6 letters of your last name_ 5
(For example, my uploaded files would look like this - - bender_5)

Save to a directory of your choice.

See the MSU CAD Technologies website, http://cad.msu.edu/ Tools section, for detailed instructions on uploading.

Upload this file by NOON on lecture day.
See the course outline for specific due dates.
MODULE R9

Adobe Photoshop
AN EXAMPLE:

TOOLS NEEDED TO COMPLETE THE MODULE:

- Drawing file: *photoshop.dwg*
- Image file: *dog.tif*
INSTRUCTIONS NEEDED TO COMPLETE THE MODULE:

The purpose of this assignment is to:

- Use Adobe Photoshop to manipulate scanned and rendered images
- Learn how to make your drawing more believable by adding images

Adobe Photoshop

Adobe Photoshop 5.0 can be accessed in all MSU Microlabs. Start, Programs, Development Apps, Adobe, Adobe Photoshop, Photoshop 5

Most AutoCAD users encounter problems when they ask AutoCAD to do things it cannot do. Making a computer-generated rendering more believable involves graphic imaging software, such as Adobe Photoshop. For design communication, Photoshop is a useful tool when working with colleagues and clients who are having difficulty visualizing your design. Adobe Photoshop is image editing software, used for graphics presentations in print media, desktop publishing and on the Internet.

To begin, you need to either scan a photo, get a digital photo or create a rendered image from another piece of software (e.g. AutoCAD). Just remember - the picture is only as good as the source! If using a scanner, scan with as high resolution as you can. A digital camera is better than a scanned photo because there's one less step putting the image into electronic format. When creating the initial electronic image file, get it as large as possible. Starting with a bigger picture and then reducing it to a smaller size is a smart idea. Changing the image's size from smaller to bigger will make the software dither the pixels. This is bad!

Raster vs. Vector

AutoCAD is vector software that produces line drawings. These lines are continuous elements that are calculated mathematically. Photoshop is raster software that produces image files. This is a type of "paint" package. Photoshop generates a line as a graphic - a series of pixels. Pixels are dots of color. The word comes from the combination of picture and element. Together, these dots form a matrix of little squares. These dots are not continuous so a diagonal line created in Photoshop appears jagged and rough. An average monitor has a resolution of 72 pixels to an inch, or 72 ppi. Each individual pixel has specific color information. A pixel's resolution, or depth, determines the number of colors available to that pixel. For example, a pixel with 8-bit depth has $2^8$ or 256 levels or colors. The higher the "bit" or depth, the more color possibilities but also the larger the computer file.

Paint packages are of benefit for photograph enhancement as the blurring of pixels is more representative of real photography. Paint packages also do not recognize three dimensional space, as compared to a line package such as AutoCAD. Lastly - because raster images are comprised of many little pixels, they require far more memory to store and manipulate than vector images.

The most successful presentations combine raster images and vector lines.

Dithering

Dithering is when the computer tries to fill in between two pixels of different colors. This is known as pixelation. For example, suppose you have a photo with a pixel of blue on the left and a pixel of yellow on the right. When you increase the image size, the computer will try to blend the blue pixel and the yellow pixel into the blank pixel in between - into a new green pixel. In Photoshop, the canvas size affects the photoshop environment and the image size affects the photo.

Layers

Layers in Photoshop are similar to layers in AutoCAD, with a few exceptions. The current layer is highlighted in blue. The layer list should always be visible when working on your pictures. There is a drawing order to the layers. If you want something to appear on top of something else, it has to be listed above it in the layer list. So the layer list is not alphabetical, but listed in viewing order. The "eye" icon means the layer is on or off. Always make a duplicate layer so your original image doesn't get altered.

Color Modes

Color management is important in Photoshop. Just because the image looks good on your monitor doesn't mean it'll look good on the web or in hard copy format. For example, if you're presenting the rendering on the monitor, make it a little lighter.
Color information in Photoshop can be in 4 modes:

1. **Indexed Color** - 256 colors only; good for GIF files and web design due to small file sizes
2. **RGB Color** - additive color system; 256 colors x 3 channels (Red Green Blue); color dependent on the monitor and scanner; file size 3 times larger than Indexed color; not good for printing as the "additive" colors of Red Green Blue will overlap each other in hard copy form
3. **CMYK Color** - subtractive color system of Cyan Magenta Yellow & Black; 256 colors x 4 channels for over 4 billion available colors; final colors dependent on the printer; good for desktop publishing and hard copy output
4. **Lab Color** - colors defined mathematically; device independent so colors will be the "same" in different formats such as monitor and hard copy output

Use the color mode most suitable for your image type and final use. We'll use CMYK for this exercise.

**Visual Tricks**

So what visual tricks can you use to enhance your renderings?

1. **Combine raster and vector together** by merging a photo with a line drawing. You can use software such as Adobe Illustrator to generate a presentation with crisp lines and lettering but also with images and photos. AutoCAD can also serve this purpose. After completing a 2D line drawing or a 3D model, make a rendering to a file. Open that file in Photoshop, embellish it and bring it back into AutoCAD as an image. You can then set up a paper space template with orthogonal views of your drawing, a titleblock and the rendered image — *all in one sheet*.

2. **Use the room's windows** to provide a visual reference for the rendering (when applicable). What you see outside a window in a photo tells you a lot about that photo. Is this environment on the 1st floor or the 5th? In Boston or San Francisco? In the city or the country? Once the AutoCAD drawing has been rendered, combine it with another photo by placing a second file "inside" the window of the first file.

3. **A person** can make any drawing look real. If the person is believable, then the rendering is believable. A person or two also gives a drawing a sense of scale, proportion and character.

4. **Include something of interest** - maybe humorous or unexpected. This trick is to be used conservatively. A palm tree inside a room, a cobweb in a window, or a photo of the President may be acceptable with some clients but not others. Know your audience before embellishing a drawing with unrealistic images.

**Saving a Rendering**

Visual tricks are done *after* you've rendered your AutoCAD drawing. Enhancing an image file is a one-way process. You cannot go back into AutoCAD to make changes once the file is in Photoshop. Always save the original rendering file. You never know when you'll need to return to it! Also, save the Photoshop file (.psd) with it's layering system.
To bring the modified image back into AutoCAD or to the web, you save a copy. This compresses all the Photoshop layers together into one layer. So it’s not a reversible process!

There are many types of image files. The 3 most popular are:

1. **TIFF** - highest quality but biggest byte size
2. **JPEG** - medium quality and retains the most amount of information without a big byte size
3. **GIF** - lowest quality and smallest byte size

**Tools**

The **Tools** toolbar can be accessed from Show Tools under the Windows pull-down menu. These tools allow you to view, edit and modify objects.

While picking and holding on the image with a tool option, pressing shift, alt or ctrl will give you even more options.

It is suggested that the Options palette be accessible during use of any tool. Do this by selecting Show Options from the Window pull-down menu or by double-clicking on any tool icon. When you select a different tool, its options will be displayed in the Options palette.

Many of these tools also use the Brushes/Color/Swatches palette. This palette can also be accessed from the Windows pull-down menu, Show Brushes.

**SELECTION TOOLS**

- Marquee
- Hand
- Lasso
- Move
- Rubber Stamp

**Marquee Tools**

*To select a rectangular area of the image*

The marquee tool in the upper left corner is a tool button that has 5 options. If you pick and hold on the icon, you will get a flyout menu with all 5 marquee options. Many tools have this same feature.

From left to right, they include:

- Rectangular marquee tool
- Elliptical marquee tool
- Single row marquee tool
- Single column marquee tool
- Crop tool

The 4 marquee options allow you to select an area by picking and dragging a window around the area. The rectangular and elliptical marquee tools allow you to select an area of any size, that you can manipulate with grip points on the selection window. The single row and column marquee tools define a one-pixel wide selection, either horizontal or vertical.

Picking the area with the Ctrl key pressed down will allow you to pick up the selected area and move it around on the image. Picking subsequent areas with the Alt key pressed down will delete areas from the original selection.

The crop tool allows you to define a rectangular area. When you press the enter key, anything NOT inside the selected area is cropped, or deleted out of the picture. To cancel a crop selection, use the ESC key.
Hand Tool  
*To move an image within the window*
- To shift the image on the screen, use the hand tool. Pick, hold and drag to see another portion of your image.
- Use of the hand tool is layer dependent. It will only shift the image or part of the image on the current layer.
- To use the hand tool while another tool is selected, hold down the spacebar as you drag in the image.
- The hand tool is equivalent to the PAN command in AutoCAD.

Lasso Tools  
*To select an area of the image in various shapes*  
(See description below in Tutorial Instructions)

Move Tool  
*To shift the location of a selected image*  
(See description below in Tutorial Instructions)

Rubber Stamp Tools  
*To make copies of a selected area of the image*
- To create a color sample, position the rubber stamp tool over the part of the image you want to duplicate. Hold down the ALT key and pick on the area of color.
- To duplicate the color sample, pick and hold the left mouse button. The cursor will pick up the colors and textures of the color sample and repeat them wherever you move the cursor.
- The crosshairs mark the original sampling point.

PAINTING TOOLS
- Airbrush
- Line & Pencil
- Paintbrush
- Paintbucket
- Pen
- Eraser
- Eyedropper and Color Sampler
- Focus and Smudge
- Gradient
- History Brush
- Magic Wand
- Measure
- Toning
- Type
- Zoom

**Color selection** - The color of the foreground paint is selected from the Color palette. From the Window pull-down menu, select Show Color. Color can also be selected from the foreground color swatch in the tools box. Color can be selected visually or by entering the Hue, Light, Saturation and Brightness values or the Red, Green and Blue values on the computer.

**Brush selection** - Brush size is selected from the Brushes palette. From the Window pull-down menu, select Show Brushes. Brushes determine how fine a point your painting tool will have or how wide a stroke you’ll paint. Brushes apply to the pencil just as easily as the paintbrush.

**Straight lines** - To draw a straight line of color, pick a starting point, hold the SHIFT key and pick an ending point. This feature works with all painting tools.

**Angled lines** - To draw in 45 degree increments, hold down the SHIFT key as you drag the line cursor.
Paths - Painting tools are related to paths. Paths are any line or shape you draw with a painting tool. These help you draw precise borders. Once you create path, you can send it to the Path palette, fill it with color or convert it to a selection border. So a drawing tool can also be used as a selection tool.

Airbrush Tool

To simulate spray painting
- Pick, hold and drag the cursor to airbrush a drawing.
- If you pick and hold without moving the cursor, color will build up.
- Options: The airbrush pressure controls the gradual tones of color.

Line and Pencil Tools

To draw straight-edged and freehand lines
- To access either icon, click on the icon and hold. A flyout menu will appear. Pick the line or pencil tool.
- Lines are not continuous. Pick and hold while moving the cursor. When you let go, the line will form.
- For a freehand line, pick, hold and drag the cursor.
- The pencil tool only produces hard-edged lines.
- To make the line edges appear smoother, check the Anti-Aliasing box in the Line Options palette before beginning your line.
- Line width is determined in pixels. Type in the weight in the Line Options palette.
- Arrowheads can form at the starting and/or ending points of your lines.
- The Auto Erase option of the pencil tool uses the background color in place of the foreground color. This is equivalent to erasing with a fine tip eraser. Note: The background color is usually white.

Paintbrush Tool

To paint with the foreground color
- Control the size of the brush from the Brushes palette.
- Pick, hold and drag the paintbrush around your photo.
- The paintbrush tool can produce both hard-edged and soft strokes of color. This depends on the size of brush you select.
- To draw a straight line of color, pick a starting point, hold the SHIFT key and pick an ending point.
- A watercolor effect can be achieved by checking Wet Edges from the Paintbrush Options palette.

Paint Bucket Tool

To fill an area with a solid color
(See description below in Tutorial Instructions)

Pen Tools

To draw straight lines and flowing curves
- Pen lines are continuous. Keep clicking after each endpoint to get a subsequent line segment.
- Pick, hold and drag to create arcs and curved lines.
- When using pen tools, you need a high level of control and accuracy.

Eraser Tool

To correct mistakes or delete an image
- Since the photo is really one layer, when you use the eraser, the “blank” area will return to the background color (usually white).
- The size of the eraser is controlled with the brush sizes. Access these sizes from the Window pull-down menu - Show Brushes.
- Make sure you are on the correct layer before erasing a part of the image.
- For more precision, use the pencil tool with the Auto Erase option turned on.

Eyedropper & Color Sampler Tools

To select new foreground/background colors from existing image colors
(See description below in Tutorial Instructions)

Focus and Smudge Tools

To blur or sharpen an image selection
- The smudge tool simulates the actions of dragging a finger through wet paint. The tool picks up color where the stroke begins and pushes it in the direction you drag.
- The focus tools consist of the blur tool and the sharpen tool. The blur tool softens hard edges or areas in an image to reduce detail. The sharpen tool focuses soft edges to increase clarity or focus.
- The smudge, focus, and toning tools cannot be used with Bitmap or Indexed color mode images.
Gradient Tools  
To create fills that transition between two colors
- The gradient tools create a gradual blend between multiple colors.
- You can choose from existing gradient fills or create your own.
- You draw a gradient by dragging in the image from a starting point (where the mouse is pressed) to an ending point (where the mouse is released). The starting and ending points affect the gradient appearance according to the gradient tool used.

History Brush Tool  
To revert a portion of the image to a previous state
- Photoshop keeps track of your mouse movements and menu selections. You can reverse these steps and return the image or part of the image to its original state.
- This tool is useful if you find a mistake and only wish to undo certain actions - without reverting the entire image back to its original state.
- The F12 key reverts the file back to the last saved image.
- This is similar to the OOPS command in AutoCAD.

Magic Wand Tool  
To select areas based on color similarity
- Use this tool by selecting an area of color you’d like to copy or remove. All similar color pixels will be selected throughout the image file.
- This tool works best when there is a high contrast between color pixels.
- Set the “tolerance” in the Magic Wand Options box to determine the range of selection. A higher tolerance will select a larger area of color. Similarly, after selecting an area of color, use the “grow” option under the Select pull-down menu. The software will increase the area of selection.
- To have the software pick ALL similar areas of color, use the “similar” option under the Select pull-down menu.
- Pushing the shift key will add to the current magic wand selection; pushing the alt key will subtract from the current magic wand selection.

Measure Tool  
To determine distances and angles
- Pick a starting point, drag the crosshairs and let go for an ending point. A non-printing line will appear.
- Information provided: starting and ending X and Y coordinates, the angle relative to the X axis, the X and Y distances, and the total distance between the two points.
- To manipulate the line, drag on the ending grip points.
- To delete the measuring line, drag it out of the image.
- To draw in 45 degree increments, hold down the SHIFT key as you drag the line cursor.
- This tool is similar to the DISTANCE command in AutoCAD.

Toning Tools  
To lighten, darken, saturate or unsaturate an image selection
- Toning tools allow you to edit and retouch images. The tools include:
  - Dodge  To lighten specific areas of an image
  - Burn  To darken specific areas of an image
  - Sponge  To subtly change the color saturation of an area
- The dodge and burn tools are based on a traditional photographer’s technique for regulating exposure on specific areas of a print. Photographers hold back light to lighten an area on the print (dodging) or increase the exposure to darken areas on a print (burning).
- The smudge, focus, and toning tools cannot be used with Bitmap or Indexed color mode images.

Type Tools  
To add text to an image
- After picking a starting location for your text, the Type Tool window will appear. Adjust the font information and enter the text.
- Any new text is created on it’s own layer, using the name of the text as the layer name. The letter T will appear to the right of the layer name.
- To manipulate or edit the text, click on the text layer itself. If you try to click on the text itself, the software thinks you’re making a new line of text.
- This is not the best tool for crisp lettering. If you will be taking this image file back into vector software (such as AutoCAD or Adobe Illustrator), create the text in that software.
Tutorial Instructions

How to Merge a Photo with an AutoCAD Rendering

**In AutoCAD**

*Open-*

Find and select the file called *photoshop.dwg* from the course CDrom

**Render** this drawing to a file. In the render box, select:

- Rendering Type: Photo Real
- Shadows: On
- Destination: File and push the More Options button
  
  File Output Configuration box: Change the filetype to TIFF and the colors to 24 bit.
  Push OK
  Push Render

In the Rendering File box, name the file *photoshop.tif* and save it to your P:drive (or floppy disk on A:drive )

*If you save the file as BMP, you will be limited when manipulating the bmp file in Photoshop.*

Close AutoCAD or leave it running in the background as you continue the exercise.

**In Photoshop**

Software location in MSU Microlabs:

Start Menu: Programs, Development Apps, Adobe, Photoshop 5, Photoshop 5

*To cancel:* Ctrl + D or choose *deselect* from the Select pull-down menu

*From the File pull-down menu, open the file called *photoshop.tif***

The layer window in Photoshop is located toward the right of the screen.

*If it is not visible, select show layers from the Windows pull-down menu.*

One layer should be visible (called background) and highlighted in blue. The "eye" icon to the left is the on/off switch and the paintbrush icon tells you that this is the current layer.

*From the File pull-down menu, open the file called *dog.tif* from the course CDrom***

**Zoom Tool**

*To view an image at various magnifications*

(See description below in Tutorial Instructions)

- By holding the mouse button and dragging the zoom tool across the image, a window will appear. When the mouse button is released, you will be zoomed closer to this area. This is equivalent of ACAD’s zoom, window feature.
- Holding down the ALT key will toggle between a (+) zoom tool and a (-) zoom tool.
- Holding down the CTRL key will also allow you to zoom. Push the (+) key to zoom closer or the (-) key to zoom back.
- The slidebar under the preview picture in the Navigator box also controls zooming.
- Additional zooming options are under the View pull-down menu.
- The keyboard shortcut is Z.
Always work zoomed closer to the image than the final desired size. If you want to see your final product at 80%, work at 160%.

**Pick on the zoom tool and pick on the dog file until it reaches 200%.** The zoom factor is displayed at the top of the screen.

**From the Image pull-down menu, select Image and then Adjust - Auto Levels.** This will adjust the colors as close to the original photo as possible. You may or may not notice an apparent change.

**Lasso Tools**

**To select an area of the image in various shapes**

- Lasso, polygon lasso and magnetic lasso tools allow you to draw a selection border with straight-edged and freehand segments.
- If you pick and hold on the icon, you will get a flyout menu with all 3 lasso options.
- The magnetic lasso tool will easily select the edges of an object if that object’s border is against a background of high contrast.
- The polygon lasso is used to select areas with straight edges.
- The
- Use the Alt key to select ending points of a straight-edged section.
- If you click close to the starting point of your lasso, the area will be enclosed. Likewise, double-clicking performs the same task.
- The keyboard shortcut is L.

If the circular lasso tool is displayed, put the arrow over it - - pick and hold. A flyout menu will appear with the other lasso options. **Select the polygonal lasso tool from the Tools box (the middle one).**

**Press the CAPSLOCK key to turn this lasso into a (+) sign.** This is easier to use for selecting your cut points. To return to the lasso icon later, push the CAPSLOCK key again.

**Make an outline around the dog.**

With the lasso tool, pick near the edge of the dog. Move the lasso to the next area and pick another point. Continue outlining the dog, picking points with the lasso tool. Don't worry about how precise you are - - you will clean up the outline later. When you return to your starting point, pick as close as you can to that initial starting point or double-click. This forms an enclosed outline.

**From the Select pull-down menu, select Inverse**

This will highlight everything BUT the dog.

**Press the delete key on your keyboard and the background will disappear.**

**From the Select pull-down menu, select Inverse again**

This will highlight the dog.

**From the Edit pull-down menu, select copy (or press Ctrl + C)**

**Pick on the photoshop file.** You may need to minimize the dog file.

**From the Edit pull-down menu, select paste (or press Ctrl + V)**

The dog appears inside the room and a new layer is created. Another way to do this is to drag and drop the dog into the room. Once you leave the first file, the software knows you are only making a copy (rather than cutting).

**With the cursor, pick the unnamed layer so it highlights blue (now the current layer).**

**In the Layer palette...**

Push the arrow pointing to the right to access the cascading menu.
Select **Layer Options...**
In the Layer box, name this layer **DOG**
Leave the opacity at 100% and the mode at Normal
Do not blend
Push OK
Move Tool  

To shift the location of a selected image

- You can move an object or layer to a new location within the existing file and between 2 or more open files.
- Use the selection marquee tool or lasso tool to first select the object or group of objects.
- When you move a selected area, the area underneath is replaced by the background color (usually white).
- Holding down the ALT key while using this move tool will COPY the select area (rather than move it).

With the move tool, pick the dog and move him anywhere within the room.

To scale an image:

From the Edit pull-down menu, select Transform and Scale

Use the arrow to select grip points. Drag the image bigger or smaller. Press enter to complete the transformation.

If you want him closer to the front, scale him larger. If you want him further in the back, scale him smaller.

Zoom closer to the edge of the dog to further cleanup the picture. After outlining a section to be removed with the lasso tool, push the delete key. Since you are working on a separate layer, the background will not be deleted or altered in any way. Continue smoothing out the image until you are satisfied.

Zoom back to 100% when you’re done.

After selecting the zoom tool, push and hold the ALT key. The zoom tool will change from a + sign to a - sign, allowing you to zoom the image smaller.

Make a duplicate layer of the dog.

With the cursor, pick the dog layer so it highlights blue (now the current layer)

In the Layer palette...

- Push the arrow pointing to the right to access the cascading menu.
- Select Duplicate Layer...
- In the Duplicate Layer box, rename this copy to DOG COPY
- Push OK

Zoom closer to the red dogtag - - maybe 600% or so.

Change the color of the red heart dogtag.

- Use one of the lasso tools to outline the dogtag.
- Right-click to get a shortcut menu.
- From this menu, select Layer Via Copy.
- In the layer box, you may rename this layer if desired. Make this the dogtag layer the current one.
- Turn off the background layer by picking on its “eye”.

Display the color swatches.

From the Window pull-down menu, select Show Color.

Eyedropper & Color Sampler Tools  

To select new foreground/background colors from existing image colors

- Pick on a pixel and the color is now the foreground color. You can then use another of the painting tools with that color.
- The color sampler tool is in the flyout menu. Pick and hold on the eyedropper to get the color sampler tool.
- You can adjust the color by clicking on the color sample itself or using the color palette
- Color can also be selected with the eyedropper in the Swatches palette.
Pick the eyedropper icon from the toolbar.
Place the eyedropper over a color of your choice and pick it with your mouse.

Notice that the foreground color sample in the toolbar (toward the bottom) has changed to this new color.

Paint Bucket Tool

To fill an area with a solid color

- The paint bucket will place the foreground color into a selected area or into pixels close in color.
- This tool cannot be used if your image is a BMP file. Change the mode to Indexed Color instead.
- Paint bucket options:
  - **Opacity**: Low numbers produce transparent color and high numbers produce solid color
  - **Tolerance**: Similarity in pixel color; low tolerance will fill pixels very similar to the exact pixel you selected; high tolerance will select a broader range of pixels
  - **Anti-aliased**: Smooths the edges of a filled selection

Select the paint bucket tool.
Place the paint bucket over the selected area of the dogtag (the area that you outlined with the lasso). As long as you are on the “dogtag” layer, the dogtag doesn’t have to be highlighted to be effected.

Click on the area of the dogtag. Notice the new color is being added. Continuing clicking in the area until the desired level of color saturation is achieved. Be careful not to click outside the dogtag or the background of that layer will be effected.

Turn on all layers by putting the “eye” next to the layer names.

Zoom back to 100%.

From the Image pull-down menu, select Image Size...

In the Image Size box, change the **width** under Print Size to 4. Notice that because there is a check mark beside “Constrain Proportions”, the height is changing proportional to the width.

Push OK

### FILTERS

Filters are effects and can be either dramatic or subtle.

- **Artistic**: Strange artsy effects
- **Blur**: Smudge or blend edges (i.e. putting a picture of yourself into your own ACAD rendering)
- **Brush strokes**: Painting on top of the photo
- **Distort**: Twisting and turning the photo
- **Noise**: Effects like shaking gravel on the photo to scratch it
- **Pixelate**: Mosaics and stained glass effects
- **Render**: Make believable merging of 2 photos
- **Sharpen**: Photo edges are crisper and colors are altered
- **Sketch**: Emulates hand-drawing
- **Stylize**: Trendy photo techniques
- **Texture**: Good for website backgrounds
- **Video**: Colorizing a black and white film
- **Other**: Ability to fix dithering problems

You may experiment with filters. Always make sure you have saved a backup copy of your file or are working on a duplicate layer.
that you can delete in case the filter effect is not what you originally intended.

To have a consistent light direction after merging 2 photos:
Be on the layer of the 2nd photo - the one in the foreground - the dog and not the dog copy.

This process is memory intensive so it may crash the system so....

.....save before continuing!

Turn off the dog copy layer.

From the Filter pull-down menu, select Render - Lighting Effects

Click and drag ellipse to duplicate the sun angle from the background photo. One light source is coming through the window to the left and another light source is coming from the front of the room and bouncing off the wall directly behind the desk. You have your choice of light directions.

The smaller the ellipse, the more intense the light.
  Style:  Default
  Light type:  Spotlight

The color box next to Spotlight controls the color of the light - this should remain white.

You may need to increase the intensity and focus.

Be careful! Don’t ruin your rendering with “phony” lighting effects!

Saving an image:
PSD is the extension for Photoshop. This file will retain all the layer settings. Saving a copy of your PSD file compresses all your layers into one image file. This also reduces the size of the file. Save the PSD file and keep it! You may need to return to this PSD file to make future changes. Once you create a copy, the layers are compressed together and basically - deleted.

From the File pull-down menu, select Save a Copy...
  In the Save a Copy box, label the file with the first 6 letters of your last name _ 6
  (For example, my uploaded files would look like this - - bender_6)
  Change the saveas type to TIFF and save it to your P:drive (or floppy disk or A:drive)
  Push OK
  In the TIFF Options box, select IBM PC and push OK
MODULE R10

Project Guidelines
AN EXAMPLE:

PROJECTS WILL VARY

TOOLS NEEDED TO COMPLETE THE PROJECT:

- Scanned photo(s) of your choice
- Drawing file: a 3D drawing of your choice
INSTRUCTIONS NEEDED TO COMPLETE THE PROJECT:

The purpose of this assignment is to:

- Demonstrate your comprehension of computer-generated rendering by creating a 3-dimensional advanced CAD synthesis project of your choice

PROJECT 6 SUBMISSION

Individual Rendering Project Guidelines

Minimum project requirements:

- Use of ONE standard material
- Use of ONE procedural material (i.e. wood, granite, marble)
- Use of ONE pendant OR spotlight
- Use of distant light
- Use of shadows
- Demonstrate correct orientation and scaling of materials
- Include at least ONE “photo” into your rendering (scan a photo and manipulate it in Photoshop)

You may render any view you’d like such as a plan view, elevation or perspective. For creating a perspective, please review the DVIEW command in module 11 of Using AutoCAD in Your Job: Part I (your text from HED 240).

You will be evaluated on the cohesion of your rendering skills, rather than the design and creativity of the 3D solid model. If you do not have a 3D solid model, one will be provided for you.

To submit your drawing, render your drawing with the Photo Real option.
Change the destination to File.
Push the More Options... button.
In the File Output Configuration box, change the File Type to TIFF. Under Colors, select 32 bit.
Push OK.
Push Render.

In the Rendering File box, name your rendering with a name of your choice.

Open this file in Adobe Photoshop and manipulate it as needed.
Open other scanned images or photos and “add” them to your rendered drawing by using the COPY command in Photoshop (see the exercise in Module R9).

When you are done in Photoshop, go to the File pull-down menu and select Save a Copy...
In the Save a Copy box, label the file with the first 6 letters of your last name _ 6
(For example, my uploaded files would look like this - - bender_6)
Change the saveas type to TIFF and save it to your P:drive (or floppy disk or A:drive)
Push OK
In the TIFF Options box, select IBM PC and push OK

See the MSU CAD Technologies website, http://cad.msu.edu/ Tools section, for detailed instructions on uploading.

Upload this file by NOON on lecture day.
See the course outline for specific due dates.
APPENDIX

3D Solids
Review & 3D Solids

It is to your benefit to review the concepts and commands associated with moving objects in 3D space and presenting them in paper space. You will be using these commands throughout the rest of the project.

**Coordinates**

3 ways to enter information based on the Cartesian Coordinate System

- Absolute: x,y,z
- Relative: @x,y
- Polar: @length<angle

**Copy in 3D**

Creates duplicate objects in different planes

**Move in 3D**

Alters the location of selected objects in different planes

- Remember how to...use the origin (0,0,0) as the basepoint and alter the necessary coordinate as the second point of displacement (x,y,z)?

**Dist**

Calculates the distance and direction between two points

- Remember how to...get the distance and direction between two selected points?

**Ucs**

Controls all available User Coordinate Systems

- Remember how to...restore saved coordinate system locations and alter the location of the UCS?

**DDvpoint**

Specifies the direction to view the model

- Remember how to...alter the view of the model through the pull-down menu preset options (under View)?

**List**

Displays information about selected objects

- Remember how to...display information about any object you select?

**Mspace**

Switches from paper space to a model space viewport

- Remember how to...switch to the model while on the paperspace presentation sheet?

**Mview**

Creates and manipulates viewports in paperspace

- Remember how to...create new viewing windows for your presentation?

**Plan**

Displays the plan view

- Remember how to...display the drawing flat on the floor?

**Pspace**

Switches from a model space viewport to paper space

- Remember how to...switch to the paper while on the paperspace presentation sheet?

**Tilemode**

Passage from model space to paper space

- Remember how to...toggle between the model space side of the computer versus the paper space side?

**View**

Saves, restores and manipulates existing views

- Remember how to...save and restore interesting views?

**Vports**

Splits the display area into tiled viewports

- Remember how to...have a single viewport or multiple viewports?

**Dview**

Creates parallel projections and perspectives

- Remember how to...create perspective, elevation and section views?
3-DIMENSIONAL SOLID OBJECTS

- Drawings usually progress through various stages such as wireframe drawing and then the application of solid surfaces. But the ultimate 3-dimensional experience is with 3d solid objects.
- 3D solids have mass and volume. They can be combined, intersected, and overlapped.
- When you explode a solid, the sides of it return to regions or faces. If you explode one more time, the regions will turn into individual entities like lines and arc. When this happens, the object loses its 3-dimensional solid properties.

Box

A three-dimensional solid box

- A 3D box is a solid, six-sided form.
- The first corner of the box is the base point for rotation.
- A cube can be created by choosing C for cube and entering a value for the length.
- Once a box is created, you cannot alter its size by the stretch or change commands (use the scale command).
- The center option will allow you to locate a center point for the box. This is the center in the X, Y, and Z directions.
- When creating a rectangular box, the length is in the X direction, the width is in the Y direction and the height is in the Z direction. Be careful where your UCS is located!

Rotate3d

Rotates an object or series of objects in three-dimensional space

- A three-dimensional axis will need to be defined as your rotation axis. This can be defined by selecting points visually or with OSNAP options, or entering absolute coordinates.
- All options will request you to define a rotation angle or a reference angle.
- 4 options:
  - Axis by object: Aligns the axis of rotation with an existing object
  - Last: Uses the axis of rotation last selected
  - View: Aligns the axis of rotation with the current viewport’s viewing direction
  - 2points: Defines the axis of rotation with 2 specified points
  - XY/YZ/XZ: Aligns the axis of rotation with the X, Y, or Z axis, which passes through a selected point

3darray

Create a three-dimensional array

- Rectangular: A rectangular array produces a number of rows, columns and levels in a matrix format.
- You must have at least one row, column, or level for this command to function properly (ex: bookcase shelving).

Cylinder

Creates a solid 3D cylinder

- The elliptical option will form a cylinder with an elliptical base.
- This base can be defined by:
  - 3 points forming the major and minor axes
  - A center point and the radius of each axis
**Cone**  
*A cone-shaped solid*

- The cone’s base can be defined by either its radius or its diameter.
- The elliptical option will form a cylinder with an elliptical base. This base can be defined by:
  - 3 points forming the major and minor axes
  - A center point and the radius of each axis
- 2 options for creating the top of a cone:
  - **Apex**: defines the height and orientation based on the current Z axis; the apex point may or may not be aligned with the center of the cone, thus allowing you to form skewed cones
  - **Height**: defines the height along the current Z axis; positive numbers go along the positive Z axis and negative numbers go along the negative Z axis (produces an upside-down cone)

**Sphere**  
*A spherical solid*

- The sphere can be defined by its center point and either its radius or its diameter.
- The sphere is created so its central axis is parallel to the Z axis of the current UCS.
- The center of the sphere is its location in the X, Y, and Z directions.

**Isolines**  
*A system variable that determines the number of lines visible on a solid object*

- Isolines can be set from 0 to 2047.
- The default setting on most drawing files is 4.
- The higher the number, the smoother the appearance of your solid objects in hide, shade, or render. However, the smoother it looks, the longer the software will take to regenerate the drawing on screen.

**Torus**  
*A donut-shaped solid*

- A torus is constructed parallel to the XY plane of the current UCS.
- The torus diameter or radius is measured from the center point to the outside edge. The tube diameter or radius is the distance between the inside and outside edges.
- The tube diameter or radius may be less than or equal to the torus diameter or radius. It may also be greater than the torus diameter, which is referred to as a self-intersecting torus.
- If both radii are positive and the tube diameter is greater than the torus diameter, the torus resembles a sphere with indentations at each pole.
- If the torus radius is negative and the tube radius is greater than the torus radius, the torus resembles a sphere pointed at each pole.

**Facetres**  
*A system variable that controls the smoothness of solid objects and their hidden lines*

- Facetres can be set from 0.01 to 10.
- The default setting on most drawing files is 0.5.
- The higher the number, the smoother the appearance of your solid objects in hide, shade or render. However, the smoother it looks, the longer the software will take to regenerate the drawing on screen.
**Wedge**  
*A right angle wedge-shaped solid*

- The sloped face tapers along the X axis.
- The first corner of the wedge is the base point for rotation.
- The base of a wedge is parallel to the XY plane of the current UCS.
- The height of a wedge can be in the positive or negative Z direction.
- The center option will allow you to locate a center point for the wedge. This is the center in the X, Y, and Z directions.
- The cube option will create a wedge with equal length sides.
- The sloping edge faces the first corner point that selected and tapers along the X axis.

**Mirror3d**  
*Mirrors objects around a plane*

- The original object can be copied or deleted after the mirroring process is completed.
- If using the 3points option, it may be helpful to put the drawing in an isometric view.
- 6 ways to mirror:
  - 3points: Define 3 points to form the mirroring plane
  - Object: Select an existing circle, arc or 2D polyline segment for the mirroring plane
  - Last: Continues mirroring by using the last selected mirroring plane
  - Zaxis: Select a point on a plane and a Zaxis point
  - View: Aligns the mirroring plane with the current view
  - XY/YZ/ZX: Aligns the mirroring plane by specifying a point in the X, Y, or Z directions

**Extrude**  
*Creates unique solid shades by extruding an existing two-dimensional object*

- One object or a multitude of objects can be extruded (stretched as a solid) in the Z direction of the current UCS by defining the object and assigning an extrusion height.
- AutoCAD ignores a polyline’s width.
- A polyline must have at least 3 vertices to be extruded.
- Objects you can extrude: closed polylines, polygons, circles, ellipses, closed splines, donuts and regions.
- Objects you cannot extrude: crossing polylines, self-intersecting polylines, and objects contained within a block or nested block.
- An extrusion taper angle of zero will not taper the object in the Z direction. A taper angle greater than zero tapers in from the base object. A taper angle less than zero tapers out from the base object.
- The Path option will allow you to select a path or direction of the extrusion. The path should not lie on the same plane as the object(s) to be extruded, though one of the endpoints of the path should be on the plane of the profile.
**Revolve**

*Forms a solid by rotating a 2-dimensional object about an axis*

- Objects that can be revolved include polylines, circles, ellipses, polygons, donuts and regions.
- Objects rotate around a defined axis of revolution. This axis may be created by selecting points on screen or with coordinates, or creating a line to represent the axis and using this as the object to revolve around.
- Objects rotate in the positive direction (clockwise).
- You cannot revolve blocks or objects contained within a block; use Explode to un-block an object or group of objects.
- You can revolve only one object at a time.

**Slice**

*Cuts through solids with a plane*

- The sliced region or solid will be split into two parts. You can retain both sides or one desired side of the cutting plane. It is suggested that you retain both sides and erase the undesirable side later.
- The layer and color properties of the sliced solid are retained.
- 5 options:
  - Object Aligns the cutting plane with an existing polyline, circle, arc or ellipse
  - Zaxis The cutting plane is defined by specifying a point on the Z axis of the XY plane
  - View Aligns the cutting plane with the current viewpoint
  - 3points The cutting plane is defined by selecting 3 specific
  - XY/YZ/ZX Aligns the cutting plane with the current UCS X, Y, or Z direction

**Intersect**

*Creates a composite object from the intersection of two or more solids or regions*

- The order of selection is unimportant.
- The regions or solids may be in any plane.
- The composite solid or region includes the volume and mass enclosed by all the selected solids or regions.
- The intersect command will not work after issuing the hide, shade or render commands (issue the zoom or regen command to regenerate the drawing).
- Once two or more objects are “intersected”, they CANNOT be separated. You can a) use the undo command, or b) erase the composite object and begin again.
- The parts of the solids that disappeared when intersected CANNOT be restored without using the Undo command.
- If the solids or regions are on separate layers, the composite will be on the layer of the object selected FIRST. The color of the object, if separate and not controlled BYLAYER, will be maintained after issuing the union command.

**Subtract**

*Joins regions or solids by subtraction*

- The Subtract command forms a composite which contains the area and volume of two or more solid objects combined together by SUBTRACTION.
- Objects selected can lie on the same or different planes.
- The first object selected will dictate the layer and color of the composite.
- The subtract command CANNOT be reversed once a drawing has been saved. The solids can either be exploded back to their original wireframe representations, or erased completely.
**Union**  
*Joins regions or solids by addition*
- The Union command forms a composite which contains the area and volume of two or more solid objects combined together by ADDITION.
- Objects selected can lie on the same or different planes.
- The first object selected will dictate the layer and color of the composite.
- The union command CANNOT be reversed once a drawing has been saved. The solids can either be exploded back to their original wireframe representations, erased completely, or you can issue the Undo command.

**3Dorbit**  
*Interactive 3D viewing*
- By clicking and dragging with your mouse, you can twist, turn and spin a 3D model. An endless number of viewpoints is possible.
- You can manipulate any view, including plan, elevation, section, perspective and isometric views.
- 3Dorbit displays on screen a circle divided into 4 quadrants. This is called an arcball.
- By picking on the 4 quadrant points or by picking outside the arcball, you can rotate the view around the X axis, the Y axis or the XY plane.
- You can view the entire drawing model or you can select particular objects within the model to view.
- By right-clicking on the screen while in 3Dorbit, you can access any of the options listed below.
- **Options:**
  - Pan: Shifts the view in real-time without distortion
  - Zoom: Shifts the view in real-time with distortion
  - Orbit: Rotates the view around the arcball
  - More: Sets and adjusts the clipping planes plus other options
  - Projection: Rotates the view around parallel or perspective planes
  - Shading models: Hides and shades the model during rotation
  - Visual aids: Controls compass, grid and ucsicon settings
  - Reset view: Returns to the original view from the beginning of the command
  - Preset views: Picks one of 10 orthogonal or isometric views

**NOTE:** Related 3D commands include: 3Dclip, 3Ddistance, 3Dpan, 3Dswivel and 3Dzoom.